Initial import to Tizen
[profile/ivi/sphinxbase.git] / packaging / sphinxbase.spec
1 Name:       sphinxbase
2 Version:    0.7
3 Release:    1
4 Group:      System/Libraries
5 License:    BSD
6 URL:        http://www.pocketsphinx.org/
7 Summary:    Speech Recognition Engine
8 Source:     http://sourceforge.net/projects/cmusphinx/files/%{name}/%{version}/%{name}-%{version}.tar.gz
9 BuildRequires:  bison
10 BuildRequires:  pkgconfig(python)
11 BuildRequires:  python-setuptools
12
13 %description
14 Sphinxbase is a common library for CMU Sphinx voice recognition products.
15 This package does not provide voice recognition by itself.
16
17 %package devel
18 Summary:        Header and other development files for sphinxbase
19 Group:          Development/Libraries
20 Requires:       %{name}-libs = %{version}-%{release}
21
22 %description devel
23 Header files and other development files for sphinxbase.
24
25 %package libs
26 Summary:        Libraries for sphinxbase
27 Group:          Development/Libraries
28
29 %description libs
30 The libraries for sphinxbase.
31
32 %package python
33 Summary:        Python interface to sphinxbase
34 Group:          Development/Libraries
35 Requires:       %{name}-libs = %{version}-%{release}
36
37 %description python
38 Python interface to sphinxbase.
39
40 %prep
41 %setup -q
42
43 %build
44 %configure --disable-static --disable-rpath
45
46 make %{?_smp_mflags}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
51 make install DESTDIR=$RPM_BUILD_ROOT
52 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
53
54 # Install the man pages
55 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
56 cp -p doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post libs -p /sbin/ldconfig
62
63 %postun libs -p /sbin/ldconfig
64
65 %files
66 %defattr(-,root,root,-)
67 %{_bindir}/*
68 %{_mandir}/man1/*
69
70 %files devel
71 %defattr(-,root,root,-)
72 %{_includedir}/sphinxbase
73 %{_libdir}/libsphinxad.so
74 %{_libdir}/libsphinxbase.so
75 %{_libdir}/pkgconfig/sphinxbase.pc
76
77 %files libs
78 %defattr(-,root,root,-)
79 %doc AUTHORS ChangeLog COPYING NEWS README
80 %{_libdir}/libsphinxad.so.*
81 %{_libdir}/libsphinxbase.so.*
82
83 %files python
84 %defattr(-,root,root,-)
85 %{python_sitearch}/*
86 %changelog