Initial packaging of SmartDeviceLink.
[profile/ivi/smartdevicelink.git] / packaging / smartdevicelink.spec
1 Name:          smartdevicelink
2 Summary:       GENIVI SmartDeviceLink (SDL)
3 Version:       0.1
4 Release:       1
5 Group:         Network & Connectivity/Connection Management
6 License:       BSD-3-Clause
7 URL:           http://projects.genivi.org/smartdevicelink/
8 Source:        %{name}-%{version}.tar.gz
9 Source1001:    %{name}.manifest
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(bluez)
12 BuildRequires: doxygen
13
14 %description
15 SmartDeviceLink is a project which intends to standardize and wrap the
16 many in-vehicle interfaces which may exist in the automotive
17 context. The end goal is to provide an expandable software framework
18 to both mobile application developers and automotive head unit
19 creators for the creation of brought-in applications that appear
20 integrated onto a head unit.
21
22 Many in-vehicle HMIs use different colors, templates, icons, fonts,
23 voice systems and input methods for their infotainment systems. With
24 SmartDeviceLink, a template-based approach is provided by the
25 automotive head unit and allows for different HMI frameworks to follow
26 a specific set of guidelines ensuring a consistent experience to a
27 developer. By leveraging this common API and a brought-in device,
28 automotive head units leverage the complete power of the brought-in
29 device using the APIs being executed on the mobile device.
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34 cp %{SOURCE1001} .
35
36 %build
37 cd SDL_Core
38 %cmake .
39 make %{?_smp_mflags}
40
41 %install
42 # Don't run "make install".  We only care about the core SDL binary,
43 # and HMI related files.
44 install -m 0755 SDL_Core/src/appMain/smartDeviceLinkCore %{buildroot}%{_bindir}
45 install -m 0644 SDL_Core/src/appMain/log4cplus.properties %{buildroot}%{_sysconfdir}/%{n
46 ame}
47 install -m 0644 SDL_Core/src/appMain/audio.8bit.wav %{buildroot}%{_datadir}/%{name}
48 cp -R SDL_Core/src/components/HMI %{buildroot}%{_datadir}/%{name}
49
50 %clean
51
52 #%post -p /sbin/ldconfig
53
54 #%postun -p /sbin/ldconfig
55
56 %files
57 %manifest %{name}.manifest
58 %license LICENSE
59 %{_bindir}/smartDeviceLinkCore
60 %{_sysconfdir}/smartdevicelink/log4cplus.properties
61 %{_datadir}/%{name}/*
62
63 #%%files doc