fbd182ab02bb2ccc2db454217103ccb2f38a01f6
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
1 Name:       smartcard-service
2 Summary:    Smartcard Service FW
3 Version:    0.1.19
4 Release:    1
5 Group:      libs
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1:    smartcard-service-server.init
9
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(security-server)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(aul)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(dbus-glib-1)
17 BuildRequires: pkgconfig(pkgmgr)
18 BuildRequires: pkgconfig(pkgmgr-info)
19 BuildRequires: cmake
20 BuildRequires: gettext-tools
21
22 Requires(post):   /sbin/ldconfig
23 Requires(post):   /usr/bin/vconftool
24 requires(postun): /sbin/ldconfig
25
26 %description
27 Smartcard Service FW.
28
29 %prep
30 %setup -q
31
32 %package    devel
33 Summary:    Smartcard service
34 Group:      Development/Libraries
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 smartcard service.
39
40 %package -n smartcard-service-common
41 Summary:    Common smartcard service
42 Group:      Development/Libraries
43 Requires:   %{name} = %{version}-%{release}
44
45 %description -n smartcard-service-common
46 common smartcard service.
47
48 %package -n smartcard-service-common-devel
49 Summary:    Common smartcard service
50 Group:      Development/Libraries
51 Requires:   %{name} = %{version}-%{release}
52 Requires:   smartcard-service-common = %{version}-%{release}
53
54 %description -n smartcard-service-common-devel
55 common smartcard service.
56
57 %package -n smartcard-service-server
58 Summary:    Server smartcard service
59 Group:      Development/Libraries
60 Requires:   %{name} = %{version}-%{release}
61
62 %description -n smartcard-service-server
63 smartcard service.
64
65
66 %build
67 mkdir obj-arm-limux-qnueabi
68 cd obj-arm-limux-qnueabi
69 %cmake .. -DUSE_AUTOSTART=1 # daemon will be started when client makes instance by DBUS
70
71 %install
72 cd obj-arm-limux-qnueabi
73 %make_install
74 %__mkdir -p  %{buildroot}/etc/init.d/
75 %__mkdir -p  %{buildroot}/etc/rc.d/rc3.d/
76 %__mkdir -p  %{buildroot}/etc/rc.d/rc5.d/
77
78 %post
79 /sbin/ldconfig
80 ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc3.d/S79smartcard-service-server
81 ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc5.d/S79smartcard-service-server
82
83 %postun
84 /sbin/ldconfig
85 rm -f /etc/rc.d/rc3.d/S79smartcard-service-server
86 rm -f /etc/rc.d/rc5.d/S79smartcard-service-server
87
88
89 %post -n smartcard-service-common
90 /sbin/ldconfig
91
92 %postun -n smartcard-service-common
93 /sbin/ldconfig
94
95
96 %files
97 %manifest smartcard-service.manifest
98 %defattr(-,root,root,-)
99 %{_libdir}/libsmartcard-service.so.*
100
101 %files  devel
102 %manifest smartcard-service-devel.manifest
103 %defattr(-,root,root,-)
104 %{_includedir}/smartcard-service/*
105 %{_libdir}/libsmartcard-service.so
106 %{_libdir}/pkgconfig/smartcard-service.pc
107
108 %files -n smartcard-service-common
109 %manifest smartcard-service-common.manifest
110 %defattr(-,root,root,-)
111 %{_libdir}/libsmartcard-service-common.so.*
112
113 %files -n smartcard-service-common-devel
114 %manifest smartcard-service-common-devel.manifest
115 %defattr(-,root,root,-)
116 %{_includedir}/smartcard-service-common/*
117 %{_libdir}/libsmartcard-service-common.so
118 %{_libdir}/pkgconfig/smartcard-service-common.pc
119
120 %files -n smartcard-service-server
121 %manifest smartcard-service-server.manifest
122 %defattr(-,root,root,-)
123 %{_bindir}/smartcard-daemon
124 /usr/share/dbus-1/services/org.tizen.smartcard_service.service
125