Remove gcov rpm package
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
1 Name:       smartcard-service
2 Summary:    Smartcard Service FW
3 Version:    0.1.59
4 Release:    0
5 Group:      Network & Connectivity
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    smartcard-service.service
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gio-unix-2.0)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(aul)
14 BuildRequires: pkgconfig(openssl1.1)
15 BuildRequires: pkgconfig(pkgmgr)
16 BuildRequires: pkgconfig(pkgmgr-info)
17 BuildRequires: pkgconfig(cynara-client)
18 BuildRequires: pkgconfig(cynara-creds-gdbus)
19 BuildRequires: pkgconfig(cynara-session)
20 BuildRequires: pkgconfig(capi-system-info)
21
22 BuildRequires: python
23 BuildRequires: python-xml
24
25 Requires(post):   /sbin/ldconfig
26 Requires(postun): /sbin/ldconfig
27 Requires:         %{name}-common = %{version}-%{release}
28
29 %if 0%{?gtests:1}
30 BuildRequires:  pkgconfig(gmock)
31 %endif
32
33 %description
34 Smartcard Service FW.
35
36 %package    common
37 Summary:    common smartcard service
38 Group:      Development/Libraries
39
40
41 %description common
42 common smartcard service.
43
44 %package    common-devel
45 Summary:    common smartcard service
46 Group:      Development/Libraries
47 Requires:   %{name}-common = %{version}-%{release}
48
49
50 %description common-devel
51 common smartcard service.
52
53 %prep
54 %setup -q
55
56
57 %build
58 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DBUILD_GTESTS=%{?gtests:1}%{!?gtests:0}
59
60 %install
61 %make_install
62
63 mkdir -p %{buildroot}/usr/lib/systemd/system/
64 cp -af %{SOURCE1} %{buildroot}/usr/lib/systemd/system/
65
66 mkdir -p %{buildroot}/etc/dbus-1/system.d/
67 cp -af %{_builddir}/%{name}-%{version}/packaging/org.tizen.SmartcardService.conf %{buildroot}/etc/dbus-1/system.d/
68
69 %files
70 %manifest %{name}.manifest
71 %defattr(-,root,root,-)
72 %{_bindir}/smartcard-daemon
73 %{_sysconfdir}/dbus-1/system.d/org.tizen.SmartcardService.conf
74 %{_datadir}/dbus-1/system-services/org.tizen.SmartcardService.service
75 /usr/lib/systemd/system/%{name}.service
76 %if 0%{?gtests:1}
77 %{_bindir}/gtest*
78 %endif
79 %license LICENSE.APLv2
80
81 %files common
82 %manifest %{name}-common.manifest
83 %defattr(-,root,root,-)
84 %{_libdir}/lib%{name}-common.so.*
85 %license LICENSE.APLv2
86
87 %files common-devel
88 %manifest %{name}-common-devel.manifest
89 %defattr(-,root,root,-)
90 %{_includedir}/%{name}-common/*
91 %{_libdir}/lib%{name}-common.so
92 %{_libdir}/pkgconfig/%{name}-common.pc