Initial commit
[platform/core/connectivity/smartcard-plugin-usb.git] / packaging / smartcard-plugin-usb.spec
1 Name:             smartcard-plugin-usb
2 Summary:          Smartcard plugin usb
3 Version:          0.0.1
4 Release:          0
5 Group:            Network & Connectivity/Smartcard
6 License:          Apache-2.0
7 Source0:          %{name}-%{version}.tar.gz
8 BuildRequires:    cmake
9 BuildRequires:    pkgconfig(glib-2.0)
10 BuildRequires:    pkgconfig(dlog)
11 BuildRequires:    pkgconfig(smartcard-service-common)
12 BuildRequires:    pkgconfig(libpcsclite)
13 Requires(post):   /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16
17 %description
18 Smartcard Service plugin usb
19
20 %prep
21 %setup -q
22
23 %build
24 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
25 %ifarch aarch64 x86_64
26          -DTIZEN_ARCH_64=1 \
27 %endif
28
29 %install
30 %make_install
31
32 %post -p /sbin/ldconfig
33
34 %postun -p /sbin/ldconfig
35
36 %files
37 %manifest %{name}.manifest
38 %license LICENSE.APLv2
39 %defattr(-,root,root,-)
40 %{_libdir}/se/lib*.so