fix build errors
[platform/core/connectivity/smartcard-plugin-nfc.git] / packaging / smartcard-plugin-nfc.spec
1 Name:             smartcard-plugin-nfc
2 Summary:          Smartcard plugin nfc
3 Version:          0.0.4
4 Release:          0
5 Group:            libs
6 License:          Apache License, Version 2.0
7 Source0:          %{name}-%{version}.tar.gz
8 Source1001:     smartcard-plugin-nfc.manifest
9 BuildRequires:    pkgconfig(glib-2.0)
10 BuildRequires:    pkgconfig(dlog)
11 BuildRequires:    nfc-client-lib-devel
12 BuildRequires:    pkgconfig(smartcard-service-common)
13 BuildRequires:    cmake
14 BuildRequires:    gettext-tools
15 Requires(post):   /sbin/ldconfig
16 Requires(post):   /usr/bin/vconftool
17 requires(postun): /sbin/ldconfig
18 %description
19 Smartcard Service plugin nfc
20
21 %prep
22 %setup -q
23 cp %{SOURCE1001} .
24
25
26 %package    devel
27 Summary:    smartcard service
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 smartcard service.
33
34
35 %build
36 mkdir obj-arm-limux-qnueabi
37 cd obj-arm-limux-qnueabi
38 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
39 #make %{?jobs:-j%jobs}
40
41
42 %install
43 cd obj-arm-limux-qnueabi
44 %make_install
45 mkdir -p %{buildroot}/usr/share/license
46 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-plugin-nfc %{buildroot}/usr/share/license/
47
48 %post
49 /sbin/ldconfig
50
51
52 %postun
53 /sbin/ldconfig
54
55 %files
56 %manifest %{name}.manifest
57 %defattr(-,root,root,-)
58 /usr/lib/se/lib*.so
59 /usr/share/license/smartcard-plugin-nfc