Tizen 2.1 base
[platform/adaptation/emulator/emulator-plugin-accel-filter.git] / packaging / sf-plugin-filter-accel-emul.spec
1 #git:/slp/pkgs/e/emulator-plugin-accel-filter
2 Name: sf-plugin-filter-accel-emul
3 Version: 0.2.11
4 Release: 1
5 Summary: Accel simulator filter plugin for sensor framework
6 Group: System Environment/Libraries
7 License: GNU2
8 Source0: %{name}-%{version}.tar.gz
9 Source1001: packaging/sf-plugin-filter-accel-emul.manifest
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(sf_common)
12
13 %description
14
15 %prep
16 %setup -q
17
18 %build
19 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--as-needed"    
20     
21 LDFLAGS="$LDFLAGS" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
22
23 make
24
25 %install
26 rm -rf %{buildroot}
27 %make_install
28
29 %clean
30 make clean
31 rm -rf CMakeCache.txt
32 rm -rf CMakeFiles
33 rm -rf cmake_install.cmake
34 rm -rf Makefile
35 rm -rf install_manifes.txt
36 rm -rf *.so
37
38 %post
39
40 %postun
41
42 %files
43 %defattr(-,root,root,-)
44 %{_prefix}/lib/sensor_framework/*.so*
45
46 %changelog