5 Summary: A set of system configuration and setup files
6 Url: https://fedorahosted.org/setup/
8 Source0: %{name}-%{version}.tar.bz2
9 Source1001: setup.manifest
14 The setup package contains a set of important system configuration and
15 setup files, such as passwd, group, and profile.
26 # Run any sanity checks.
30 cp -ar files/* %{buildroot}
31 touch %{buildroot}%{_sysconfdir}/environment
32 chmod 0644 %{buildroot}%{_sysconfdir}/environment
33 chmod 0400 %{buildroot}%{_sysconfdir}/{shadow,gshadow}
34 touch %{buildroot}%{_sysconfdir}/fstab
35 touch %{buildroot}%{_sysconfdir}/mtab
38 rm %{buildroot}/%{_sysconfdir}/filesystems
40 #throw away useless and dangerous update stuff until rpm will be able to
41 #handle it ( http://rpm.org/ticket/6 )
43 for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
44 os.remove("/etc/"..name..".rpmnew")
47 %manifest setup.manifest
48 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/passwd
49 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/group
50 %verify(not md5 size mtime) %attr(0000,root,root) %config(noreplace,missingok) %{_sysconfdir}/shadow
51 %verify(not md5 size mtime) %attr(0000,root,root) %config(noreplace,missingok) %{_sysconfdir}/gshadow
52 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/services
53 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/exports
54 %config(noreplace) %{_sysconfdir}/aliases
55 %config(noreplace) %{_sysconfdir}/environment
56 %config(noreplace) %{_sysconfdir}/host.conf
57 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/hosts
58 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/hosts.allow
59 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/hosts.deny
60 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/motd
61 %config(noreplace) %{_sysconfdir}/printcap
62 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/inputrc
63 %config(noreplace) %{_sysconfdir}/bashrc
64 %config(noreplace) %{_sysconfdir}/profile
65 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/protocols
66 %attr(0600,root,root) %config(noreplace,missingok) %{_sysconfdir}/securetty
67 %config(noreplace) %{_sysconfdir}/csh.login
68 %config(noreplace) %{_sysconfdir}/csh.cshrc
69 %dir %{_sysconfdir}/profile.d
70 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/shells
71 %ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
72 %ghost %attr(0600,root,root) %verify(not md5 size mtime) /var/log/faillog
73 %ghost %attr(0664,root,utmp) %verify(not md5 size mtime) /var/log/wtmp
74 %ghost %attr(0600,root,root) %verify(not md5 size mtime) /var/log/btmp
75 %ghost %attr(0664,root,utmp) %verify(not md5 size mtime) /run/utmp
76 %ghost %verify(not md5 size mtime) %config(noreplace,missingok) %{_sysconfdir}/fstab
77 %ghost %verify(not md5 size mtime) %config(noreplace,missingok) %{_sysconfdir}/mtab