Initial implementation
[profile/ivi/setup-mbr-ivi.git] / packaging / setup-mbr-ivi.spec
1 Name:           setup-mbr-ivi
2 Version:        1.0
3 Release:        10
4 License:        GPL-2.0
5 Summary:        Legacy BIOS boot setup
6 Url:            http://www.tizen.org
7 Group:          System/Configuration
8 Source:         %{name}_%{version}.tar.gz
9 Requires:       syslinux-extlinux
10 Requires:       /usr/bin/dd
11 Requires:       /usr/bin/sed
12 Requires:       /usr/bin/sort
13 Requires:       /usr/bin/grep
14 Requires:       /usr/bin/printf
15 ExclusiveArch:  %{ix86} x86_64
16
17 %description
18 Configure the system to support booting on legacy BIOS platforms.
19
20 ###
21 ### PREP
22 ###
23 %prep
24 %setup -q -n %{name}-%{version}
25
26 ###
27 ### INSTALL
28 ###
29 %install
30 install -d %{buildroot}/%{_sbindir}
31 install -m755 setup-mbr-ivi %{buildroot}/%{_sbindir}
32 install -m755 setup-extlinux-conf %{buildroot}/%{_sbindir}
33
34 ###
35 ### CLEAN
36 ###
37 %clean
38 rm -rf %{buildroot}
39
40 ###
41 ### FILES
42 ###
43 %files
44 %defattr(-,root,root)
45 %{_sbindir}/setup-mbr-ivi
46 %{_sbindir}/setup-extlinux-conf