TIVI-1924: Initial commit of IVI settings daemon.
[profile/ivi/settings-daemon.git] / packaging / settingsd.spec
1 Name:          settingsd
2 Summary:       Tizen IVI Settings Daemon
3 Version:       0.1
4 Release:       1
5 Group:         Application Framework/Settings
6 License:       LGPL-2.1
7 URL:           http://tizen.org/
8 Source:        %{name}-%{version}.tar.gz
9 Source1:       settingsd.service
10 Source2:       settingsd.socket
11 Source1001:    %{name}.manifest
12 BuildRequires: pkgconfig(gio-2.0)
13 BuildRequires: pkgconfig(json-glib-1.0)
14 BuildRequires: pkgconfig(libwebsockets)
15 BuildRequires: doxygen
16 BuildRequires: boost-devel
17
18 %define pkgincludedir %{_includedir}/%{name}
19 %define pkglibdir %{_libdir}/%{name}
20 %define _unitdir_user /usr/lib/systemd/user
21
22
23 %description
24 The settings daemon provides native backend support for settings
25 related operations initiated by the Tizen IVI Settings app.  In
26 particular, it fills gaps in functionality required by the Settings
27 app that are not available in any of the Web APIs available in Tizen
28 IVI.
29
30 Settingsd is comprised of a standalone binary as well as a library,
31 libsettings, that provides the interface settingsd plugin writers
32 must implement.
33
34 %package devel
35 Summary:    Plug-in library development package (headers, etc)
36 Group:      Application Framework/Settings
37 Requires: %{name} = %{version}
38
39 %description devel
40 The settings daemon provides native backend support for settings
41 related operations initiated by the Tizen IVI Settings app.  In
42 particular, it fills gaps in functionality required by the Settings
43 app that are not available in any of the Web APIs available in Tizen
44 IVI.
45
46 Settingsd is comprised of a standalone binary as well as a library,
47 libsettings, that provides the interface settingsd plugin writers
48 must implement.
49
50
51 %prep
52 %setup -q -n %{name}-%{version}
53 cp %{SOURCE1001} .
54
55 %build
56 autoreconf --install --include=m4
57 %configure
58 make %{?_smp_mflags}
59
60 %install
61 %make_install
62
63 rm %{buildroot}%{pkglibdir}/test_setting.so
64
65 mkdir -p %{buildroot}%{_unitdir_user}
66 install -d %{buildroot}/%{_unitdir_user}/weston.target.wants
67 install -m 644 %{SOURCE1} %{buildroot}%{_unitdir_user}/settingsd.service
68 ln -sf ../settingsd.service %{buildroot}/%{_unitdir_user}/weston.target.wants/
69
70 %clean
71
72 %post -p /sbin/ldconfig
73
74 %postun -p /sbin/ldconfig
75
76 %files
77 %manifest %{name}.manifest
78 %dir %{pkglibdir}
79 %doc AUTHORS README
80 %license COPYING COPYING.LESSER
81 %{_bindir}/settingsd
82 %{_libdir}/libsettings.so.*
83 %{pkglibdir}/*.so
84 %config %{_sysconfdir}/%{name}/*
85 %{_unitdir_user}/settingsd.service
86 %{_unitdir_user}/weston.target.wants/settingsd.service
87
88 %files devel
89 %manifest %{name}.manifest
90 %{_libdir}/libsettings.so
91 %{pkgincludedir}/*.hpp
92
93