Merge "[Bug] Fix N_SE-4038: remove the popup when changing region ." into 2.0_beta
[apps/core/preloaded/settings.git] / packaging / settings.spec
1 Name:       settings
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(devman_haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(iniparser)
20 BuildRequires:  pkgconfig(heynoti)
21 BuildRequires:  pkgconfig(ui-gadget-1)
22 BuildRequires:  pkgconfig(json-glib-1.0)
23 BuildRequires:  pkgconfig(libxml-2.0)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(pmapi)
27 BuildRequires:  pkgconfig(ecore-input)
28 BuildRequires:  pkgconfig(eina)
29 BuildRequires:  pkgconfig(icu-i18n)
30 BuildRequires:  pkgconfig(ail)
31 BuildRequires:  pkgconfig(sysman)
32 BuildRequires:  pkgconfig(glib-2.0)
33 BuildRequires:  pkgconfig(gthread-2.0)
34 BuildRequires:  pkgconfig(ecore-imf)
35 BuildRequires:  pkgconfig(ecore-x)
36 BuildRequires:  pkgconfig(ecore)
37 BuildRequires:  pkgconfig(ecore-file)
38 BuildRequires:  pkgconfig(icu-io)
39 BuildRequires:  pkgconfig(icu-le)
40 BuildRequires:  pkgconfig(icu-lx)
41 BuildRequires:  pkgconfig(icu-uc)
42 BuildRequires:  pkgconfig(ewebkit2)
43 BuildRequires:  pkgconfig(evas)
44 BuildRequires:  pkgconfig(edje)
45 BuildRequires:  pkgconfig(mm-player)
46 BuildRequires:  pkgconfig(network)
47 BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-system-device)
57 BuildRequires:  pkgconfig(capi-appfw-application)
58 BuildRequires:  pkgconfig(capi-appfw-app-manager)
59 BuildRequires:  pkgconfig(capi-system-sensor)
60 BuildRequires:  pkgconfig(capi-system-info)
61 BuildRequires:  pkgconfig(capi-system-system-settings)
62 BuildRequires:  sysman-internal-devel
63 BuildRequires:  cmake
64 BuildRequires:  edje-tools
65 BuildRequires:  gettext-tools
66 %description
67 Setting application
68  BEAT UI, Setting application.
69
70
71 %prep
72 %setup -q
73
74 %build
75
76 %define PREFIX    "/opt/apps/org.tizen.setting"
77 %define RESDIR    "/opt/apps/org.tizen.setting/res"
78 %define DATADIR    "/opt/apps/org.tizen.setting/data"
79 CFLAGS+=" -fPIC";export CFLAGS
80 CXXFLAGS+=" -fPIC";export CFLAGS
81 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
82
83 %ifarch %{arm}
84         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
85 %else
86         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
87 %endif
88
89 make
90
91 %install
92 rm -rf %{buildroot}
93 %make_install
94
95 mkdir -p %{buildroot}/opt/data/setting
96
97 %clean
98
99 %post
100
101 # Set vconf values with -g/-u options
102 GOPTION="-g 6514"
103
104 #resetMenuscreen
105         # menuscreen app will take this vconf
106         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
107
108
109 #resetFlightmode
110         vconftool $GOPTION set -t bool db/setting/flight_mode "0"
111
112 #resetNetwork
113         vconftool $GOPTION set -t int db/setting/select_network "0"
114         vconftool $GOPTION set -t int db/setting/select_network_act "0"
115         vconftool $GOPTION set -t int db/setting/network_mode "0"
116         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
117         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
118
119 #resetUsbConnectivity
120         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
121         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
122         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
123
124 #resetSound
125 %ifarch %{arm}
126         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Over the horizon.mp3"
127 %else
128         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
129 %endif
130
131 %ifarch %{arm}
132         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Whistle.mp3"
133 %else
134         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
135 %endif
136
137         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
138         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
139
140         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
141         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
142         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
143         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
144
145         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
146         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
148
149         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
150         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
151
152         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
153         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
154
155         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
156         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
157
158         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
159
160 #resetWallpaper
161         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
162         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
163
164 #resetTilt
165         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
166         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
167         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
168         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
169
170 #resetPanning
171         vconftool $GOPTION set -t bool db/setting/use_panning "0"
172         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
173         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
174         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
175
176 #resetDoubleTap
177         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
178
179 #resetShake
180         vconftool $GOPTION set -t bool db/setting/use_shake "1"
181
182 #resetPickup
183         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
184         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
185
186 #resetTurnOver
187         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
188
189 #resetMotions
190         vconftool $GOPTION set -t bool db/setting/motion_active "1"
191         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
192         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
193         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
194
195 #resetDisplay
196         #backlight
197 %ifarch %{arm}
198         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
199 %else
200         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
201 %endif
202         #vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
203
204         #brightness
205         vconftool $GOPTION set -t int db/setting/Brightness "-1"
206         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
207
208         #battery
209         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
210         #launch
211         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
212
213         #smart screen
214         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
215         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
216         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
217         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
218         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
219
220 #resetPowersaving
221         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "1"
222         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
223         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
224
225         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
231
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
233         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
234         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
235         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
236
237         #v0.4
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
240         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
241         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
242
243 #resetFont
244         vconftool $GOPTION set -t int db/setting/font_size "1"
245         vconftool $GOPTION set -t int db/setting/font_type "0"
246
247 #resetRotationLock
248         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
249
250 #resetTimeAndData
251 %ifarch %{arm}
252         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
253 %else
254         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
255 %endif
256
257         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
258         vconftool $GOPTION set -t int db/setting/date_format "0"
259         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
260
261         vconftool $GOPTION set -t string db/setting/timezone "+9"
262         # to be removed
263         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
264
265         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
266
267         #if [ -f /opt/etc/localtime ]
268         #then
269         rm -f /opt/etc/localtime
270         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
271         #fi
272
273
274 #resetAccessibility
275         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
276         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
277         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
278         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
279         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
280         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
281         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
282
283         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
284         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
285         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
286         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
287
288         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
289         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
290         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
291         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
292
293         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
294         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
295         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
296         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
297
298 #Driving Mode
299         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
300         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
301         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
302         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
303         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
304         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
305         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
306         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
307
308 #resetLanguageAndRegion
309         vconftool $GOPTION set -t int db/setting/lang "2"
310         vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
311         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
312
313 #resetViewtype
314         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
315         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
316
317 #resetTouch
318         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
319         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
320
321 #resetLicense
322         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
323         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
324         vconftool $GOPTION set -t int db/setting/roaming_network "0"
325
326 #resetNotification
327         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
330         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
332
333         # display content
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
339
340         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
343         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
344         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
345
346 #resetSecurity
347         rm -rf /opt/data/setting/set_info
348         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
349
350         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
351         vconftool $GOPTION set -t bool db/setting/simple_password "1"
352         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
353         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
354         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
355         vconftool $GOPTION set -t string db/setting/fmm/sender ""
356         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
357         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
358         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
359
360         # NOT USED NOW.
361         #vconftool $GOPTION set -t bool db/setting/rcs "0"
362
363         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
364         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
365         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
366         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
367         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
368 #resetMemory
369         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
370         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
371         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
372         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
373         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
374         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
375         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
376         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
377
378         # format - system server
379         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
380
381 #resetAbout
382         vconftool $GOPTION set -t string db/setting/device_name "Redwood"
383         vconftool $GOPTION set -t string db/setting/selected_num ""
384 #resetMenuWidgets
385         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
386         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
387
388 #resetDevoptions
389         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
390
391 #resetDatausage
392         vconftool $GOPTION set -t bool db/setting/mobile_data "1"
393         vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
394         vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
395         vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
396         vconftool $GOPTION set -t int db/setting/data_each_month "10"
397
398 #resetDisplay
399         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
400
401 #------------------------------------------
402 #create directory /opt/data/setting
403 if [ ! -d /opt/data/setting ]
404 then
405         mkdir -p /opt/data/setting
406 fi
407
408 # create setting.cfg at runtime right after installation
409 #/opt/apps/org.tizen.setting/bin/setting_conf_util
410 # After flashing, initialize timezone file
411 /opt/apps/org.tizen.setting/bin/setting_conf_util timezone_init
412 chown 5000:5000 /opt/data/setting -R
413 #------------------------------------------
414 heynotitool set setting_time_changed -a
415 sync
416
417 mkdir -p /opt/ug/bin/
418 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
419 # ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
420
421 %files -n settings
422 %manifest settings.manifest
423 %defattr(-,root,root,-)
424 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
425 %attr(-,app,app) %dir /opt/data/setting
426 /opt/apps/org.tizen.setting/bin/setting
427 /opt/apps/org.tizen.setting/bin/setting_conf_util
428 /opt/data/setting/setting.cfg
429
430 /opt/share/packages/org.tizen.setting.xml
431 /opt/share/packages/ug-setting-accessibility-efl.xml
432 /opt/share/packages/ug-setting-font-efl.xml
433
434 /opt/share/icons/default/small/org.tizen.setting.png
435 /opt/share/settings/*
436 /opt/apps/org.tizen.setting/res/*
437 /opt/apps/org.tizen.setting/lib/*
438 /opt/apps/org.tizen.setting/data/*
439 /opt/ug/lib/*
440 /opt/data/setting/langlist.xml
441 /opt/data/setting/plugin-cfg/*
442 /opt/data/setting/plugin-xml/*
443 #/opt/apps/org.tizen.setting/bin/test_server
444