2 Summary: Setting application
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(appcore-common)
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(elementary)
11 BuildRequires: pkgconfig(vconf)
12 BuildRequires: pkgconfig(tapi)
13 BuildRequires: pkgconfig(utilX)
14 BuildRequires: pkgconfig(devman)
15 BuildRequires: pkgconfig(devman_haptic)
16 BuildRequires: pkgconfig(bluetooth-api)
17 BuildRequires: pkgconfig(mm-sound)
18 BuildRequires: pkgconfig(openssl)
19 BuildRequires: pkgconfig(iniparser)
20 BuildRequires: pkgconfig(heynoti)
21 BuildRequires: pkgconfig(ui-gadget-1)
22 BuildRequires: pkgconfig(json-glib-1.0)
23 BuildRequires: pkgconfig(libxml-2.0)
24 BuildRequires: pkgconfig(dlog)
25 BuildRequires: pkgconfig(aul)
26 BuildRequires: pkgconfig(pmapi)
27 BuildRequires: pkgconfig(ecore-input)
28 BuildRequires: pkgconfig(eina)
29 BuildRequires: pkgconfig(icu-i18n)
30 BuildRequires: pkgconfig(ail)
31 BuildRequires: pkgconfig(sysman)
32 BuildRequires: pkgconfig(glib-2.0)
33 BuildRequires: pkgconfig(gthread-2.0)
34 BuildRequires: pkgconfig(dbus-glib-1)
35 BuildRequires: pkgconfig(ecore-imf)
36 BuildRequires: pkgconfig(ecore-x)
37 BuildRequires: pkgconfig(ecore)
38 BuildRequires: pkgconfig(ecore-file)
39 BuildRequires: pkgconfig(icu-io)
40 BuildRequires: pkgconfig(icu-le)
41 BuildRequires: pkgconfig(icu-lx)
42 BuildRequires: pkgconfig(icu-uc)
43 BuildRequires: pkgconfig(ewebkit2)
44 BuildRequires: pkgconfig(evas)
45 BuildRequires: pkgconfig(edje)
46 BuildRequires: pkgconfig(mm-player)
47 BuildRequires: pkgconfig(network)
48 BuildRequires: pkgconfig(security-server)
49 BuildRequires: pkgconfig(svi)
50 BuildRequires: pkgconfig(appsvc)
51 BuildRequires: pkgconfig(libxml-2.0)
52 BuildRequires: pkgconfig(notification)
53 BuildRequires: pkgconfig(pango)
54 BuildRequires: pkgconfig(capi-system-runtime-info)
55 BuildRequires: pkgconfig(capi-media-player)
56 BuildRequires: pkgconfig(capi-media-sound-manager)
57 BuildRequires: pkgconfig(capi-system-device)
58 BuildRequires: pkgconfig(capi-appfw-application)
59 BuildRequires: pkgconfig(capi-appfw-app-manager)
60 BuildRequires: pkgconfig(capi-system-sensor)
61 BuildRequires: pkgconfig(capi-system-info)
62 BuildRequires: pkgconfig(capi-system-system-settings)
63 BuildRequires: sysman-internal-devel
65 BuildRequires: edje-tools
66 BuildRequires: gettext-tools
69 BEAT UI, Setting application.
77 %define PREFIX "/opt/apps/org.tizen.setting"
78 %define RESDIR "/opt/apps/org.tizen.setting/res"
79 %define DATADIR "/opt/apps/org.tizen.setting/data"
80 CFLAGS+=" -fPIC";export CFLAGS
81 CXXFLAGS+=" -fPIC";export CFLAGS
82 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
85 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
87 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
96 mkdir -p %{buildroot}/opt/data/setting
102 # Set vconf values with -g/-u options
106 # menuscreen app will take this vconf
107 #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
111 vconftool $GOPTION set -t bool db/setting/flight_mode "0"
114 vconftool $GOPTION set -t int db/setting/select_network "0"
115 vconftool $GOPTION set -t int db/setting/select_network_act "0"
116 vconftool $GOPTION set -t int db/setting/network_mode "0"
117 vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
118 vconftool $GOPTION set -t bool db/setting/data_roaming "1"
120 #resetUsbConnectivity
121 vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
122 vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
123 vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
126 DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
127 DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
129 vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
130 vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
132 vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
133 vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
134 vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
135 vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
137 vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
138 vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
139 vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
141 vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
142 vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
144 vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path "${DEFAULT_NOTI_TONE}"
145 vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type "0"
147 vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path "${DEFAULT_NOTI_TONE}"
148 vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type "0"
150 vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
153 vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
154 vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
157 vconftool $GOPTION set -t bool db/setting/use_tilt "1"
158 vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
159 vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
160 vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
163 vconftool $GOPTION set -t bool db/setting/use_panning "0"
164 vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
165 vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
166 vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
169 vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
172 vconftool $GOPTION set -t bool db/setting/use_shake "1"
175 vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
176 vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
179 vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
182 vconftool $GOPTION set -t bool db/setting/motion_active "1"
183 vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
184 vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
185 vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
190 vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
192 vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
194 #vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
197 vconftool $GOPTION set -t int db/setting/Brightness "-1"
198 vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
201 vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
203 #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
206 vconftool $GOPTION set -t int db/pm/smartstay_status "0"
207 vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
208 vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
209 vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
210 vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
213 vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "1"
214 vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
215 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
217 vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
218 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
219 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
220 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
221 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
222 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
224 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status "1"
225 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
226 vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
227 vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
230 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
231 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
232 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
233 vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
236 vconftool $GOPTION set -t int db/setting/font_size "1"
237 vconftool $GOPTION set -t int db/setting/font_type "0"
240 vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
244 vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
246 vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
249 vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
250 vconftool $GOPTION set -t int db/setting/date_format "0"
251 vconftool $GOPTION set -t int db/setting/weekofday_format "0"
253 vconftool $GOPTION set -t string db/setting/timezone "+9"
255 vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
257 vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
259 #if [ -f /opt/etc/localtime ]
261 rm -f /opt/etc/localtime
262 ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
267 vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
268 vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
269 vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
270 vconftool $GOPTION set -t int db/setting/accessibility/font_size "3"
271 #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
272 vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
273 vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
275 vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
276 vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
277 vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
278 vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
280 vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
281 vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
282 vconftool $GOPTION set -t int db/ciss/answering_mode "0"
283 vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
285 vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
286 vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
287 vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
288 vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
291 vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
292 vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
293 vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
294 vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
295 vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
296 vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
297 vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
298 vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
300 #resetLanguageAndRegion
301 vconftool $GOPTION set -t int db/setting/lang "2"
302 vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
303 vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
306 #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
307 #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
310 #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
311 #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
314 vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
315 vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
316 vconftool $GOPTION set -t int db/setting/roaming_network "0"
319 vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
320 vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
321 vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
322 vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
323 vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
326 vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
327 vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
328 vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
329 vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
330 vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
332 vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
333 vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
334 vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
335 vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
336 vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
339 rm -rf /opt/data/setting/set_info
340 #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
342 vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
343 vconftool $GOPTION set -t bool db/setting/simple_password "1"
344 vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
345 vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
346 vconftool $GOPTION set -t string db/setting/fmm/recipients ""
347 vconftool $GOPTION set -t string db/setting/fmm/sender ""
348 vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
349 vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
350 vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
353 #vconftool $GOPTION set -t bool db/setting/rcs "0"
355 vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
356 vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
357 vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
358 vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
359 vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
361 vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
362 vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
363 vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
364 vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
365 vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
366 vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
367 vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
368 vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
370 # format - system server
371 #vconftool $GOPTION -i set -t int memory/mmc/format "0"
374 vconftool $GOPTION set -t string db/setting/device_name "Redwood"
375 vconftool $GOPTION set -t string db/setting/selected_num ""
377 vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
378 #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
381 vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
384 vconftool $GOPTION set -t bool db/setting/mobile_data "1"
385 vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
386 vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
387 vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
388 vconftool $GOPTION set -t int db/setting/data_each_month "10"
391 vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
393 #------------------------------------------
394 #create directory /opt/data/setting
395 if [ ! -d /opt/data/setting ]
397 mkdir -p /opt/data/setting
400 # create setting.cfg at runtime right after installation
401 #/opt/apps/org.tizen.setting/bin/setting_conf_util
402 # After flashing, initialize timezone file
403 /opt/apps/org.tizen.setting/bin/setting_conf_util timezone_init
404 chown 5000:5000 /opt/data/setting -R
405 #------------------------------------------
406 heynotitool set setting_time_changed -a
409 mkdir -p /opt/ug/bin/
410 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
411 # ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
414 %manifest settings.manifest
415 %defattr(-,root,root,-)
416 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
417 %attr(-,app,app) %dir /opt/data/setting
418 /opt/apps/org.tizen.setting/bin/setting
419 /opt/apps/org.tizen.setting/bin/setting_conf_util
420 /opt/data/setting/setting.cfg
422 /opt/share/packages/org.tizen.setting.xml
423 /opt/share/packages/ug-setting-accessibility-efl.xml
424 /opt/share/packages/ug-setting-font-efl.xml
426 /opt/share/icons/default/small/org.tizen.setting.png
427 /opt/share/settings/*
428 /opt/apps/org.tizen.setting/res/*
429 /opt/apps/org.tizen.setting/lib/*
430 /opt/apps/org.tizen.setting/data/*
432 /opt/data/setting/langlist.xml
433 /opt/data/setting/plugin-cfg/*
434 /opt/data/setting/plugin-xml/*
435 /opt/apps/org.tizen.setting/bin/test_server