new release for RSA
[apps/core/preloaded/settings.git] / packaging / settings.spec
1 Name:       settings
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(devman_haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(iniparser)
20 BuildRequires:  pkgconfig(heynoti)
21 BuildRequires:  pkgconfig(ui-gadget-1)
22 BuildRequires:  pkgconfig(json-glib-1.0)
23 BuildRequires:  pkgconfig(libxml-2.0)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(pmapi)
27 BuildRequires:  pkgconfig(ecore-input)
28 BuildRequires:  pkgconfig(eina)
29 BuildRequires:  pkgconfig(icu-i18n)
30 BuildRequires:  pkgconfig(ail)
31 BuildRequires:  pkgconfig(sysman)
32 BuildRequires:  pkgconfig(glib-2.0)
33 BuildRequires:  pkgconfig(gthread-2.0)
34 BuildRequires:  pkgconfig(ecore-imf)
35 BuildRequires:  pkgconfig(ecore-x)
36 BuildRequires:  pkgconfig(ecore)
37 BuildRequires:  pkgconfig(ecore-file)
38 BuildRequires:  pkgconfig(icu-io)
39 BuildRequires:  pkgconfig(icu-le)
40 BuildRequires:  pkgconfig(icu-lx)
41 BuildRequires:  pkgconfig(icu-uc)
42 BuildRequires:  pkgconfig(ewebkit2)
43 BuildRequires:  pkgconfig(drm-client)
44 BuildRequires:  pkgconfig(drm-trusted)
45 BuildRequires:  pkgconfig(evas)
46 BuildRequires:  pkgconfig(edje)
47 BuildRequires:  pkgconfig(mm-player)
48 BuildRequires:  pkgconfig(network)
49 BuildRequires:  pkgconfig(security-server)
50 BuildRequires:  pkgconfig(svi)
51 BuildRequires:  pkgconfig(appsvc)
52 BuildRequires:  pkgconfig(libxml-2.0)
53 BuildRequires:  pkgconfig(notification)
54 BuildRequires:  pkgconfig(pango)
55 BuildRequires:  pkgconfig(capi-system-runtime-info)
56 BuildRequires:  pkgconfig(capi-media-player)
57 BuildRequires:  pkgconfig(capi-media-sound-manager)
58 BuildRequires:  pkgconfig(capi-system-device)
59 BuildRequires:  pkgconfig(capi-appfw-application)
60 BuildRequires:  pkgconfig(capi-appfw-app-manager)
61 BuildRequires:  pkgconfig(capi-system-sensor)
62 BuildRequires:  sysman-internal-devel
63 BuildRequires:  cmake
64 BuildRequires:  edje-tools
65 BuildRequires:  gettext-tools
66 %description
67 Setting application
68  BEAT UI, Setting application.
69
70
71 %prep
72 %setup -q
73
74 %build
75
76 %define PREFIX    "/opt/apps/com.samsung.setting"
77 %define RESDIR    "/opt/apps/com.samsung.setting/res"
78 %define DATADIR    "/opt/apps/com.samsung.setting/data"
79 CFLAGS+=" -fPIC";export CFLAGS
80 CXXFLAGS+=" -fPIC";export CFLAGS
81 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
82
83 %ifarch %{arm}
84         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
85 %else
86         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
87 %endif
88
89 make
90
91 %install
92 rm -rf %{buildroot}
93 %make_install
94
95 mkdir -p %{buildroot}/opt/data/setting
96
97 %clean
98
99 %post
100
101 # Set vconf values with -g/-u options
102 GOPTION="-g 6514"
103
104 #resetMenuscreen
105         # menuscreen app will take this vconf
106         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
107
108
109 #resetFlightmode
110         vconftool $GOPTION set -t bool db/setting/flight_mode "0"
111
112 #resetNetwork
113         vconftool $GOPTION set -t int db/setting/select_network "0"
114         vconftool $GOPTION set -t int db/setting/select_network_act "0"
115         vconftool $GOPTION set -t int db/setting/network_mode "0"
116         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
117         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
118
119 #resetUsbConnectivity
120         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
121         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
122         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
123
124 #resetSound
125 %ifarch %{arm}
126         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Over the horizon.mp3"
127 %else
128         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
129 %endif
130
131 %ifarch %{arm}
132         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Whistle.mp3"
133 %else
134         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
135 %endif
136
137         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
138         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
139
140         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
141         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
142         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
143         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
144
145         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
146         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
148
149         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
150         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
151
152         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
153         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
154
155         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
156         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
157
158         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
159
160 #resetWallpaper
161         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
162         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
163
164 #resetTilt
165         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
166         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
167         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
168         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
169
170 #resetPanning
171         vconftool $GOPTION set -t bool db/setting/use_panning "0"
172         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
173         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
174         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
175
176 #resetDoubleTap
177         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
178
179 #resetShake
180         vconftool $GOPTION set -t bool db/setting/use_shake "1"
181
182 #resetPickup
183         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
184         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
185
186 #resetTurnOver
187         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
188
189 #resetMotions
190         vconftool $GOPTION set -t bool db/setting/motion_active "1"
191         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
192         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
193         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
194
195 #resetDisplay
196         #backlight
197 %ifarch %{arm}
198         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
199 %else
200         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
201 %endif
202         #vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
203
204         #brightness
205         vconftool $GOPTION set -t int db/setting/Brightness "-1"
206         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
207
208         #battery
209         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
210         #launch
211         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
212
213         #smart screen
214         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
215         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
216         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
217         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
218         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
219
220 #resetPowersaving
221         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "1"
222         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
223         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
224
225         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
231
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
233         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
234         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
235         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
236
237         #v0.4
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
240         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
241         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
242
243 #resetFont
244         vconftool $GOPTION set -t int db/setting/font_size "1"
245         vconftool $GOPTION set -t int db/setting/font_type "0"
246
247 #resetRotationLock
248         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
249
250 #resetTimeAndData
251         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
252
253         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
254         vconftool $GOPTION set -t int db/setting/date_format "0"
255         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
256
257         vconftool $GOPTION set -t string db/setting/timezone "+9"
258         # to be removed
259         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
260
261         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
262
263         #if [ -f /opt/etc/localtime ]
264         #then
265         rm -f /opt/etc/localtime
266         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
267         #fi
268
269
270 #resetAccessibility
271         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
272         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
273         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
274         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
275         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
276         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
277         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
278
279         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
280         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
281         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
282         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
283
284         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
285         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
286         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
287         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
288
289         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
290         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
291         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
292         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
293
294 #Driving Mode
295         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
296         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
297         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
298         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
299         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
300         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
301         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
302         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
303
304 #resetLanguageAndRegion
305         vconftool $GOPTION set -t int db/setting/lang "2"
306         vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
307         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
308
309 #resetViewtype
310         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
311         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
312
313 #resetTouch
314         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
315         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
316
317 #resetLicense
318         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
319         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
320         vconftool $GOPTION set -t int db/setting/roaming_network "0"
321
322 #resetNotification
323         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
324         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
325         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
326         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
327         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
328
329         # display content
330         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
333         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
335
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
340         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
341
342 #resetSecurity
343         rm -rf /opt/data/setting/set_info
344         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
345
346         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
347         vconftool $GOPTION set -t bool db/setting/simple_password "1"
348         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
349         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
350         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
351         vconftool $GOPTION set -t string db/setting/fmm/sender ""
352         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
353         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
354         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
355
356         # NOT USED NOW.
357         #vconftool $GOPTION set -t bool db/setting/rcs "0"
358
359         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
360         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
361         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
362         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
363         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
364 #resetMemory
365         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
366         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
367         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
368         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
369         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
370         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
371         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
372         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
373
374         # format - system server
375         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
376
377 #resetAbout
378         vconftool $GOPTION set -t string db/setting/device_name "Redwood"
379
380 #resetMenuWidgets
381         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
382         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
383
384 #resetDevoptions
385         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
386
387 #resetDatausage
388         vconftool $GOPTION set -t bool db/setting/mobile_data "1"
389         vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
390         vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
391         vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
392         vconftool $GOPTION set -t int db/setting/data_each_month "10"
393
394 #resetDisplay
395         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
396
397 #------------------------------------------
398 #create directory /opt/data/setting
399 if [ ! -d /opt/data/setting ]
400 then
401         mkdir -p /opt/data/setting
402 fi
403
404 # create setting.cfg at runtime right after installation
405 #/opt/apps/com.samsung.setting/bin/setting_conf_util
406 # After flashing, initialize timezone file
407 /opt/apps/com.samsung.setting/bin/setting_conf_util timezone_init
408 chown 5000:5000 /opt/data/setting -R
409 #------------------------------------------
410 heynotitool set setting_time_changed -a
411 sync
412
413 mkdir -p /opt/ug/bin/
414 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
415 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
416
417 %files -n settings
418 %manifest settings.manifest
419 %defattr(-,root,root,-)
420 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
421 %attr(-,app,app) %dir /opt/data/setting
422 /opt/apps/com.samsung.setting/bin/setting
423 /opt/apps/com.samsung.setting/bin/setting_conf_util
424 /opt/data/setting/setting.cfg
425
426 /opt/share/packages/com.samsung.setting.xml
427 /opt/share/packages/ug-setting-accessibility-efl.xml
428 /opt/share/packages/ug-setting-font-efl.xml
429
430 /opt/share/icons/default/small/com.samsung.setting.png
431 /opt/share/settings/*
432 /opt/apps/com.samsung.setting/res/*
433 /opt/apps/com.samsung.setting/lib/*
434 /opt/apps/com.samsung.setting/data/*
435 /opt/ug/lib/*
436 /opt/data/setting/langlist.xml
437 /opt/data/setting/plugin-cfg/*
438 /opt/data/setting/plugin-xml/*
439 #/opt/apps/com.samsung.setting/bin/test_server
440