removed drm-trusted, drm-client in dependencies.
[apps/core/preloaded/settings.git] / packaging / settings.spec
1 Name:       settings
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(devman_haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(iniparser)
20 BuildRequires:  pkgconfig(heynoti)
21 BuildRequires:  pkgconfig(ui-gadget-1)
22 BuildRequires:  pkgconfig(json-glib-1.0)
23 BuildRequires:  pkgconfig(libxml-2.0)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(pmapi)
27 BuildRequires:  pkgconfig(ecore-input)
28 BuildRequires:  pkgconfig(eina)
29 BuildRequires:  pkgconfig(icu-i18n)
30 BuildRequires:  pkgconfig(ail)
31 BuildRequires:  pkgconfig(sysman)
32 BuildRequires:  pkgconfig(glib-2.0)
33 BuildRequires:  pkgconfig(gthread-2.0)
34 BuildRequires:  pkgconfig(ecore-imf)
35 BuildRequires:  pkgconfig(ecore-x)
36 BuildRequires:  pkgconfig(ecore)
37 BuildRequires:  pkgconfig(ecore-file)
38 BuildRequires:  pkgconfig(icu-io)
39 BuildRequires:  pkgconfig(icu-le)
40 BuildRequires:  pkgconfig(icu-lx)
41 BuildRequires:  pkgconfig(icu-uc)
42 BuildRequires:  pkgconfig(ewebkit2)
43 BuildRequires:  pkgconfig(evas)
44 BuildRequires:  pkgconfig(edje)
45 BuildRequires:  pkgconfig(mm-player)
46 BuildRequires:  pkgconfig(network)
47 BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-system-device)
57 BuildRequires:  pkgconfig(capi-appfw-application)
58 BuildRequires:  pkgconfig(capi-appfw-app-manager)
59 BuildRequires:  pkgconfig(capi-system-sensor)
60 BuildRequires:  sysman-internal-devel
61 BuildRequires:  cmake
62 BuildRequires:  edje-tools
63 BuildRequires:  gettext-tools
64 %description
65 Setting application
66  BEAT UI, Setting application.
67
68
69 %prep
70 %setup -q
71
72 %build
73
74 %define PREFIX    "/opt/apps/com.samsung.setting"
75 %define RESDIR    "/opt/apps/com.samsung.setting/res"
76 %define DATADIR    "/opt/apps/com.samsung.setting/data"
77 CFLAGS+=" -fPIC";export CFLAGS
78 CXXFLAGS+=" -fPIC";export CFLAGS
79 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
80
81 %ifarch %{arm}
82         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
83 %else
84         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
85 %endif
86
87 make
88
89 %install
90 rm -rf %{buildroot}
91 %make_install
92
93 mkdir -p %{buildroot}/opt/data/setting
94
95 %clean
96
97 %post
98
99 # Set vconf values with -g/-u options
100 GOPTION="-g 6514"
101
102 #resetMenuscreen
103         # menuscreen app will take this vconf
104         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
105
106
107 #resetFlightmode
108         vconftool $GOPTION set -t bool db/setting/flight_mode "0"
109
110 #resetNetwork
111         vconftool $GOPTION set -t int db/setting/select_network "0"
112         vconftool $GOPTION set -t int db/setting/select_network_act "0"
113         vconftool $GOPTION set -t int db/setting/network_mode "0"
114         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
115         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
116
117 #resetUsbConnectivity
118         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
119         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
120         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
121
122 #resetSound
123 %ifarch %{arm}
124         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Over the horizon.mp3"
125 %else
126         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
127 %endif
128
129 %ifarch %{arm}
130         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Whistle.mp3"
131 %else
132         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
133 %endif
134
135         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
136         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
137
138         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
139         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
140         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
141         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
142
143         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
144         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
145         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
146
147         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
148         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
149
150         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
151         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
152
153         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
154         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
155
156         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
157
158 #resetWallpaper
159         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
160         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
161
162 #resetTilt
163         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
164         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
165         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
166         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
167
168 #resetPanning
169         vconftool $GOPTION set -t bool db/setting/use_panning "0"
170         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
171         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
172         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
173
174 #resetDoubleTap
175         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
176
177 #resetShake
178         vconftool $GOPTION set -t bool db/setting/use_shake "1"
179
180 #resetPickup
181         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
182         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
183
184 #resetTurnOver
185         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
186
187 #resetMotions
188         vconftool $GOPTION set -t bool db/setting/motion_active "1"
189         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
190         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
191         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
192
193 #resetDisplay
194         #backlight
195 %ifarch %{arm}
196         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
197 %else
198         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
199 %endif
200         #vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
201
202         #brightness
203         vconftool $GOPTION set -t int db/setting/Brightness "-1"
204         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
205
206         #battery
207         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
208         #launch
209         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
210
211         #smart screen
212         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
213         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
214         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
215         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
216         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
217
218 #resetPowersaving
219         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "1"
220         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
221         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
222
223         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
224         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
225         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
229
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
232         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
233         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
234
235         #v0.4
236         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
237         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
240
241 #resetFont
242         vconftool $GOPTION set -t int db/setting/font_size "1"
243         vconftool $GOPTION set -t int db/setting/font_type "0"
244
245 #resetRotationLock
246         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
247
248 #resetTimeAndData
249         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
250
251         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
252         vconftool $GOPTION set -t int db/setting/date_format "0"
253         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
254
255         vconftool $GOPTION set -t string db/setting/timezone "+9"
256         # to be removed
257         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
258
259         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
260
261         #if [ -f /opt/etc/localtime ]
262         #then
263         rm -f /opt/etc/localtime
264         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
265         #fi
266
267
268 #resetAccessibility
269         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
270         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
271         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
272         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
273         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
274         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
275         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
276
277         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
278         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
279         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
280         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
281
282         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
283         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
284         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
285         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
286
287         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
288         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
289         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
290         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
291
292 #Driving Mode
293         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
294         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
295         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
296         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
297         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
298         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
299         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
300         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
301
302 #resetLanguageAndRegion
303         vconftool $GOPTION set -t int db/setting/lang "2"
304         vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
305         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
306
307 #resetViewtype
308         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
309         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
310
311 #resetTouch
312         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
313         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
314
315 #resetLicense
316         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
317         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
318         vconftool $GOPTION set -t int db/setting/roaming_network "0"
319
320 #resetNotification
321         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
322         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
323         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
324         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
325         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
326
327         # display content
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
330         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
333
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
339
340 #resetSecurity
341         rm -rf /opt/data/setting/set_info
342         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
343
344         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
345         vconftool $GOPTION set -t bool db/setting/simple_password "1"
346         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
347         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
348         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
349         vconftool $GOPTION set -t string db/setting/fmm/sender ""
350         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
351         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
352         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
353
354         # NOT USED NOW.
355         #vconftool $GOPTION set -t bool db/setting/rcs "0"
356
357         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
358         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
359         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
360         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
361         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
362 #resetMemory
363         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
364         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
365         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
366         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
367         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
368         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
369         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
370         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
371
372         # format - system server
373         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
374
375 #resetAbout
376         vconftool $GOPTION set -t string db/setting/device_name "Redwood"
377
378 #resetMenuWidgets
379         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
380         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
381
382 #resetDevoptions
383         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
384
385 #resetDatausage
386         vconftool $GOPTION set -t bool db/setting/mobile_data "1"
387         vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
388         vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
389         vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
390         vconftool $GOPTION set -t int db/setting/data_each_month "10"
391
392 #resetDisplay
393         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
394
395 #------------------------------------------
396 #create directory /opt/data/setting
397 if [ ! -d /opt/data/setting ]
398 then
399         mkdir -p /opt/data/setting
400 fi
401
402 # create setting.cfg at runtime right after installation
403 #/opt/apps/com.samsung.setting/bin/setting_conf_util
404 # After flashing, initialize timezone file
405 /opt/apps/com.samsung.setting/bin/setting_conf_util timezone_init
406 chown 5000:5000 /opt/data/setting -R
407 #------------------------------------------
408 heynotitool set setting_time_changed -a
409 sync
410
411 mkdir -p /opt/ug/bin/
412 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
413 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
414
415 %files -n settings
416 %manifest settings.manifest
417 %defattr(-,root,root,-)
418 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
419 %attr(-,app,app) %dir /opt/data/setting
420 /opt/apps/com.samsung.setting/bin/setting
421 /opt/apps/com.samsung.setting/bin/setting_conf_util
422 /opt/data/setting/setting.cfg
423
424 /opt/share/packages/com.samsung.setting.xml
425 /opt/share/packages/ug-setting-accessibility-efl.xml
426 /opt/share/packages/ug-setting-font-efl.xml
427
428 /opt/share/icons/default/small/com.samsung.setting.png
429 /opt/share/settings/*
430 /opt/apps/com.samsung.setting/res/*
431 /opt/apps/com.samsung.setting/lib/*
432 /opt/apps/com.samsung.setting/data/*
433 /opt/ug/lib/*
434 /opt/data/setting/langlist.xml
435 /opt/data/setting/plugin-cfg/*
436 /opt/data/setting/plugin-xml/*
437 #/opt/apps/com.samsung.setting/bin/test_server
438