applied app setting code for 3rd part app installation
[apps/core/preloaded/settings.git] / packaging / settings.spec
1 Name:       settings
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(devman_haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(iniparser)
20 BuildRequires:  pkgconfig(heynoti)
21 BuildRequires:  pkgconfig(ui-gadget-1)
22 BuildRequires:  pkgconfig(json-glib-1.0)
23 BuildRequires:  pkgconfig(libxml-2.0)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(pmapi)
27 BuildRequires:  pkgconfig(ecore-input)
28 BuildRequires:  pkgconfig(eina)
29 BuildRequires:  pkgconfig(icu-i18n)
30 BuildRequires:  pkgconfig(ail)
31 BuildRequires:  pkgconfig(sysman)
32 BuildRequires:  pkgconfig(glib-2.0)
33 BuildRequires:  pkgconfig(gthread-2.0)
34 BuildRequires:  pkgconfig(dbus-glib-1)
35 BuildRequires:  pkgconfig(ecore-imf)
36 BuildRequires:  pkgconfig(ecore-x)
37 BuildRequires:  pkgconfig(ecore)
38 BuildRequires:  pkgconfig(ecore-file)
39 BuildRequires:  pkgconfig(icu-io)
40 BuildRequires:  pkgconfig(icu-le)
41 BuildRequires:  pkgconfig(icu-lx)
42 BuildRequires:  pkgconfig(icu-uc)
43 BuildRequires:  pkgconfig(ewebkit2)
44 BuildRequires:  pkgconfig(evas)
45 BuildRequires:  pkgconfig(edje)
46 BuildRequires:  pkgconfig(mm-player)
47 BuildRequires:  pkgconfig(network)
48 BuildRequires:  pkgconfig(security-server)
49 BuildRequires:  pkgconfig(svi)
50 BuildRequires:  pkgconfig(appsvc)
51 BuildRequires:  pkgconfig(libxml-2.0)
52 BuildRequires:  pkgconfig(notification)
53 BuildRequires:  pkgconfig(pango)
54 BuildRequires:  pkgconfig(capi-system-runtime-info)
55 BuildRequires:  pkgconfig(capi-media-player)
56 BuildRequires:  pkgconfig(capi-media-sound-manager)
57 BuildRequires:  pkgconfig(capi-system-device)
58 BuildRequires:  pkgconfig(capi-appfw-application)
59 BuildRequires:  pkgconfig(capi-appfw-app-manager)
60 BuildRequires:  pkgconfig(capi-system-sensor)
61 BuildRequires:  pkgconfig(capi-system-info)
62 BuildRequires:  pkgconfig(capi-system-system-settings)
63 BuildRequires:  sysman-internal-devel
64 BuildRequires:  cmake
65 BuildRequires:  edje-tools
66 BuildRequires:  gettext-tools
67 %description
68 Setting application
69  BEAT UI, Setting application.
70
71
72 %prep
73 %setup -q
74
75 %build
76
77 %define PREFIX    "/opt/apps/org.tizen.setting"
78 %define RESDIR    "/opt/apps/org.tizen.setting/res"
79 %define DATADIR    "/opt/apps/org.tizen.setting/data"
80 CFLAGS+=" -fPIC";export CFLAGS
81 CXXFLAGS+=" -fPIC";export CFLAGS
82 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
83
84 %ifarch %{arm}
85         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
86 %else
87         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
88 %endif
89
90 make
91
92 %install
93 rm -rf %{buildroot}
94 %make_install
95
96 mkdir -p %{buildroot}/opt/data/setting
97
98 %clean
99
100 %post
101
102 # Set vconf values with -g/-u options
103 GOPTION="-g 6514"
104
105 #resetMenuscreen
106         # menuscreen app will take this vconf
107         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
108
109
110 #resetFlightmode
111         vconftool $GOPTION set -t bool db/setting/flight_mode "0"
112
113 #resetNetwork
114         vconftool $GOPTION set -t int db/setting/select_network "0"
115         vconftool $GOPTION set -t int db/setting/select_network_act "0"
116         vconftool $GOPTION set -t int db/setting/network_mode "0"
117         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
118         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
119
120 #resetUsbConnectivity
121         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
122         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
123         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
124
125 #resetSound
126 %ifarch %{arm}
127         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Over the horizon.mp3"
128 %else
129         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
130 %endif
131
132 %ifarch %{arm}
133         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Whistle.mp3"
134 %else
135         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
136 %endif
137
138         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
139         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
140
141         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
142         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
143         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
144         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
145
146         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
148         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
149
150         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
151         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
152
153         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
154         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
155
156         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
157         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
158
159         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
160
161 #resetWallpaper
162         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
163         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
164
165 #resetTilt
166         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
167         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
168         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
169         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
170
171 #resetPanning
172         vconftool $GOPTION set -t bool db/setting/use_panning "0"
173         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
174         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
175         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
176
177 #resetDoubleTap
178         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
179
180 #resetShake
181         vconftool $GOPTION set -t bool db/setting/use_shake "1"
182
183 #resetPickup
184         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
185         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
186
187 #resetTurnOver
188         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
189
190 #resetMotions
191         vconftool $GOPTION set -t bool db/setting/motion_active "1"
192         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
193         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
194         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
195
196 #resetDisplay
197         #backlight
198 %ifarch %{arm}
199         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
200 %else
201         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
202 %endif
203         #vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
204
205         #brightness
206         vconftool $GOPTION set -t int db/setting/Brightness "-1"
207         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
208
209         #battery
210         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
211         #launch
212         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
213
214         #smart screen
215         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
216         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
217         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
218         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
219         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
220
221 #resetPowersaving
222         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "1"
223         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
224         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
225
226         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
232
233         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
234         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
235         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
236         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
237
238         #v0.4
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
240         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
241         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
242         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
243
244 #resetFont
245         vconftool $GOPTION set -t int db/setting/font_size "1"
246         vconftool $GOPTION set -t int db/setting/font_type "0"
247
248 #resetRotationLock
249         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
250
251 #resetTimeAndData
252 %ifarch %{arm}
253         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
254 %else
255         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
256 %endif
257
258         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
259         vconftool $GOPTION set -t int db/setting/date_format "0"
260         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
261
262         vconftool $GOPTION set -t string db/setting/timezone "+9"
263         # to be removed
264         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
265
266         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
267
268         #if [ -f /opt/etc/localtime ]
269         #then
270         rm -f /opt/etc/localtime
271         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
272         #fi
273
274
275 #resetAccessibility
276         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
277         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
278         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
279         vconftool $GOPTION set -t int db/setting/accessibility/font_size "3"
280         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
281         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
282         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
283
284         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
285         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
286         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
287         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
288
289         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
290         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
291         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
292         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
293
294         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
295         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
296         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
297         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
298
299 #Driving Mode
300         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
301         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
302         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
303         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
304         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
305         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
306         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
307         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
308
309 #resetLanguageAndRegion
310         vconftool $GOPTION set -t int db/setting/lang "2"
311         vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
312         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
313
314 #resetViewtype
315         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
316         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
317
318 #resetTouch
319         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
320         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
321
322 #resetLicense
323         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
324         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
325         vconftool $GOPTION set -t int db/setting/roaming_network "0"
326
327 #resetNotification
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
330         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
333
334         # display content
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
340
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
343         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
344         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
345         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
346
347 #resetSecurity
348         rm -rf /opt/data/setting/set_info
349         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
350
351         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
352         vconftool $GOPTION set -t bool db/setting/simple_password "1"
353         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
354         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
355         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
356         vconftool $GOPTION set -t string db/setting/fmm/sender ""
357         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
358         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
359         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
360
361         # NOT USED NOW.
362         #vconftool $GOPTION set -t bool db/setting/rcs "0"
363
364         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
365         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
366         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
367         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
368         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
369 #resetMemory
370         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
371         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
372         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
373         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
374         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
375         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
376         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
377         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
378
379         # format - system server
380         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
381
382 #resetAbout
383         vconftool $GOPTION set -t string db/setting/device_name "Redwood"
384         vconftool $GOPTION set -t string db/setting/selected_num ""
385 #resetMenuWidgets
386         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
387         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
388
389 #resetDevoptions
390         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
391
392 #resetDatausage
393         vconftool $GOPTION set -t bool db/setting/mobile_data "1"
394         vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
395         vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
396         vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
397         vconftool $GOPTION set -t int db/setting/data_each_month "10"
398
399 #resetDisplay
400         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
401
402 #------------------------------------------
403 #create directory /opt/data/setting
404 if [ ! -d /opt/data/setting ]
405 then
406         mkdir -p /opt/data/setting
407 fi
408
409 # create setting.cfg at runtime right after installation
410 #/opt/apps/org.tizen.setting/bin/setting_conf_util
411 # After flashing, initialize timezone file
412 /opt/apps/org.tizen.setting/bin/setting_conf_util timezone_init
413 chown 5000:5000 /opt/data/setting -R
414 #------------------------------------------
415 heynotitool set setting_time_changed -a
416 sync
417
418 mkdir -p /opt/ug/bin/
419 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
420 # ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
421
422 %files -n settings
423 %manifest settings.manifest
424 %defattr(-,root,root,-)
425 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
426 %attr(-,app,app) %dir /opt/data/setting
427 /opt/apps/org.tizen.setting/bin/setting
428 /opt/apps/org.tizen.setting/bin/setting_conf_util
429 /opt/data/setting/setting.cfg
430
431 /opt/share/packages/org.tizen.setting.xml
432 /opt/share/packages/ug-setting-accessibility-efl.xml
433 /opt/share/packages/ug-setting-font-efl.xml
434
435 /opt/share/icons/default/small/org.tizen.setting.png
436 /opt/share/settings/*
437 /opt/apps/org.tizen.setting/res/*
438 /opt/apps/org.tizen.setting/lib/*
439 /opt/apps/org.tizen.setting/data/*
440 /opt/ug/lib/*
441 /opt/data/setting/langlist.xml
442 /opt/data/setting/plugin-cfg/*
443 /opt/data/setting/plugin-xml/*
444 /opt/apps/org.tizen.setting/bin/test_server