[Feature] use system-info api to get build info .
[apps/core/preloaded/settings.git] / packaging / settings.spec
1 Name:       settings
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(devman_haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(heynoti)
20 BuildRequires:  pkgconfig(ui-gadget-1)
21 BuildRequires:  pkgconfig(json-glib-1.0)
22 BuildRequires:  pkgconfig(libxml-2.0)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(aul)
25 BuildRequires:  pkgconfig(pmapi)
26 BuildRequires:  pkgconfig(ecore-input)
27 BuildRequires:  pkgconfig(eina)
28 BuildRequires:  pkgconfig(icu-i18n)
29 BuildRequires:  pkgconfig(ail)
30 BuildRequires:  pkgconfig(sysman)
31 BuildRequires:  pkgconfig(glib-2.0)
32 BuildRequires:  pkgconfig(gthread-2.0)
33 BuildRequires:  pkgconfig(dbus-glib-1)
34 BuildRequires:  pkgconfig(ecore-imf)
35 BuildRequires:  pkgconfig(ecore-x)
36 BuildRequires:  pkgconfig(ecore)
37 BuildRequires:  pkgconfig(ecore-file)
38 BuildRequires:  pkgconfig(icu-io)
39 BuildRequires:  pkgconfig(icu-le)
40 BuildRequires:  pkgconfig(icu-lx)
41 BuildRequires:  pkgconfig(icu-uc)
42 BuildRequires:  pkgconfig(ewebkit2)
43 BuildRequires:  pkgconfig(evas)
44 BuildRequires:  pkgconfig(edje)
45 BuildRequires:  pkgconfig(mm-player)
46 BuildRequires:  pkgconfig(network)
47 BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-system-device)
57 BuildRequires:  pkgconfig(capi-appfw-application)
58 BuildRequires:  pkgconfig(capi-appfw-app-manager)
59 BuildRequires:  pkgconfig(capi-system-sensor)
60 BuildRequires:  pkgconfig(capi-system-info)
61 BuildRequires:  pkgconfig(capi-system-system-settings)
62 BuildRequires:  sysman-internal-devel
63 BuildRequires:  cmake
64 BuildRequires:  edje-tools
65 BuildRequires:  gettext-tools
66 %description
67 Setting application
68  BEAT UI, Setting application.
69
70
71 %prep
72 %setup -q
73
74 %build
75
76 %define PREFIX    "/opt/apps/org.tizen.setting"
77 %define RESDIR    "/opt/apps/org.tizen.setting/res"
78 %define DATADIR    "/opt/apps/org.tizen.setting/data"
79 CFLAGS+=" -fPIC";export CFLAGS
80 CXXFLAGS+=" -fPIC";export CFLAGS
81 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
82
83 %ifarch %{arm}
84         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
85 %else
86         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
87 %endif
88
89 make
90
91 %install
92 rm -rf %{buildroot}
93 %make_install
94
95 mkdir -p %{buildroot}/opt/data/setting
96
97 %clean
98
99 %post
100
101 # Set vconf values with -g/-u options
102 GOPTION="-g 6514"
103
104 #resetMenuscreen
105         # menuscreen app will take this vconf
106         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
107
108
109 #resetFlightmode
110         vconftool $GOPTION set -t bool db/setting/flight_mode "0"
111
112 #resetNetwork
113         vconftool $GOPTION set -t int db/setting/select_network "0"
114         vconftool $GOPTION set -t int db/setting/select_network_act "0"
115         vconftool $GOPTION set -t int db/setting/network_mode "0"
116         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
117         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
118
119 #resetUsbConnectivity
120         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
121         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
122         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
123
124 #resetSound
125         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
126         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
127
128         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
129         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
130
131         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
132         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
133         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
134         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
135
136         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
137         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
138         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
139
140         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
141         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
142
143         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
144         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
145
146         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
147         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
148
149         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
150
151 #resetWallpaper
152         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
153         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
154
155 #resetTilt
156         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
157         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
158         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
159         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
160
161 #resetPanning
162         vconftool $GOPTION set -t bool db/setting/use_panning "0"
163         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
164         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
165         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
166
167 #resetDoubleTap
168         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
169
170 #resetShake
171         vconftool $GOPTION set -t bool db/setting/use_shake "1"
172
173 #resetPickup
174         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
175         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
176
177 #resetTurnOver
178         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
179
180 #resetMotions
181         vconftool $GOPTION set -t bool db/setting/motion_active "1"
182         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
183         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
184         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
185
186 #resetDisplay
187         #backlight
188 %ifarch %{arm}
189         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
190 %else
191         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
192 %endif
193         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
194
195         #brightness
196         vconftool $GOPTION set -t int db/setting/Brightness "-1"
197         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
198
199         #battery
200         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
201         #launch
202         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
203
204         #smart screen
205         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
206         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
207         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
208         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
209         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
210
211 #resetPowersaving
212         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "1"
213         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
214         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
215
216         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
217         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
218         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
219         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
220         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
221         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
222
223         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
224         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
225         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
226         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
227
228         #v0.4
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
233
234 #resetFont
235         vconftool $GOPTION set -t int db/setting/font_size "1"
236         vconftool $GOPTION set -t int db/setting/font_type "0"
237
238 #resetRotationLock
239         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
240
241 #resetTimeAndData
242 %ifarch %{arm}
243         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
244 %else
245         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
246 %endif
247
248         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
249         vconftool $GOPTION set -t int db/setting/date_format "0"
250         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
251
252         vconftool $GOPTION set -t string db/setting/timezone "+9"
253         # to be removed
254         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
255
256         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
257
258         #if [ -f /opt/etc/localtime ]
259         #then
260         rm -f /opt/etc/localtime
261         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
262         #fi
263
264
265 #resetAccessibility
266         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
267         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
268         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
269         vconftool $GOPTION set -t int db/setting/accessibility/font_size "3"
270         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
271         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
272         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
273
274         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
275         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
276         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
277         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
278
279         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
280         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
281         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
282         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
283
284         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
285         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
286         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
287         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
288
289 #Driving Mode
290         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
291         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
292         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
293         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
294         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
295         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
296         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
297         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
298
299 #resetLanguageAndRegion
300         vconftool $GOPTION set -t int db/setting/lang "2"
301         vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
302         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
303
304 #resetViewtype
305         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
306         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
307
308 #resetTouch
309         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
310         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
311
312 #resetLicense
313         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
314         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
315         vconftool $GOPTION set -t int db/setting/roaming_network "0"
316
317 #resetNotification
318         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
319         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
320         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
321         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
322         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
323
324         # display content
325         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
326         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
327         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
330
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
333         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
336
337 #resetSecurity
338         rm -rf /opt/data/setting/set_info
339         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
340
341         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
342         vconftool $GOPTION set -t bool db/setting/simple_password "1"
343         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
344         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
345         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
346         vconftool $GOPTION set -t string db/setting/fmm/sender ""
347         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
348         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
349         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
350
351         # NOT USED NOW.
352         #vconftool $GOPTION set -t bool db/setting/rcs "0"
353
354         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
355         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
356         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
357         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
358         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
359 #resetMemory
360         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
361         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
362         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
363         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
364         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
365         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
366         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
367         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
368
369         # format - system server
370         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
371
372 #resetAbout
373         vconftool $GOPTION set -t string db/setting/device_name "Redwood"
374         vconftool $GOPTION set -t string db/setting/selected_num ""
375 #resetMenuWidgets
376         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
377         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
378
379 #resetDevoptions
380         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
381
382 #resetDatausage
383         vconftool $GOPTION set -t bool db/setting/mobile_data "1"
384         vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
385         vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
386         vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
387         vconftool $GOPTION set -t int db/setting/data_each_month "10"
388
389 #resetDisplay
390         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
391
392 #------------------------------------------
393 #create directory /opt/data/setting
394 if [ ! -d /opt/data/setting ]
395 then
396         mkdir -p /opt/data/setting
397 fi
398
399 # create setting.cfg at runtime right after installation
400 #/opt/apps/org.tizen.setting/bin/setting_conf_util
401 # After flashing, initialize timezone file
402 /opt/apps/org.tizen.setting/bin/setting_conf_util timezone_init
403 chown 5000:5000 /opt/data/setting -R
404 #------------------------------------------
405 heynotitool set setting_time_changed -a
406 sync
407
408 mkdir -p /opt/ug/bin/
409 ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
410 # ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
411
412 %files -n settings
413 %manifest settings.manifest
414 %defattr(-,root,root,-)
415 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
416 %attr(-,app,app) %dir /opt/data/setting
417 /opt/apps/org.tizen.setting/bin/setting
418 /opt/apps/org.tizen.setting/bin/setting_conf_util
419 /opt/data/setting/setting.cfg
420
421 /opt/share/packages/org.tizen.setting.xml
422 /opt/share/packages/ug-setting-accessibility-efl.xml
423 /opt/share/packages/ug-setting-font-efl.xml
424
425 /opt/share/icons/default/small/org.tizen.setting.png
426 /opt/share/settings/*
427 /opt/apps/org.tizen.setting/res/*
428 /opt/apps/org.tizen.setting/lib/*
429 /opt/apps/org.tizen.setting/data/*
430 /opt/ug/lib/*
431 /opt/data/setting/langlist.xml
432 /opt/data/setting/plugin-cfg/*
433 /opt/data/setting/plugin-xml/*
434 /opt/apps/org.tizen.setting/bin/test_server