Git init
[framework/system/libslp-sensor.git] / packaging / sensor.spec
1
2 Name:       sensor
3 Summary:    Sensor framework client library
4 Version:    0.5.6
5 Release:    1
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    sensor-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12 BuildRequires:  vconf-keys-devel
13 BuildRequires:  pkgconfig(sf_common)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(glib-2.0)
16
17
18 %description
19 Sensor framework client library
20
21
22
23 %package devel
24 Summary:    Sensor framework library (devel)
25 Group:      System/Sensor Framework
26 Requires:   %{name} = %{version}-%{release}
27
28 %description devel
29 Sensor framework client library (devel)
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34
35
36 %build
37 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38
39
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46
47
48
49 %post -p /sbin/ldconfig
50
51 %postun -p /sbin/ldconfig
52
53
54
55
56
57 %files
58 %defattr(-,root,root,-)
59 %doc COPYING
60 %{_libdir}/libsensor.so.*
61
62
63 %files devel
64 %defattr(-,root,root,-)
65 %{_includedir}/sensor/*.h
66 %{_libdir}/libsensor.so
67 %{_libdir}/pkgconfig/sensor.pc
68