update configure file
[framework/system/sensor-framework.git] / packaging / sensor-framework.spec
1 #sbs-git:slp/pkgs/s/sensor-framework sensor-framework 0.2.5 f585f766aa864c3857e93c776846771899a4fa41
2 Name:       sensor-framework
3 Summary:    Sensor framework
4 Version: 0.2.10
5 Release:    1
6 Group:      TO_BE/FILLED_IN
7 License:    LGPL
8 Source0:    %{name}-%{version}.tar.gz
9
10 Requires(post): /usr/bin/vconftool
11
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(sf_common)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(heynoti)
17 %description
18 Sensor framework
19
20 %prep
21 %setup -q
22
23 %build
24 cmake . -DCMAKE_INSTALL_PREFIX=/usr
25
26 make %{?jobs:-j%jobs}
27
28 %install
29 %make_install
30
31 %post 
32 vconftool set -t int memory/private/sensor/10001 0 -i
33 vconftool set -t int memory/private/sensor/10002 0 -i
34 vconftool set -t int memory/private/sensor/10004 0 -i
35 vconftool set -t int memory/private/sensor/10008 0 -i
36 vconftool set -t int memory/private/sensor/20001 0 -i
37 vconftool set -t int memory/private/sensor/20002 0 -i
38 vconftool set -t int memory/private/sensor/20004 0 -i
39 vconftool set -t int memory/private/sensor/200001 0 -i
40 vconftool set -t int memory/private/sensor/40001 0 -i
41 vconftool set -t int memory/private/sensor/40002 0 -i
42 vconftool set -t int memory/private/sensor/800001 0 -i
43 vconftool set -t int memory/private/sensor/800002 0 -i
44 vconftool set -t int memory/private/sensor/800004 0 -i
45 vconftool set -t int memory/private/sensor/800008 0 -i
46 vconftool set -t int memory/private/sensor/800010 0 -i
47 vconftool set -t int memory/private/sensor/800020 0 -i
48 vconftool set -t int memory/private/sensor/800040 0 -i
49 vconftool set -t int memory/private/sensor/800080 0 -i
50 vconftool set -t int memory/private/sensor/800100 0 -i
51 vconftool set -t int memory/private/sensor/80001 0 -i
52 vconftool set -t int memory/private/sensor/80002 0 -i
53 vconftool set -t int memory/private/sensor/poweroff 0 -i
54
55 mkdir -p /etc/rc.d/rc3.d
56 mkdir -p /etc/rc.d/rc4.d
57 ln -s /etc/rc.d/init.d/sfsvc /etc/rc.d/rc3.d/S40sfsvc
58 ln -s /etc/rc.d/init.d/sfsvc /etc/rc.d/rc4.d/S40sfsvc
59
60 %postun
61 rm -f /etc/rc.d/rc3.d/S40sfsvc
62 rm -f /etc/rc.d/rc4.d/S40sfsvc
63
64 %files
65 %defattr(-,root,root,-)
66 /usr/bin/sf_server
67 %{_sysconfdir}/rc.d/init.d/sfsvc
68 %attr(0644,root,root)/usr/etc/sf_data_stream.conf
69 %attr(0644,root,root)/usr/etc/sf_filter.conf
70 %attr(0644,root,root)/usr/etc/sf_processor.conf
71 %attr(0644,root,root)/usr/etc/sf_sensor.conf
72