resetting manifest requested domain to floor
[platform/core/system/sensor-framework.git] / packaging / sensor-framework.spec
1 #sbs-git:slp/pkgs/s/sensor-framework sensor-framework 0.2.5 f585f766aa864c3857e93c776846771899a4fa41
2 Name:       sensor-framework
3 Summary:    Sensor framework
4 Version: 0.2.30
5 Release:    1
6 Group:      Framework/system
7 License:    Apache License, Version 2.0
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    sensor-framework.service
10 Source1001:     sensor-framework.manifest
11
12 %ifarch %{arm}
13   #arm build
14   %define        _archtype arch_arm
15 %else
16   #ix86 build
17   %if 0%{?simulator}
18    #emul build target
19    %define       _archtype arch_sdk
20   %else
21    #IA build target
22    %define       _archtype arch_ia
23   %endif
24 %endif
25 Requires(post): /usr/bin/vconftool
26
27 BuildRequires:  cmake
28 BuildRequires:  pkgconfig(glib-2.0)
29 BuildRequires:  pkgconfig(sf_common)
30 BuildRequires:  pkgconfig(vconf)
31 BuildRequires:  pkgconfig(heynoti)
32
33 %description
34 Sensor framework
35
36 %prep
37 %setup -q
38 cp %{SOURCE1001} .
39
40 %build
41 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DPLATFORM_ARCH=%{_archtype}
42
43 make %{?jobs:-j%jobs}
44
45 %install
46 %make_install
47
48 mkdir -p %{buildroot}/usr/share/license
49 cp LICENSE %{buildroot}/usr/share/license/%{name}
50
51 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
52 install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/system/
53 ln -s ../sensor-framework.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/sensor-framework.service
54
55 # FIXME: remove initscripts after we start using systemd
56 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d
57 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc4.d
58 ln -s ../init.d/sfsvc %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S40sfsvc
59 ln -s ../init.d/sfsvc %{buildroot}%{_sysconfdir}/rc.d/rc4.d/S40sfsvc
60
61 %post 
62 vconftool set -t int memory/private/sensor/10001 0 -i
63 vconftool set -t int memory/private/sensor/10002 0 -i
64 vconftool set -t int memory/private/sensor/10004 0 -i
65 vconftool set -t int memory/private/sensor/10008 0 -i
66 vconftool set -t int memory/private/sensor/10010 0 -i
67 vconftool set -t int memory/private/sensor/20001 0 -i
68 vconftool set -t int memory/private/sensor/20002 0 -i
69 vconftool set -t int memory/private/sensor/20004 0 -i
70 vconftool set -t int memory/private/sensor/200001 0 -i
71 vconftool set -t int memory/private/sensor/40001 0 -i
72 vconftool set -t int memory/private/sensor/40002 0 -i
73 vconftool set -t int memory/private/sensor/800001 0 -i
74 vconftool set -t int memory/private/sensor/800002 0 -i
75 vconftool set -t int memory/private/sensor/800004 0 -i
76 vconftool set -t int memory/private/sensor/800008 0 -i
77 vconftool set -t int memory/private/sensor/800010 0 -i
78 vconftool set -t int memory/private/sensor/800020 0 -i
79 vconftool set -t int memory/private/sensor/800040 0 -i
80 vconftool set -t int memory/private/sensor/800080 0 -i
81 vconftool set -t int memory/private/sensor/800100 0 -i
82 vconftool set -t int memory/private/sensor/800200 0 -i
83 vconftool set -t int memory/private/sensor/800400 0 -i
84 vconftool set -t int memory/private/sensor/800800 0 -i
85 vconftool set -t int memory/private/sensor/80001 0 -i
86 vconftool set -t int memory/private/sensor/80002 0 -i
87 vconftool set -t int memory/private/sensor/poweroff 0 -i
88
89 %files
90 %manifest %{name}.manifest
91 %attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/sfsvc
92 %{_sysconfdir}/rc.d/rc3.d/S40sfsvc
93 %{_sysconfdir}/rc.d/rc4.d/S40sfsvc
94 %{_bindir}/sf_server
95 %attr(0644,root,root)/usr/etc/sf_data_stream.conf
96 %attr(0644,root,root)/usr/etc/sf_filter.conf
97 %attr(0644,root,root)/usr/etc/sf_processor.conf
98 %attr(0644,root,root)/usr/etc/sf_sensor.conf
99 %{_libdir}/systemd/system/sensor-framework.service
100 %{_libdir}/systemd/system/multi-user.target.wants/sensor-framework.service
101 /usr/share/license/%{name}
102