5 tests added - 1 smack_accesses_clear() test; 1 smack_revoke_subject() test; 1 smack...
[platform/core/test/security-tests.git] / packaging / security-tests.spec
1 #sbs-git:slp/pkgs/w/wrt-security wrt-security 0.0.43
2 Name:       security-tests
3 Summary:    Security repository for holding tests.
4 Version:    0.0.45
5 Release:    1
6 Group:      Development/Libraries
7 License:    Apache License, Version 2.0
8 URL:        N/A
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(libsmack)
12 BuildRequires: pkgconfig(libprivilege-control)
13 BuildRequires: pkgconfig(security-server)
14 BuildRequires: pkgconfig(dpl-test-efl)
15 BuildRequires: pkgconfig(dlog)
16 Requires:   smack
17 Requires:   libprivilege-control
18
19 %description
20 Security tests repository - for tests that can't be kept together with code.
21
22 %prep
23 %setup -q
24
25 %build
26 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib"
27
28 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
29         -DDPL_LOG="ON"                    \
30         -DVERSION=%{version}
31 make %{?jobs:-j%jobs}
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36 ln -sf /etc/smack/test_smack_rules %{buildroot}/etc/smack/test_smack_rules_lnk
37
38 %clean
39 rm -rf %{buildroot}
40
41 %post
42 find /etc/smack/test_privilege_control_DIR/ -type f -name exec -exec chmod 0755 {} +
43 echo "security-tests postinst done ..."
44
45 %postun
46
47 %files
48 %defattr(-, root, root, -)
49 /usr/bin/security-tests.sh
50 /usr/bin/security-tests-all.sh
51 /usr/bin/libsmack-test
52 /usr/bin/libprivilege-control-test
53 /usr/bin/security-server-tests-client-smack
54 /usr/bin/security-server-tests-label
55 /usr/bin/security-server-tests-pid-reuser
56 /usr/bin/security-server-tests-server
57 /usr/bin/security-server-tests-password
58 /etc/smack/test_smack_rules_full
59 /etc/smack/test_smack_rules2
60 /etc/smack/test_smack_rules3
61 /etc/smack/test_smack_rules4
62 /etc/smack/test_smack_rules
63 /etc/smack/test_smack_rules_lnk
64 /usr/share/privilege-control/*
65 /etc/smack/test_privilege_control_DIR/*