Added libprivilege-control tests.
[platform/core/test/security-tests.git] / packaging / security-tests.spec
1 #sbs-git:slp/pkgs/w/wrt-security wrt-security 0.0.43
2 Name:       security-tests
3 Summary:    Security repository for holding tests.
4 Version:    0.0.44
5 Release:    1
6 Group:      Development/Libraries
7 License:    Apache License, Version 2.0
8 URL:        N/A
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(libsmack)
12 BuildRequires: pkgconfig(libprivilege-control)
13 BuildRequires: pkgconfig(dpl-test-efl)
14 Requires:   cert-svc-test
15 Requires:   security-server-test
16
17 %description
18 Security tests repository - for tests that can't be kept together with code.
19
20 %prep
21 %setup -q
22
23 %build
24 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib"
25
26 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
27         -DDPL_LOG="ON"                    \
28         -DVERSION=%{version}
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33 %make_install
34 ln -sf /etc/smack/test_smack_rules %{buildroot}/etc/smack/test_smack_rules_lnk
35
36 %clean
37 rm -rf %{buildroot}
38
39 %post
40
41 echo "security-tests postinst done ..."
42
43 %postun
44
45 %files
46 /usr/bin/security-tests.sh
47 /usr/bin/security-tests-all.sh
48 /usr/bin/libsmack-test
49 /usr/bin/libprivilege-control-test
50 /etc/smack/test_smack_rules
51 /etc/smack/test_smack_rules_lnk
52 /usr/share/privilege-control/test_privilege_control_rules.smack
53 /etc/smack/test_privilege_control_DIR/*