Moved SMACK test from wrt-security repository.
[platform/core/test/security-tests.git] / packaging / security-tests.spec
1 #sbs-git:slp/pkgs/w/wrt-security wrt-security 0.0.43
2 Name:       security-tests
3 Summary:    Security repository for holding tests.
4 Version:    0.0.44
5 Release:    1
6 Group:      Development/Libraries
7 License:    Apache License, Version 2.0
8 URL:        N/A
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(libsmack)
12 BuildRequires: pkgconfig(dpl-test-efl)
13 Requires:   cert-svc-test
14 Requires:   security-server-test
15
16 %description
17 Security tests repository - for tests that can't be kept together with code.
18
19 %prep
20 %setup -q
21
22 %build
23 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib"
24
25 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
26         -DDPL_LOG="ON"                    \
27         -DVERSION=%{version}
28 make %{?jobs:-j%jobs}
29
30 %install
31 rm -rf %{buildroot}
32 %make_install
33 ln -sf /etc/smack/test_smack_rules %{buildroot}/etc/smack/test_smack_rules_lnk
34
35 %clean
36 rm -rf %{buildroot}
37
38 %post
39 echo "security-tests postinst done ..."
40
41 %postun
42
43 %files
44 /usr/bin/security-tests.sh
45 /usr/bin/security-tests-all.sh
46 /usr/bin/libsmack-test
47 /etc/smack/test_smack_rules
48 /etc/smack/test_smack_rules_lnk