Initial import to Tizen
[profile/ivi/python-twisted.git] / packaging / python-twisted.spec
1 Name:       python-twisted
2 Version:    12.1.0
3 Release:    1
4 Group:      System/Libraries
5 License:    MIT
6 Url:        http://twistedmatrix.com/
7 Summary:    An asynchronous networking framework written in Python
8 Source:     http://pypi.python.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
9 BuildRequires:  pkgconfig(python)
10 BuildRequires:  python-zope.interface
11 Requires:  python-xml
12 Requires:  python-pyOpenSSL
13 Requires:  python-PyPAM
14 Requires:  python-zope.interface
15 Provides:  python-twisted
16 Provides:  python-twisted-core
17 Provides:  python-twisted-conch
18 Provides:  python-twisted-lore
19 Provides:  python-twisted-mail
20 Provides:  python-twisted-name
21 Provides:  python-twisted-news
22 Provides:  python-twisted-runner
23 Provides:  python-twisted-web
24 Provides:  python-twisted-words
25 Provides:  python-twisted-xish
26
27 %description
28 An extensible framework for Python programming, with special focus
29 on event-based network programming and multiprotocol integration.
30
31 %prep
32 %setup -q -n Twisted-%{version}
33
34 %build
35 python setup.py build
36
37 %install
38 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
39 find %{buildroot} -regex '.*\.[ch]' -exec rm {} ";" # Remove leftover C sources
40 install -dm0755 %{buildroot}/%{_mandir}/man1/
41 install -m0644 doc/*/man/*.1 %{buildroot}/%{_mandir}/man1/ # Install man pages
42 find doc -type f -print0 | xargs -0 chmod a-x # Fix doc-file dependency by removing x flags
43 sed -i "s/\r//" doc/core/howto/listings/udp/{MulticastClient,MulticastServer}.py
44
45 %files
46 %defattr(-,root,root,-)
47 %doc LICENSE NEWS README
48 %doc doc/*
49 %{_bindir}/cftp
50 %{_bindir}/ckeygen
51 %{_bindir}/conch
52 %{_bindir}/lore
53 %{_bindir}/mailmail
54 %{_bindir}/manhole
55 %{_bindir}/pyhtmlizer
56 %{_bindir}/tap2deb
57 %{_bindir}/tap2rpm
58 %{_bindir}/tapconvert
59 %{_bindir}/tkconch
60 %{_bindir}/trial
61 %{_bindir}/twistd
62 %{_mandir}/man1/*
63 %{python_sitearch}/*