Update to 2.28 for TINF-96
[profile/ivi/pygobject2.git] / packaging / pygobject.spec
1 # Last updated for version 2.21.0
2 %define glib2_version                  2.22.4
3 %define python2_version                2.3.5
4
5 ### Abstract ###
6
7 Name: pygobject2
8 Version: 2.28.6
9 Release: 3%{?dist}
10 License: LGPLv2+
11 Group: Development/Languages
12 Summary: Python 2 bindings for GObject 
13 URL: http://www.pygtk.org/
14 BuildRoot: %{_tmppath}/%{name}-%{version}-root
15 #VCS: git:git://git.gnome.org/pygobject
16 Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.28/pygobject-%{version}.tar.bz2
17
18 ### Patches ###
19
20 ### Build Dependencies ###
21
22 BuildRequires: glib2-devel >= %{glib2_version}
23 BuildRequires: python2-devel >= %{python2_version}
24
25 # Bootstrap requirements
26 BuildRequires: automake autoconf libtool
27
28 %description
29 The %{name} package provides a convenient wrapper for the GObject library
30 for use in Python programs.
31
32 %package codegen
33 Summary: The code generation program for PyGObject
34 Group: Development/Languages
35
36 %description codegen
37 The package contains the C code generation program for PyGObject.
38
39 %package devel
40 Summary: Development files for building add-on libraries
41 Group: Development/Languages
42 Requires: %{name} = %{version}-%{release}
43 Requires: %{name}-codegen = %{version}-%{release}
44 Requires: %{name}-doc = %{version}-%{release}
45 Requires: glib2-devel
46 Requires: pkgconfig
47
48 %description devel
49 This package contains files required to build wrappers for %{name}-based
50 libraries such as pygtk2.
51
52 %package doc
53 Summary: Documentation files for %{name}
54 Group: Development/Languages
55
56 %description doc
57 This package contains documentation files for %{name}.
58
59 %prep
60 %setup -q -n pygobject-%{version}
61
62 find -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python}|'
63
64 %build
65 PYTHON=%{__python} 
66 export PYTHON
67 %configure --disable-introspection
68 make %{?_smp_mflags}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 make DESTDIR=$RPM_BUILD_ROOT install
74 find $RPM_BUILD_ROOT -name '*.la' -delete
75 find $RPM_BUILD_ROOT -name '*.a' -delete
76
77 rm examples/Makefile*
78
79 %files
80 %defattr(644, root, root, 755)
81 %doc AUTHORS NEWS README
82 %doc examples
83
84 %{_libdir}/libpyglib-2.0-python.so*
85 %dir %{python_sitearch}/gtk-2.0
86 %dir %{python_sitearch}/gobject
87 %dir %{python_sitearch}/glib
88
89 %{python_sitearch}/gtk-2.0/*
90 %{python_sitearch}/pygtk.*
91 %{python_sitearch}/gobject/*
92 %{python_sitearch}/glib/*
93
94 %files codegen
95 %defattr(755, root, root, 755)
96 %{_bindir}/pygobject-codegen-2.0
97 %defattr(644, root, root, 755)
98 %dir %{_datadir}/pygobject/2.0
99 %{_datadir}/pygobject/2.0/codegen
100
101 %files devel
102 %defattr(644, root, root, 755)
103 %dir %{_datadir}/pygobject
104 %dir %{_includedir}/pygtk-2.0
105 %{_datadir}/pygobject/2.0/defs
106 %{_includedir}/pygtk-2.0/pyglib.h
107 %{_includedir}/pygtk-2.0/pygobject.h
108 %{_libdir}/pkgconfig/pygobject-2.0.pc
109
110 %files doc
111 %defattr(644, root, root, 755)
112 %{_datadir}/gtk-doc/html/pygobject
113 %{_datadir}/pygobject/xsl
114
115 %changelog
116 * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.28.6-3
117 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
118
119 * Thu Aug 18 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.6-2
120 - disable introspection in anticipation of pygobject3
121 - https://bugzilla.redhat.com/show_bug.cgi?id=731851
122 - pygobject2 now becomes legacy for static binding support (e.g. PyGTK)
123
124 * Mon Jun 13 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.6-1
125 - update to upstream 2.28.6
126 - closure: avoid double free crash
127 - GVariantType is a boxed struct in newer versions of glib
128 - Revert back to a GVariant workaround since the fix hasn't migrated to
129   Fedora's version of glib yet (workaround works in both cases)
130 - closure: Check the out arg is not null.
131 - Fix GC-related crash during PyGObject deallocation (remove patch from
132   previous spec)
133
134 * Mon Jun 06 2011 Daniel Drake <dsd@laptop.org> - 2.28.4-3
135 - add upstream patch to solve Python GC crash during gobject deallocation
136
137 * Thu Apr 21 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.4-2
138 - require gobject-introspection version 0.10.8
139
140 * Thu Apr 21 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.4-1
141 - update to upstream 2.28.4
142
143 * Tue Mar 22 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.3-1
144 - update to upstream 2.28.3
145
146 * Mon Mar 21 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.2-1
147 - update to upstream version 2.28.2 stable
148 - fixes issue in bug - https://bugzilla.redhat.com/show_bug.cgi?id=682543
149
150 * Mon Mar 21 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.1-1
151 - update to upstream version 2.28.1 stable
152 - fix the spec file's sources line to point to the correct ftp directory
153
154 * Tue Mar 08 2011 John (J5) Palmieri <johnp@redhat.com> - 2.28.0-1
155 - update to upstream version 2.28.0 stable
156
157 * Mon Feb 28 2011 John (J5) Palmieri <johnp@redhat.com> - 2.27.91-1
158 - update to upstream version 2.27.91
159
160 * Fri Feb 09 2011 John (J5) Palmieri <johnp@redhat.com> - 2.27.90-2
161 - update files manifest to reflect files that moved around
162
163 * Fri Feb 09 2011 John (J5) Palmieri <johnp@redhat.com> - 2.27.90-1
164 - update to upstream version 2.27.90
165
166 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.27.0-2
167 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
168
169 * Wed Nov 10 2010 John (J5) Palmieri <johnp@redhat.com> - 2.27.0-1
170 - update to upstream version 2.27.0
171
172 * Thu Sep 30 2010 John (J5) Palmieri <johnp@redhat.com> - 2.26.0-4
173 - Edit PyCapsule patch to only use PyCapsule in Python 3.x
174   since this effects header files which require other modules to 
175   be recompiled.  There is actually discussion upstream to undeprecate it
176   for the 2.x series
177
178 * Tue Sep 28 2010 John (J5) Palmieri <johnp@redhat.com> - 2.26.0-3
179 - add patch to work with PyCapsule since PyCObject is removed from 
180   Python 3.2 which we ship in rawhide
181
182 * Tue Sep 28 2010 John (J5) Palmieri <johnp@redhat.com> - 2.26.0-2
183 - add another py3k patch so that we compile correctly under python 3
184 - fixes a couple of print syntax and a try, except syntax
185
186 * Tue Sep 28 2010 John (J5) Palmieri <johnp@redhat.com> - 2.26.0-1
187 - Update to upstream 2.26.0
188 - package python3-gobject module
189
190 * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.21.5-3
191 - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
192
193 * Wed Jul 14 2010 Colin Walters <walters@verbum.org> - 2.21.5-2
194 - Rebuild against new gobject-introspection
195 - Strip noarch docs hack, seems obsolete now
196
197 * Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 2.21.5-1
198 - New upstream version
199
200 * Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 2.21.4-5
201 - Require g-i 0.9.0 
202
203 * Wed Jul  7 2010 Colin Walters <walters@verbum.org> - 2.21.4-4
204 - Update to latest upstream
205 - Drop upstreamed patches
206 - Require pycairo, since we have a module that uses it
207 - Drop libtool overriding; was not commented and seems fine
208   without
209 - Drop --enable-thread, it's default now
210 - Drop --enable-pygi, it's default now
211 - Drop clean section, no longer needed in F-14
212 - Drop python-sitearch copy&paste, no longer needed in F-14
213 - Add SMP flags to make
214
215 * Thu May 27 2010 Colin Walters <walters@verbum.org> - 2.21.1-9
216 - Readd my patch to not blow up mysteriously
217   Resolves: #596392
218
219 * Mon May 24 2010 Colin Walters <walters@verbum.org> - 2.21.1-7
220 - Reenable pygi in preparation for getting it packaged
221
222 * Wed May 05 2010 Colin Walters <walters@verbum.org> - 2.21.1-6
223 - Switch to disabling pygi, remove my patch for now.  See commentary
224   https://bugzilla.redhat.com/show_bug.cgi?id=569885#c38
225
226 * Wed May 05 2010 Colin Walters <walters@verbum.org> - 2.21.1-5
227 - Another patch to clear error when we've enabled pygi
228   Should really fix bug #569885
229
230 * Fri Mar 26 2010 Colin Walters <walters@verbum.org> - 2.21.1-4
231 - Cherrypick patch from HEAD to fix pygi imports
232   Hopefully fixes bug #569885
233
234 * Sat Jan 23 2010 Thomas Spura <tomspur@fedoraproject.org> - 2.21.1-3
235 - add --enable-pygi (fixes bug #558003)
236 - replace global with define
237
238 * Fri Jan 08 2010 Matthew Barnes <mbarnes@redhat.com> - 2.21.1-2.fc13
239 - Provide a complete URI for the Source field.
240
241 * Sat Jan 02 2010 Matthew Barnes <mbarnes@redhat.com> - 2.21.1-1.fc13
242 - Update to 2.21.1
243
244 * Sun Dec 20 2009 Matthew Barnes <mbarnes@redhat.com> - 2.21.0-1.fc13
245 - Update to 2.21.0
246
247 * Wed Sep 23 2009 Matthew Barnes <mbarnes@redhat.com> - 2.20.0-1.fc12
248 - Update to 2.20.0
249
250 * Tue Aug 11 2009 Matthew Barnes <mbarnes@redhat.com> - 2.19.0-1.fc12
251 - Update to 2.19.0
252
253 * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.18.0-2
254 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
255
256 * Mon May 25 2009 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc12
257 - Update to 2.18.0
258
259 * Thu Apr 30 2009 Matthew Barnes <mbarnes@redhat.com> - 2.17.1-1.fc12
260 - Update to 2.17.0
261 - Remove patch for GNOME bug #566571 (fixed upstream).
262
263 * Wed Apr 22 2009 Matthew Barnes <mbarnes@redhat.com> - 2.16.1-4.fc11
264 - Add patch for GNOME bug #566571 (classic vs new-style inheritance crash).
265
266 * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.16.1-3
267 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
268
269 * Tue Feb 24 2009 Matthias Clasen <mclasen@redhat.com> - 2.16.1-2
270 - Make -doc noarch
271
272 * Sun Feb 22 2009 - Matthew Barnes <mbarnes@redhat.com> - 2.16.1-1.fc11
273 - Update to 2.16.1
274
275 * Sun Jan 04 2009 - Matthew Barnes <mbarnes@redhat.com> - 2.16.0-1.fc11
276 - Update to 2.16.0
277 - Remove patch for RH bug #457502 (fixed upstream).
278 - Remove patch for GNOME bug #551059 and #551212 (fixed upstream).
279
280 * Sat Nov 29 2008 - Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.15.4-4
281 - Rebuild for Python 2.6
282
283 * Tue Oct 21 2008 - Bastien Nocera <bnocera@redhat.com> - 2.15.4-3.fc10
284 - Add patch to fix typos breaking compilation
285
286 * Tue Oct 21 2008 - Bastien Nocera <bnocera@redhat.com> - 2.15.4-2.fc10
287 - Add 2-liner fixing the load_contents functions not working appropriately
288
289 * Wed Sep 03 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.4-1.fc10
290 - Update to 2.15.4
291
292 * Sun Aug 31 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.3-1.fc10
293 - Update to 2.15.3
294
295 * Tue Aug 12 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.2-3.fc10
296 - Modify thread initialization patch to fix RH bug #458522.
297
298 * Thu Aug 07 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.2-2.fc10
299 - Add patch for RH bug #457502 (error on gtk.gdk.threads_init).
300
301 * Sat Jul 26 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.2-1.fc10
302 - Update to 2.15.2
303
304 * Sun Jul 20 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.1-2.fc10
305 - Fix directory ownership.  (RH bug #455974, patch by Robert Scheck).
306
307 * Wed Jul 16 2008 Matthew Barnes <mbarnes@redhat.com> - 2.15.1-1.fc10
308 - Update to 2.15.1
309 - Bump glib2_version to 2.16.0.
310 - Remove ancient automake_version.
311 - Add a pygobject2-codegen subpackage.
312
313 * Fri May 23 2008 Matthew Barnes <mbarnes@redhat.com> - 2.14.2-1.fc10
314 - Update to 2.14.2
315
316 * Sun Feb 17 2008 Matthew Barnes <mbarnes@redhat.com> - 2.14.1-2.fc9
317 - Rebuild with GCC 4.3
318
319 * Thu Jan 03 2008 Matthew Barnes <mbarnes@redhat.com> - 2.14.1-1.fc9
320 - Update to 2.14.1
321
322 * Fri Oct 26 2007 Matthew Barnes <mbarnes@redhat.com> - 2.14.0-2.fc9
323 - Remove redundant requirements.
324 - Use name tag where appropriate.
325
326 * Sun Sep 16 2007 Matthew Barnes <mbarnes@redhat.com> - 2.14.0-1.fc8
327 - Update to 2.14.0
328
329 * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.13.2-3
330 - Rebuild for selinux ppc32 issue.
331
332 * Wed Aug  8 2007 Matthias Clasen <mclasen@redhat.com> - 2.13.2-2
333 - Update the license field
334
335 * Sat Jul 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.13.2-1.fc8
336 - Update to 2.13.2
337
338 * Fri May 18 2007 Matthew Barnes <mbarnes@redhat.com> - 2.13.1-1.fc8
339 - Update to 2.13.1
340 - Remove patch for RH bug #237179 (fixed upstream).
341
342 * Thu May 03 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-5.fc7
343 - Fix devel subpackage dependency (RH bug #238793).
344
345 * Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
346 - Add patch for RH bug #237179 (memory leak).
347
348 * Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
349 - rebuild against python 2.5
350
351 * Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
352 - Update to 2.12.3
353
354 * Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
355 - Add subpackage pygobject2-doc (bug #205231).
356
357 * Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
358 - Use python_sitearch instead of python_sitelib.
359
360 * Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
361 - Update to 2.12.2
362
363 * Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
364 - Require glib2-devel for the -devel package.
365
366 * Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
367 - Define a python_sitelib macro for files under site_packages.
368 - Spec file cleanups.
369
370 * Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
371 - Update to 2.12.1
372 - Require pkgconfig for the -devel package
373
374 * Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
375 - Update to 2.11.4
376 - Use pre-built docs
377
378 * Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
379 - Update to 2.11.3
380
381 * Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
382 - BR libxslt
383
384 * Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
385 - Update to 2.11.2
386
387 * Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
388 - rebuild
389
390 * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
391 - Update to 2.11.0
392
393 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
394 - rebuild
395 - Add missing br libtool
396
397 * Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
398 - Cleanup
399
400 * Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
401 - Initial package