Tizen 2.1 base
[platform/adaptation/intel_mfld/pvr-bin-mdfld.git] / packaging / pvr-bin-mdfld.spec
1 %define debug_package %{nil}
2 %define binrelease 7
3
4 Name:           pvr-bin-mdfld
5 Version:        1.7.17.296760.%{binrelease}
6 Release:        1
7 License:        Intel Free Distribution Binary License
8 Summary:        Binary graphics driver and libraries from PowerVR
9 Group:          Development/Libraries
10 Source0:        %{name}-%{version}.tar.bz2
11 Source10:       license.txt
12 Source100:      pvr-bin-mdfld-rpmlintrc
13 Requires:       libwsbm
14 Requires:       pciutils
15 Provides:       libEGL.so.1
16 Provides:       libGLESv2.so.1
17 ExclusiveArch: %{ix86} x86_64
18 AutoReqProv: no
19 Provides:       libEGL.so
20 Provides:       libGLESv1_CM.so
21 Provides:       libGLESv2.so
22
23 %description
24 PowerVR graphics driver and runtime library.
25
26 %package tests
27 Summary:        Unit tests for pvr driver
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}
30 AutoReqProv: no
31
32 %description tests
33 Unit tests for pvr-video libraries.
34
35 %package devel
36 Summary:        Development package for pvr driver
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}
39 Conflicts:  mesa-libEGL-devel mesa-libGLESv1-devel mesa-libGLESv2-devel mesa-libOpenVG-devel
40
41 %description devel
42 pvr-bin development package
43
44 %prep
45 %setup -q -n  %{name}-%{version}
46
47 # HACK: need to move (linker) .so links from devel to the main package because
48 #       sonames are wrong in the libraries
49 find devel/usr/lib/ -name '*.so' | xargs -I {} mv {} main/usr/lib/
50
51 %build
52
53 %install
54 install -d %{buildroot}
55 cp -arv  main/* %{buildroot}/
56 cp -arv  tests/* %{buildroot}/
57 cp -arv  devel/* %{buildroot}/
58
59 # create lists of files
60 find main -type f -o -type l | \
61     sed s'![^/]*!!' > files.list
62 # add config macro in front of config files
63 sed -i s'!^\(/etc*\)!%config \1!' files.list
64 sed -i s'!^\(/opt/etc*\)!%config \1!' files.list
65
66 find tests -type f -o -type l | \
67     sed s'![^/]*!!' > files-tests.list
68
69 find devel -type f -o -type l | \
70     sed s'![^/]*!!' > files-devel.list
71
72
73 %post -p /sbin/ldconfig
74
75 %postun -p /sbin/ldconfig
76
77
78 %files -f files.list
79
80 %files tests -f files-tests.list
81
82 %files devel -f files-devel.list
83
84