efed06e8c9021eaae8354a73ea4454f8e638cab3
[platform/core/appfw/sppc.git] / packaging / push.spec
1 %global _support_weblog 0
2
3 # Do not provide .so automatically for the extensions.
4 # This if statement is for backward compatibility with GBM/Obsolete build systems
5 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
6 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
7 %endif
8
9 Name:       push
10 Summary:    Push services and client library
11 Version:    0.4.69
12 Release:    1
13 Group:      Application Framework/Service
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1:    pushd.service
17 Source2:    pushd.path
18 Requires(post): /sbin/ldconfig
19 Requires(post): /usr/bin/sqlite3
20 Requires(postun): /sbin/ldconfig
21 BuildRequires:  pkgconfig(libtzplatform-config)
22
23 # There are not ready for .so files of tv/wearable aarch64 and x86_64
24 %if "%{?profile}" == "wearable"
25 ExcludeArch: aarch64 x86_64
26 %endif
27
28 %if "%{?profile}" == "tv"
29 ExcludeArch: aarch64
30 %endif
31
32 %if %{_support_weblog}
33 BuildRequires:  pkgconfig(zlib)
34 BuildRequires:  pkgconfig(json-glib-1.0)
35 %endif
36
37 %description
38 Push services and client library.
39
40 %package -n libpush
41 Summary:    Push service client library
42 Group:      Application Framework/Libraries
43 Requires:   %{name}-bin = %{version}-%{release}
44 Requires:       libpush-compat = %{version}-%{release}
45 Recommends:     libpush-profile_common = %{version}-%{release}
46 %description -n libpush
47 Push service client library
48
49 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
50 # if mobile || ivi || common || "undefined"
51 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
52 %package -n libpush-profile_common
53 Summary:    Push service client library for common/mobile/ivi
54 Group:      Application Framework/Libraries
55 Provides:       libpush-compat = %{version}-%{release}
56 Provides:       libpush-profile_mobile = %{version}-%{release}
57 Provides:       libpush-profile_ivi = %{version}-%{release}
58 Conflicts:      libpush-profile_wearable
59 Conflicts:      libpush-profile_tv
60 %description -n libpush-profile_common
61 Push service client library for common/mobile/ivi
62 %endif
63
64 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
65 # if tv || "undefined"
66 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
67 %package -n libpush-profile_tv
68 Summary:    Push service client library for tv
69 Group:      Application Framework/Libraries
70 Provides:       libpush-compat = %{version}-%{release}
71 Conflicts:      libpush-profile_common
72 Conflicts:      libpush-profile_wearable
73 %description -n libpush-profile_tv
74 Push service client library for tv
75 %endif
76
77 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
78 # if wearable || "undefined"
79 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
80 %package -n libpush-profile_wearable
81 Summary:    Push service client library for wearable
82 Group:      Application Framework/Libraries
83 Provides:       libpush-compat = %{version}-%{release}
84 Conflicts:      libpush-profile_common
85 Conflicts:      libpush-profile_tv
86 %description -n libpush-profile_wearable
87 Push service client library for wearable
88 %endif
89
90 %package -n libpush-devel
91 Summary:    Push service client library (DEV)
92 Group:      Development/Libraries
93 Requires:   libpush = %{version}-%{release}
94 Requires:   capi-appfw-application-devel
95 %description -n libpush-devel
96 Push service client library (DEV)
97
98 %package bin
99 Summary:    Push service daemon
100 Group:      Application Framework/Service
101 Requires:       %{name}-bin-compat = %{version}-%{release}
102 Recommends:     %{name}-bin-profile_common = %{version}-%{release}
103 %description bin
104 Push service daemon
105
106 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
107 # if mobile || ivi || common || "undefined"
108 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
109 %package bin-profile_common
110 Summary:    Push service daemon for mobile/common/ivi
111 Group:      Application Framework/Service
112 Provides:       %{name}-bin-compat = %{version}-%{release}
113 Provides:       %{name}-bin-profile_mobile = %{version}-%{release}
114 Provides:       %{name}-bin-profile_ivi = %{version}-%{release}
115 Conflicts:      %{name}-bin-profile_wearable
116 Conflicts:      %{name}-bin-profile_tv
117 %description bin-profile_common
118 Push service daemon for mobile/common/ivi
119 %endif
120
121 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
122 # if tv || "undefined"
123 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
124 %package bin-profile_tv
125 Summary:    Push service daemon for tv
126 Group:      Application Framework/Service
127 Provides:       %{name}-bin-compat = %{version}-%{release}
128 Conflicts:      %{name}-bin-profile_wearable
129 Conflicts:      %{name}-bin-profile_common
130 %description bin-profile_tv
131 Push service daemon for tv
132 %endif
133
134 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
135 # if wearable || "undefined"
136 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
137 %package bin-profile_wearable
138 Summary:    Push service daemon for wearable
139 Group:      Application Framework/Service
140 Provides:       %{name}-bin-compat = %{version}-%{release}
141 Conflicts:      %{name}-bin-profile_tv
142 Conflicts:      %{name}-bin-profile_common
143 %description bin-profile_wearable
144 Push service daemon for wearable
145 %endif
146
147 %package tool
148 Summary:    Push service tool
149 Group:      Development/Tools
150 Requires:   libpush = %{version}-%{release}
151 Requires:   %{name}-bin = %{version}-%{release}
152 Requires:       %{name}-tool-compat = %{version}-%{release}
153 Recommends:     %{name}-tool-profile_common = %{version}-%{release}
154 %description tool
155 Push service tool
156
157 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
158 # if mobile || ivi || common || "undefined"
159 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
160 %package tool-profile_common
161 Summary:    Push service tool for mobile/common/ivi
162 Group:      Development/Tools
163 Provides:       %{name}-tool-compat = %{version}-%{release}
164 Provides:       %{name}-tool-profile_mobile = %{version}-%{release}
165 Provides:       %{name}-tool-profile_ivi = %{version}-%{release}
166 Conflicts:      %{name}-tool-profile_wearable
167 Conflicts:      %{name}-tool-profile_tv
168 %description tool-profile_common
169 Push service tool for mobile/common/ivi
170 %endif
171
172 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
173 # if tv || "undefined"
174 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
175 %package tool-profile_tv
176 Summary:    Push service tool for tv
177 Group:      Development/Tools
178 Provides:       %{name}-tool-compat = %{version}-%{release}
179 Conflicts:      %{name}-tool-profile_wearable
180 Conflicts:      %{name}-tool-profile_common
181 %description tool-profile_tv
182 Push service tool for tv
183 %endif
184
185 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
186 # if wearable || "undefined"
187 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
188 %package tool-profile_wearable
189 Summary:    Push service tool for wearable
190 Group:      Development/Tools
191 Provides:       %{name}-tool-compat = %{version}-%{release}
192 Conflicts:      %{name}-tool-profile_tv
193 Conflicts:      %{name}-tool-profile_common
194 %description tool-profile_wearable
195 Push service tool for wearable
196 %endif
197
198 %define _upgrade_script_path /usr/share/upgrade/scripts/
199 %define _upgrade_script 500.sppc.sh
200
201 %prep
202 %setup -q
203
204 %build
205
206 %install
207 rm -rf %{buildroot}
208 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
209 install -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/pushd.service
210
211 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
212 # if mobile || ivi || common || "undefined"
213 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
214 install -m 0644 %{SOURCE2} %{buildroot}%{_unitdir}/pushd.path
215 %endif
216
217 %ifarch %{ix86} || %{arm}
218 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
219 # if wearable || tv || "undefined"
220 %if "%{?profile}" != "mobile" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
221 %install_service multi-user.target.wants pushd.service
222 %endif
223
224 %endif //%ifarch %{ix86} || %{arm}
225
226 mkdir -p %{buildroot}/usr/share/licenses/%{name}
227 cp -f LICENSE %{buildroot}/usr/share/licenses/%{name}
228
229 mkdir -p %{buildroot}%{_includedir}
230 cp -a include/push-service.h %{buildroot}%{_includedir}
231 cp -a include/push.h %{buildroot}%{_includedir}
232 %if %{_support_weblog}
233         include/pushlog.h %{buildroot}%{_includedir}
234 %endif
235
236 mkdir -p %{buildroot}%{_libdir}/pkgconfig
237 cp -a push.pc %{buildroot}%{_libdir}/pkgconfig/
238 mkdir -p %{buildroot}%{_bindir}
239
240 mkdir -p %{buildroot}%{_upgrade_script_path}
241 cp -f scripts/%{_upgrade_script} %{buildroot}%{_upgrade_script_path}
242
243 mkdir -p %{buildroot}/usr/share/push
244
245 %ifarch %{arm}
246
247 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
248 # if mobile || ivi || common || "undefined"
249 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
250 pushd arm/lib/
251 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
252 popd
253 pushd arm/bin/
254 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
255 popd
256 pushd arm/share/push/
257 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
258 popd
259 %if %{_support_weblog}
260         arm/bin/pushlog_tool
261 %endif
262 %endif
263
264 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
265 # if tv || "undefined"
266 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
267 pushd arm_tv/lib/
268 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.tv"; done
269 popd
270 pushd arm_tv/bin/
271 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.tv"; done
272 popd
273 pushd arm_tv/share/push/
274 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.tv"; done
275 popd
276 %if %{_support_weblog}
277         arm_tv/bin/pushlog_tool
278 %endif
279 %endif
280
281 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
282 # if wearable || "undefined"
283 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
284 pushd arm_wearable/lib/
285 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.wearable"; done
286 popd
287 pushd arm_wearable/bin/
288 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.wearable"; done
289 popd
290 pushd arm_wearable/share/push/
291 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.wearable"; done
292 popd
293 %if %{_support_weblog}
294         arm_wearable/bin/pushlog_tool
295 %endif
296 %endif
297
298 %endif //%ifarch %{arm}
299
300 %ifarch aarch64
301
302 pushd aarch64/lib64/
303 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
304 popd
305 pushd aarch64/bin/
306 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
307 popd
308 pushd aarch64/share/push/
309 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
310 popd
311
312 %if %{_support_weblog}
313         aarch64/bin/pushlog_tool
314 %endif
315 %endif
316
317 %ifarch %{ix86}
318
319 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
320 # if mobile || ivi || common || "undefined"
321 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
322 pushd x86/lib/
323 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
324 popd
325 pushd x86/bin/
326 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
327 popd
328 pushd x86/share/push/
329 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
330 popd
331 %if %{_support_weblog}
332         x86/bin/pushlog_tool
333 %endif
334 %endif
335
336 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
337 # if tv || "undefined"
338 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
339 pushd x86_tv/lib/
340 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.tv"; done
341 popd
342 pushd x86_tv/bin/
343 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.tv"; done
344 popd
345 pushd x86_tv/share/push/
346 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.tv"; done
347 popd
348 %if %{_support_weblog}
349         x86_tv/bin/pushlog_tool
350 %endif
351 %endif
352
353 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
354 # if wearable || "undefined"
355 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
356 pushd x86_wearable/lib/
357 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.wearable"; done
358 popd
359 pushd x86_wearable/bin/
360 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.wearable"; done
361 popd
362 pushd x86_wearable/share/push/
363 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.wearable"; done
364 popd
365 %if %{_support_weblog}
366         x86_wearable/bin/pushlog_tool
367 %endif
368 %endif
369
370 %endif //%ifarch %{ix86}
371
372
373 %ifarch x86_64
374 pushd x86_64/lib64/
375 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
376 # if mobile || ivi || common || "undefined"
377 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
378 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
379 popd
380 pushd x86_64/bin/
381 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
382 popd
383 pushd x86_64/share/push/
384 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
385 popd
386 %if %{_support_weblog}
387         x86_64/bin/pushlog_tool
388 %endif
389 %endif
390
391
392 %endif //%ifarch %{x86_64}
393
394
395
396
397
398 %post bin
399 mkdir -p %{TZ_SYS_GLOBALUSER_DB}
400 sqlite3 %{TZ_SYS_GLOBALUSER_DB}/.push.db "PRAGMA journal_mode = PERSIST; create table a(a); drop table a;" > /dev/null
401 chown service_fw:service_fw %{TZ_SYS_GLOBALUSER_DB}/.push.db
402 chown service_fw:service_fw %{TZ_SYS_GLOBALUSER_DB}/.push.db-journal
403 chmod 644 %{TZ_SYS_GLOBALUSER_DB}/.push.db
404 chmod 644 %{TZ_SYS_GLOBALUSER_DB}/.push.db-journal
405
406 chsmack -a "*" %{TZ_SYS_GLOBALUSER_DB}/.push.db
407 chsmack -a "*" %{TZ_SYS_GLOBALUSER_DB}/.push.db-journal
408
409 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
410 # if mobile || ivi || common || "undefined"
411 %if "%{?profile}" != "wearable" || "%{?profile}" != "tv"
412 ln -sf ../pushd.path  %{_unitdir}/multi-user.target.wants/
413 %endif
414
415
416 %ifarch %{ix86} || %{arm}
417 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
418 # if tv || "undefined"
419 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
420 %post bin-profile_tv
421 pushd %{_bindir}
422 for FILE in push*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
423 popd
424 pushd /usr/share/push/
425 for FILE in Push*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
426 popd
427
428 %post tool-profile_tv
429 ln -sf push_tool.tv %{_bindir}/push_tool
430
431 %post -n libpush-profile_tv
432 pushd %{_libdir}
433 for FILE in libpush.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
434 popd
435 /sbin/ldconfig
436
437 %endif
438
439 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
440 # if wearable || "undefined"
441 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
442 %post bin-profile_wearable
443 pushd %{_bindir}
444 for FILE in push*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
445 popd
446 pushd /usr/share/push/
447 for FILE in Push*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
448 popd
449
450 %post tool-profile_wearable
451 ln -sf push_tool.wearable %{_bindir}/push_tool
452
453 %post -n libpush-profile_wearable
454 pushd %{_libdir}
455 for FILE in libpush.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
456 popd
457 /sbin/ldconfig
458
459 %endif
460
461 %endif //%ifarch %{ix86} || %{arm}
462
463
464 %files -n libpush
465 %manifest libpush.manifest
466 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
467 # if mobile || ivi || common || "undefined"
468 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
469 %attr(755,root,root) %{_libdir}/libpush.so*
470 %exclude %{_libdir}/libpush.so*.tv
471 %exclude %{_libdir}/libpush.so*.wearable
472 %endif
473
474 %files -n libpush-devel
475 %{_includedir}/*.h
476 %{_libdir}/pkgconfig/*.pc
477
478 %files bin
479 %manifest push-bin.manifest
480 %{_unitdir}/pushd.service
481 %attr(644,root,root) /usr/share/licenses/%{name}/LICENSE
482 %{_upgrade_script_path}%{_upgrade_script}
483 %attr(755,root,root) %{_upgrade_script_path}%{_upgrade_script}
484
485 %files tool
486 %manifest push-tool.manifest
487 %if %{_support_weblog}
488         %{_bindir}/pushlog_tool
489 %endif
490
491 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
492 # if mobile || ivi || common || "undefined"
493 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
494
495 %files -n libpush-profile_common
496 # default .so files are housed in the main pkg.
497
498 %files bin-profile_common
499 %{_bindir}/pushd
500 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer
501 %{_unitdir}/pushd.path
502
503 %files tool-profile_common
504 %{_bindir}/push_tool
505
506 %endif
507
508 %ifarch %{ix86} || %{arm}
509 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
510 # if tv || "undefined"
511 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
512
513 %files -n libpush-profile_tv
514 %manifest libpush.manifest
515 %attr(755,root,root) %{_libdir}/libpush.so*.tv
516
517 %files bin-profile_tv
518 %{_bindir}/pushd.tv
519 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer.tv
520 %{_unitdir}/multi-user.target.wants/pushd.service
521
522 %files tool-profile_tv
523 %{_bindir}/push_tool.tv
524
525 %endif
526
527 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
528 # if wearable || "undefined"
529 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
530
531 %files -n libpush-profile_wearable
532 %manifest libpush.manifest
533 %attr(755,root,root) %{_libdir}/libpush.so*.wearable
534
535 %files bin-profile_wearable
536 %{_bindir}/pushd.wearable
537 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer.wearable
538 %{_unitdir}/multi-user.target.wants/pushd.service
539
540 %files tool-profile_wearable
541 %{_bindir}/push_tool.wearable
542
543 %endif
544
545 %endif //%ifarch %{ix86} || %{arm}
546
547 %changelog
548 * Sat Nov 3 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.26
549 - Prevent bug fixed(out-of bounds read, dead code,..)
550 * Mon Oct 22 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.25
551 - bundle null check added & protobuf null check added
552 * Wed Sep 19 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.24
553 - when pkg is uninstalled, db process is added
554 * Fri Sep 7 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.23
555 - emul check logic is changed(using capi-system-info)
556 * Tue Sep 4 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.22
557 - decoding of message with space character which is urlencoded to "+"
558 * Wed Aug 29 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.21
559 - package uninstalled event added
560 * Fri Aug 17 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.20
561 - debug msg added & some internal function name changed
562 * Wed Aug 8 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.19
563 - push noti default action is silent, and old key is deleted
564 * Wed Aug 8 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.18
565 - tapi imei api is changed for new tapi
566 * Tue Aug 7 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.17
567 - emulator check func is added
568 * Wed Jul 25 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.16
569 - OSP Push noti support(alertMessage,..)
570