Fix spec for building 64 bit tv emul
[platform/core/appfw/sppc.git] / packaging / push.spec
1 %global _support_weblog 0
2
3 # Do not provide .so automatically for the extensions.
4 # This if statement is for backward compatibility with GBM/Obsolete build systems
5 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
6 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
7 %endif
8
9 Name:       push
10 Summary:    Push services and client library
11 Version:    0.4.69
12 Release:    1
13 Group:      Application Framework/Service
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1:    pushd.service
17 Source2:    pushd.path
18 Requires(post): /sbin/ldconfig
19 Requires(post): /usr/bin/sqlite3
20 Requires(postun): /sbin/ldconfig
21 BuildRequires:  pkgconfig(libtzplatform-config)
22
23
24 # There are not ready for .so files of wearable aarch64 and x86_64
25 %if "%{?profile}" == "wearable"
26 ExcludeArch: aarch64 x86_64
27 %endif
28
29 # There are not ready for .so files of tv aarch64
30 %if "%{?profile}" == "tv"
31 ExcludeArch: aarch64
32 %endif
33
34
35 %if %{_support_weblog}
36 BuildRequires:  pkgconfig(zlib)
37 BuildRequires:  pkgconfig(json-glib-1.0)
38 %endif
39
40 %description
41 Push services and client library.
42
43 %package -n libpush
44 Summary:    Push service client library
45 Group:      Application Framework/Libraries
46 Requires:   %{name}-bin = %{version}-%{release}
47 Requires:       libpush-compat = %{version}-%{release}
48 Recommends:     libpush-profile_common = %{version}-%{release}
49 %description -n libpush
50 Push service client library
51
52 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
53 # if mobile || ivi || common || "undefined"
54 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
55 %package -n libpush-profile_common
56 Summary:    Push service client library for common/mobile/ivi
57 Group:      Application Framework/Libraries
58 Provides:       libpush-compat = %{version}-%{release}
59 Provides:       libpush-profile_mobile = %{version}-%{release}
60 Provides:       libpush-profile_ivi = %{version}-%{release}
61 Conflicts:      libpush-profile_wearable
62 Conflicts:      libpush-profile_tv
63 %description -n libpush-profile_common
64 Push service client library for common/mobile/ivi
65 %endif
66
67 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
68 # if tv || "undefined"
69 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
70 %package -n libpush-profile_tv
71 Summary:    Push service client library for tv
72 Group:      Application Framework/Libraries
73 Provides:       libpush-compat = %{version}-%{release}
74 Conflicts:      libpush-profile_common
75 Conflicts:      libpush-profile_wearable
76 %description -n libpush-profile_tv
77 Push service client library for tv
78 %endif
79
80 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
81 # if wearable || "undefined"
82 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
83 %package -n libpush-profile_wearable
84 Summary:    Push service client library for wearable
85 Group:      Application Framework/Libraries
86 Provides:       libpush-compat = %{version}-%{release}
87 Conflicts:      libpush-profile_common
88 Conflicts:      libpush-profile_tv
89 %description -n libpush-profile_wearable
90 Push service client library for wearable
91 %endif
92
93 %package -n libpush-devel
94 Summary:    Push service client library (DEV)
95 Group:      Development/Libraries
96 Requires:   libpush = %{version}-%{release}
97 Requires:   capi-appfw-application-devel
98 %description -n libpush-devel
99 Push service client library (DEV)
100
101 %package bin
102 Summary:    Push service daemon
103 Group:      Application Framework/Service
104 Requires:       %{name}-bin-compat = %{version}-%{release}
105 Recommends:     %{name}-bin-profile_common = %{version}-%{release}
106 %description bin
107 Push service daemon
108
109 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
110 # if mobile || ivi || common || "undefined"
111 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
112 %package bin-profile_common
113 Summary:    Push service daemon for mobile/common/ivi
114 Group:      Application Framework/Service
115 Provides:       %{name}-bin-compat = %{version}-%{release}
116 Provides:       %{name}-bin-profile_mobile = %{version}-%{release}
117 Provides:       %{name}-bin-profile_ivi = %{version}-%{release}
118 Conflicts:      %{name}-bin-profile_wearable
119 Conflicts:      %{name}-bin-profile_tv
120 %description bin-profile_common
121 Push service daemon for mobile/common/ivi
122 %endif
123
124 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
125 # if tv || "undefined"
126 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
127 %package bin-profile_tv
128 Summary:    Push service daemon for tv
129 Group:      Application Framework/Service
130 Provides:       %{name}-bin-compat = %{version}-%{release}
131 Conflicts:      %{name}-bin-profile_wearable
132 Conflicts:      %{name}-bin-profile_common
133 %description bin-profile_tv
134 Push service daemon for tv
135 %endif
136
137 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
138 # if wearable || "undefined"
139 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
140 %package bin-profile_wearable
141 Summary:    Push service daemon for wearable
142 Group:      Application Framework/Service
143 Provides:       %{name}-bin-compat = %{version}-%{release}
144 Conflicts:      %{name}-bin-profile_tv
145 Conflicts:      %{name}-bin-profile_common
146 %description bin-profile_wearable
147 Push service daemon for wearable
148 %endif
149
150 %package tool
151 Summary:    Push service tool
152 Group:      Development/Tools
153 Requires:   libpush = %{version}-%{release}
154 Requires:   %{name}-bin = %{version}-%{release}
155 Requires:       %{name}-tool-compat = %{version}-%{release}
156 Recommends:     %{name}-tool-profile_common = %{version}-%{release}
157 %description tool
158 Push service tool
159
160 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
161 # if mobile || ivi || common || "undefined"
162 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
163 %package tool-profile_common
164 Summary:    Push service tool for mobile/common/ivi
165 Group:      Development/Tools
166 Provides:       %{name}-tool-compat = %{version}-%{release}
167 Provides:       %{name}-tool-profile_mobile = %{version}-%{release}
168 Provides:       %{name}-tool-profile_ivi = %{version}-%{release}
169 Conflicts:      %{name}-tool-profile_wearable
170 Conflicts:      %{name}-tool-profile_tv
171 %description tool-profile_common
172 Push service tool for mobile/common/ivi
173 %endif
174
175 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
176 # if tv || "undefined"
177 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
178 %package tool-profile_tv
179 Summary:    Push service tool for tv
180 Group:      Development/Tools
181 Provides:       %{name}-tool-compat = %{version}-%{release}
182 Conflicts:      %{name}-tool-profile_wearable
183 Conflicts:      %{name}-tool-profile_common
184 %description tool-profile_tv
185 Push service tool for tv
186 %endif
187
188 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
189 # if wearable || "undefined"
190 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
191 %package tool-profile_wearable
192 Summary:    Push service tool for wearable
193 Group:      Development/Tools
194 Provides:       %{name}-tool-compat = %{version}-%{release}
195 Conflicts:      %{name}-tool-profile_tv
196 Conflicts:      %{name}-tool-profile_common
197 %description tool-profile_wearable
198 Push service tool for wearable
199 %endif
200
201
202 %define _upgrade_script_path /usr/share/upgrade/scripts/
203 %define _upgrade_script 500.sppc.sh
204
205
206 %prep
207 %setup -q
208
209
210 %build
211
212
213 %install
214 rm -rf %{buildroot}
215 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
216 install -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/pushd.service
217
218 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
219 # if mobile //Lazy mount is for mobile only
220 %if "%{?profile}" == "mobile"
221 install -m 0644 %{SOURCE2} %{buildroot}%{_unitdir}/pushd.path
222 %endif
223
224 %ifarch %{ix86} || %{arm}
225 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
226 # if not mobile //Lazy mount is for mobile only
227 %if "%{?profile}" != "mobile"
228 %install_service multi-user.target.wants pushd.service
229 %endif
230 %endif //%ifarch %{ix86} || %{arm}
231
232 %ifarch x86_64
233 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
234 # if wearable || tv || "undefined"
235 %if "%{?profile}" != "mobile" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
236 #install -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/multi-user.target.wants/pushd.service
237 %install_service multi-user.target.wants pushd.service
238 %endif
239 %endif //%ifarch x86_64
240
241
242 mkdir -p %{buildroot}/usr/share/licenses/%{name}
243 cp -f LICENSE %{buildroot}/usr/share/licenses/%{name}
244
245 mkdir -p %{buildroot}%{_includedir}
246 cp -a include/push-service.h %{buildroot}%{_includedir}
247 cp -a include/push.h %{buildroot}%{_includedir}
248 %if %{_support_weblog}
249         include/pushlog.h %{buildroot}%{_includedir}
250 %endif
251
252 mkdir -p %{buildroot}%{_libdir}/pkgconfig
253 cp -a push.pc %{buildroot}%{_libdir}/pkgconfig/
254 mkdir -p %{buildroot}%{_bindir}
255
256 mkdir -p %{buildroot}%{_upgrade_script_path}
257 cp -f scripts/%{_upgrade_script} %{buildroot}%{_upgrade_script_path}
258
259 mkdir -p %{buildroot}/usr/share/push
260
261
262 %ifarch %{arm}
263
264 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
265 # if mobile || ivi || common || "undefined"
266 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
267 pushd arm/lib/
268 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
269 popd
270 pushd arm/bin/
271 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
272 popd
273 pushd arm/share/push/
274 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
275 popd
276 %if %{_support_weblog}
277         arm/bin/pushlog_tool
278 %endif
279 %endif
280
281 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
282 # if tv || "undefined"
283 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
284 pushd arm_tv/lib/
285 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.tv"; done
286 popd
287 pushd arm_tv/bin/
288 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.tv"; done
289 popd
290 pushd arm_tv/share/push/
291 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.tv"; done
292 popd
293 %if %{_support_weblog}
294         arm_tv/bin/pushlog_tool
295 %endif
296 %endif
297
298 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
299 # if wearable || "undefined"
300 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
301 pushd arm_wearable/lib/
302 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.wearable"; done
303 popd
304 pushd arm_wearable/bin/
305 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.wearable"; done
306 popd
307 pushd arm_wearable/share/push/
308 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.wearable"; done
309 popd
310 %if %{_support_weblog}
311         arm_wearable/bin/pushlog_tool
312 %endif
313 %endif
314
315 %endif //%ifarch %{arm}
316
317
318 %ifarch aarch64
319
320 pushd aarch64/lib64/
321 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
322 popd
323 pushd aarch64/bin/
324 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
325 popd
326 pushd aarch64/share/push/
327 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
328 popd
329 %if %{_support_weblog}
330         aarch64/bin/pushlog_tool
331 %endif
332
333 %endif
334
335
336 %ifarch %{ix86}
337
338 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
339 # if mobile || ivi || common || "undefined"
340 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
341 pushd x86/lib/
342 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
343 popd
344 pushd x86/bin/
345 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
346 popd
347 pushd x86/share/push/
348 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
349 popd
350 %if %{_support_weblog}
351         x86/bin/pushlog_tool
352 %endif
353 %endif
354
355 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
356 # if tv || "undefined"
357 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
358 pushd x86_tv/lib/
359 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.tv"; done
360 popd
361 pushd x86_tv/bin/
362 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.tv"; done
363 popd
364 pushd x86_tv/share/push/
365 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.tv"; done
366 popd
367 %if %{_support_weblog}
368         x86_tv/bin/pushlog_tool
369 %endif
370 %endif
371
372 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
373 # if wearable || "undefined"
374 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
375 pushd x86_wearable/lib/
376 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.wearable"; done
377 popd
378 pushd x86_wearable/bin/
379 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.wearable"; done
380 popd
381 pushd x86_wearable/share/push/
382 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.wearable"; done
383 popd
384 %if %{_support_weblog}
385         x86_wearable/bin/pushlog_tool
386 %endif
387 %endif
388
389 %endif //%ifarch %{ix86}
390
391
392 %ifarch x86_64
393
394 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
395 # if mobile || ivi || common || "undefined"
396 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
397 pushd x86_64/lib64/
398 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
399 popd
400 pushd x86_64/bin/
401 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE"; done
402 popd
403 pushd x86_64/share/push/
404 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE"; done
405 popd
406 %if %{_support_weblog}
407         x86_64/bin/pushlog_tool
408 %endif
409 %endif
410
411 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
412 # if tv || "undefined"
413 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
414 pushd x86_64_tv/lib64/
415 for FILE in libpush.so*; do cp -a "$FILE" "%{buildroot}%{_libdir}/$FILE.tv"; done
416 popd
417 pushd x86_64_tv/bin/
418 for FILE in push*; do cp -a "$FILE" "%{buildroot}%{_bindir}/$FILE.tv"; done
419 popd
420 pushd x86_64_tv/share/push/
421 for FILE in *.cer; do cp -a "$FILE" "%{buildroot}/usr/share/push/$FILE.tv"; done
422 popd
423 %if %{_support_weblog}
424         x86_64_tv/bin/pushlog_tool
425 %endif
426 %endif
427
428 %endif //%ifarch %{x86_64}
429
430
431 %post bin
432 mkdir -p %{TZ_SYS_GLOBALUSER_DB}
433 sqlite3 %{TZ_SYS_GLOBALUSER_DB}/.push.db "PRAGMA journal_mode = PERSIST; create table a(a); drop table a;" > /dev/null
434 chown service_fw:service_fw %{TZ_SYS_GLOBALUSER_DB}/.push.db
435 chown service_fw:service_fw %{TZ_SYS_GLOBALUSER_DB}/.push.db-journal
436 chmod 644 %{TZ_SYS_GLOBALUSER_DB}/.push.db
437 chmod 644 %{TZ_SYS_GLOBALUSER_DB}/.push.db-journal
438
439 chsmack -a "*" %{TZ_SYS_GLOBALUSER_DB}/.push.db
440 chsmack -a "*" %{TZ_SYS_GLOBALUSER_DB}/.push.db-journal
441
442
443 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
444 # if mobile //Lazy mount is for mobile only
445 %if "%{?profile}" == "mobile"
446 ln -sf ../pushd.path  %{_unitdir}/multi-user.target.wants/
447 %endif
448
449
450 %ifarch %{ix86} || %{arm}
451
452 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
453 # if tv || "undefined"
454 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
455
456 %post bin-profile_tv
457 pushd %{_bindir}
458 for FILE in push*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
459 popd
460 pushd /usr/share/push/
461 for FILE in Push*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
462 popd
463
464 %post tool-profile_tv
465 ln -sf push_tool.tv %{_bindir}/push_tool
466
467 %post -n libpush-profile_tv
468 pushd %{_libdir}
469 for FILE in libpush.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
470 popd
471 /sbin/ldconfig
472 %endif
473
474
475 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
476 # if wearable || "undefined"
477 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
478
479 %post bin-profile_wearable
480 pushd %{_bindir}
481 for FILE in push*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
482 popd
483 pushd /usr/share/push/
484 for FILE in Push*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
485 popd
486
487 %post tool-profile_wearable
488 ln -sf push_tool.wearable %{_bindir}/push_tool
489
490 %post -n libpush-profile_wearable
491 pushd %{_libdir}
492 for FILE in libpush.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
493 popd
494 /sbin/ldconfig
495
496 %endif
497
498 %endif //%ifarch %{ix86} || %{arm}
499
500
501 %files -n libpush
502 %manifest libpush.manifest
503 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
504 # if mobile || ivi || common || "undefined"
505 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
506 %attr(755,root,root) %{_libdir}/libpush.so*
507 %exclude %{_libdir}/libpush.so*.tv
508 %exclude %{_libdir}/libpush.so*.wearable
509 %endif
510
511 %files -n libpush-devel
512 %{_includedir}/*.h
513 %{_libdir}/pkgconfig/*.pc
514
515 %files bin
516 %manifest push-bin.manifest
517 %{_unitdir}/pushd.service
518 %attr(644,root,root) /usr/share/licenses/%{name}/LICENSE
519 %attr(755,root,root) %{_upgrade_script_path}%{_upgrade_script}
520
521 %files tool
522 %manifest push-tool.manifest
523 %if %{_support_weblog}
524         %{_bindir}/pushlog_tool
525 %endif
526
527 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
528 # if mobile || ivi || common || "undefined"
529 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv"
530
531 %files -n libpush-profile_common
532 # default .so files are housed in the main pkg.
533
534 %files bin-profile_common
535 %{_bindir}/pushd
536 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer
537 %{_unitdir}/pushd.path
538
539 %files tool-profile_common
540 %{_bindir}/push_tool
541
542 %endif
543
544
545 %ifarch %{ix86} || %{arm}
546
547 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
548 # if tv || "undefined"
549 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
550
551 %files -n libpush-profile_tv
552 %manifest libpush.manifest
553 %attr(755,root,root) %{_libdir}/libpush.so*.tv
554
555 %files bin-profile_tv
556 %{_bindir}/pushd.tv
557 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer.tv
558 %{_unitdir}/multi-user.target.wants/pushd.service
559
560 %files tool-profile_tv
561 %{_bindir}/push_tool.tv
562
563 %endif
564
565
566 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
567 # if wearable || "undefined"
568 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
569
570 %files -n libpush-profile_wearable
571 %manifest libpush.manifest
572 %attr(755,root,root) %{_libdir}/libpush.so*.wearable
573
574 %files bin-profile_wearable
575 %{_bindir}/pushd.wearable
576 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer.wearable
577 %{_unitdir}/multi-user.target.wants/pushd.service
578
579 %files tool-profile_wearable
580 %{_bindir}/push_tool.wearable
581
582 %endif
583
584 %endif //%ifarch %{ix86} || %{arm}
585
586
587 %ifarch x86_64
588
589 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
590 # if tv || "undefined"
591 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
592
593 %files -n libpush-profile_tv
594 %manifest libpush.manifest
595 %attr(755,root,root) %{_libdir}/libpush.so*.tv
596
597 %files bin-profile_tv
598 %{_bindir}/pushd.tv
599 %attr(600,service_fw,service_fw) /usr/share/push/PushServerTrust.cer.tv
600 %{_unitdir}/multi-user.target.wants/pushd.service
601
602 %files tool-profile_tv
603 %{_bindir}/push_tool.tv
604
605 %endif
606
607 %endif //x86_64
608
609
610 %changelog
611 * Sat Nov 3 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.26
612 - Prevent bug fixed(out-of bounds read, dead code,..)
613 * Mon Oct 22 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.25
614 - bundle null check added & protobuf null check added
615 * Wed Sep 19 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.24
616 - when pkg is uninstalled, db process is added
617 * Fri Sep 7 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.23
618 - emul check logic is changed(using capi-system-info)
619 * Tue Sep 4 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.22
620 - decoding of message with space character which is urlencoded to "+"
621 * Wed Aug 29 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.21
622 - package uninstalled event added
623 * Fri Aug 17 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.20
624 - debug msg added & some internal function name changed
625 * Wed Aug 8 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.19
626 - push noti default action is silent, and old key is deleted
627 * Wed Aug 8 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.18
628 - tapi imei api is changed for new tapi
629 * Tue Aug 7 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.17
630 - emulator check func is added
631 * Wed Jul 25 2012 Jooseok Park <jooseok.park@samsung.com> - 0.2.16
632 - OSP Push noti support(alertMessage,..)
633