apply ASLR options #1
[platform/upstream/procps-ng.git] / packaging / procps-ng.spec
1 %global tests_enabled 0
2
3 Name:           procps-ng
4 Version:        3.3.9
5 Release:        1
6 License:        GPL-2.0 and LGPL-2.0+
7 Summary:        System and process monitoring utilities
8 Url:            https://sourceforge.net/projects/procps-ng/
9 Group:          Base/Utilities
10 Source:         http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
11 Source1001:     procps-ng.manifest
12
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  libtool
20 BuildRequires:  ncurses-devel
21
22 %if %{tests_enabled}
23 BuildRequires:  dejagnu
24 %endif
25
26 Provides:       procps = %{version}
27 Obsoletes:      procps < 3.3.4-1
28
29 Provides:       /sbin/sysctl
30 Provides:       /bin/ps
31
32 %description
33 The procps package contains a set of system utilities that provide
34 system information. Procps includes ps, free, skill, pkill, pgrep,
35 snice, tload, top, uptime, vmstat, w, watch and pwdx. The ps command
36 displays a snapshot of running processes. The top command provides
37 a repetitive update of the statuses of running processes. The free
38 command displays the amounts of free and used memory on your
39 system. The skill command sends a terminate command (or another
40 specified signal) to a specified set of processes. The snice
41 command is used to change the scheduling priority of specified
42 processes. The tload command prints a graph of the current system
43 load average to a specified tty. The uptime command displays the
44 current time, how long the system has been running, how many users
45 are logged on, and system load averages for the past one, five,
46 and fifteen minutes. The w command displays a list of the users
47 who are currently logged on and what they are running. The watch
48 program watches a running program. The vmstat command displays
49 virtual memory statistics about processes, memory, paging, block
50 I/O, traps, and CPU activity. The pwdx command reports the current
51 working directory of a process or processes.
52
53 %package devel
54 Summary:        System and process monitoring utilities
55 Group:          Development/Libraries
56 Requires:       %{name}%{?_isa} = %{version}
57 Provides:       procps-devel = %{version}
58 Obsoletes:      procps-devel < 3.3.4-1
59
60 %description devel
61 System and process monitoring utilities development headers
62
63 %prep
64 %setup -q
65 cp %{SOURCE1001} .
66
67 %build
68 CFLAGS+=" -fPIE"
69 LDFLAGS+=" -pie"
70 %reconfigure --prefix=/ \
71              --exec-prefix=/ \
72              --docdir=/unwanted \
73              --disable-static \
74              --disable-w-from \
75              --disable-kill \
76              --disable-rpath
77
78 make %{?_smp_mflags}
79
80 %if %{tests_enabled}
81 %check
82 make check
83 %endif
84
85
86 %install
87 %make_install
88
89 mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
90 rm -rf %{buildroot}/unwanted
91
92 %post -p /sbin/ldconfig
93
94 %postun -p /sbin/ldconfig
95
96 %docs_package
97
98 %files
99 %manifest %{name}.manifest
100 %license COPYING COPYING.LIB
101 %{_libdir}/libprocps.so.*
102 %{_bindir}/*
103 %{_sbindir}/*
104 %{_sysconfdir}/sysctl.d
105
106 %exclude %{_sysconfdir}/sysctl.conf
107
108 %files devel
109 %manifest %{name}.manifest
110 %{_libdir}/libprocps.so
111 %{_includedir}/proc
112 %{_libdir}/pkgconfig/libprocps.pc
113
114 %changelog