resetting manifest requested domain to floor
[platform/upstream/popt.git] / packaging / popt.spec
1 Name:           popt
2 Version:        1.16
3 Release:        0
4 License:        XFree86-1.0
5 Summary:        A C library for parsing command line parameters
6 Url:            http://www.rpm5.org/
7 Group:          Base/Libraries
8 Source:         popt-%{version}.tar.bz2
9 Source2:        baselibs.conf
10 Source1001:     popt.manifest
11 BuildRequires:  pkgconfig
12
13 %description
14 Popt is a C library for parsing command line parameters.  Popt was
15 heavily influenced by the getopt() and getopt_long() functions. It
16 improves on them by allowing more powerful argument expansion. Popt can
17 parse arbitrary argv[] style arrays and automatically set variables
18 based on command line arguments.  Popt allows command line arguments to
19 be aliased via configuration files and includes utility functions for
20 parsing arbitrary strings into argv[] arrays using shell-like rules.
21
22 %package -n libpopt
23 Summary:        A C library for parsing command line parameters
24 Group:          Base/Libraries
25 Provides:       popt = %{version}
26 Obsoletes:      popt < %{version}
27
28 %description -n libpopt
29 Popt is a C library for parsing command line parameters.  Popt was
30 heavily influenced by the getopt() and getopt_long() functions. It
31 improves on them by allowing more powerful argument expansion. Popt can
32 parse arbitrary argv[] style arrays and automatically set variables
33 based on command line arguments.  Popt allows command line arguments to
34 be aliased via configuration files and includes utility functions for
35 parsing arbitrary strings into argv[] arrays using shell-like rules.
36
37 %package devel
38 Summary:        Development files for the popt library
39 Group:          Development/Libraries
40 Requires:       libpopt = %{version}
41
42 %description devel
43 The popt-devel package includes header files and libraries necessary
44 for developing programs which use the popt C library. It contains the
45 API documentation of the popt library, too.
46
47 %prep
48 %setup -q
49 cp %{SOURCE1001} .
50 %build
51 %configure --with-pic --disable-static
52 make %{?_smp_mflags}
53
54 %install
55 %make_install
56
57 %if "%{_libdir}" != "%{_prefix}/lib"
58 install -d -m755 %{buildroot}/%{_libdir}/pkgconfig
59 mv %{buildroot}%{_prefix}/lib/pkgconfig/%{name}.pc %{buildroot}/%{_libdir}/pkgconfig/%{name}.pc
60 %endif
61
62 %find_lang %{name}
63
64 %post -n libpopt -p /sbin/ldconfig
65
66 %postun -n libpopt -p /sbin/ldconfig
67
68 %lang_package
69
70 %files -n libpopt 
71 %manifest %{name}.manifest
72 %defattr(-,root,root)
73 %license COPYING
74 %{_libdir}/libpopt.so.*
75
76 %files devel
77 %manifest %{name}.manifest
78 %defattr(-,root,root)
79 %doc README
80 %{_libdir}/libpopt.so
81 %{_includedir}/popt.h
82 %{_mandir}/man3/popt.3*
83 %{_libdir}/pkgconfig/popt.pc
84
85 %changelog