Apply ASLR option
[platform/upstream/pkg-config.git] / packaging / pkg-config.spec
1 Name:           pkg-config
2 Version:        0.28
3 Release:        0
4 Summary:        A library management system
5 License:        GPL-2.0+
6 Group:          Base/Tools
7 Url:            http://pkgconfig.freedesktop.org/
8 Source:         http://pkgconfig.freedesktop.org/releases/%{name}-%{version}.tar.gz
9 Source1001:     pkg-config.manifest
10 Provides:       pkgconfig = %{version}
11 # pkg-config has a virtual internal pkg-config.pc file, so we should provide it
12 Provides:       pkgconfig(pkg-config) = %{version}
13
14 %description
15 The pkg-config program is used to retrieve information about installed
16 libraries in the system. It is typically used to compile and link
17 against one or more libraries.
18
19 %prep
20 %setup -q
21 cp %{SOURCE1001} .
22
23 %build
24 CFLAGS+=" -fPIE"
25 LDFLAGS+=" -pie"
26 %configure\
27     --with-internal-glib \
28 %if "%{_lib}" == "lib"
29        --with-pc_path=/usr/local/lib/pkgconfig:/usr/local/share/pkgconfig:%{_libdir}/pkgconfig:%{_datadir}/pkgconfig:/opt/kde3/%{_lib}/pkgconfig
30 %else
31        --with-pc_path=/usr/local/%{_lib}/pkgconfig:/usr/local/lib/pkgconfig:/usr/local/share/pkgconfig:%{_libdir}/pkgconfig:%{_datadir}/pkgconfig:/opt/kde3/%{_lib}/pkgconfig
32 %endif
33 make %{?_smp_mflags}
34
35 %install
36 %make_install
37 rm %{buildroot}%{_datadir}/doc/pkg-config/pkg-config-guide.html
38
39 %files
40 %manifest %{name}.manifest
41 %defattr(-,root,root)
42 %license COPYING
43 %{_bindir}/pkg-config
44 %{_bindir}/*-pkg-config
45 %dir %{_datadir}/aclocal
46 %{_datadir}/aclocal/pkg.m4
47
48 %docs_package
49
50 %changelog