Fix TC-2024 - bluetooth off status not persisted after system reboot
[profile/ivi/phoned.git] / packaging / phoned.spec
1 %define PREFIX "%{_libdir}/wrt-plugins"
2
3 Name:       phoned
4 Summary:    OFono/Obex business logic for phone web APIs
5 Version:    0.0.0
6 Release:    0
7 Group:      Automotive/Modello
8 License:    Apache-2.0
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001: %{name}.manifest
11
12 BuildRequires:  cmake
13 BuildRequires:  gettext-devel
14 BuildRequires:  pkgconfig(libebook-contacts-1.2)
15 BuildRequires:  pkgconfig(expat)
16 BuildRequires:  pkgconfig(json-glib-1.0)
17 BuildRequires:  pkgconfig(dbus-1)
18 BuildRequires:  pkgconfig(aul)
19
20 %description
21 A service to export OFono/Obex functionality over DBUS, to be used by WebRuntime plugin
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 export LDFLAGS="${LDFLAGS} -Wl,--rpath=%{PREFIX} -Wl,--as-needed"
29
30 %cmake . \
31        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
32        -DENABLE_TIME_TRACER="OFF" \
33        -DSYSTEMD_SERVICE_PREFIX="%{_unitdir_user}"
34
35 %__make %{?_smp_mflags} VERBOSE=1
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %install_service ../user/weston.target.wants phoned.service
42
43 %files
44 %manifest %{name}.manifest
45 %{_libdir}/pkgconfig/phoned.pc
46 %{_prefix}/bin/phoned
47 %{_prefix}/share/dbus-1/services/org.tizen.phone.service
48 %{_unitdir_user}/phoned.service
49 %{_unitdir_user}/weston.target.wants/phoned.service