Initial checkin for phone daemon for the HTML5 UI
[profile/ivi/phoned.git] / packaging / phoned.spec
1 Name:       phoned
2 Summary:    A service to export OFono/Obex functionality over DBUS, to be used by WebRuntime plugin
3 Version:    0.0.0
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(ewebkit2)
10 BuildRequires:  pkgconfig(dpl-efl)
11 BuildRequires:  pkgconfig(dpl-event-efl)
12 BuildRequires:  pkgconfig(wrt-plugins-commons)
13 BuildRequires:  pkgconfig(wrt-plugins-commons-javascript)
14
15 BuildRequires:  evolution-data-server-devel
16 BuildRequires:  wrt-plugins-tizen-devel
17 BuildRequires:  expat-devel
18 BuildRequires:  cmake
19 BuildRequires:  gettext-devel
20 BuildRequires:  pkgconfig(json-glib-1.0)
21
22 %description
23 A service to export OFono/Obex functionality over DBUS, to be used by WebRuntime plugin
24
25 %prep
26 %setup -q
27
28 %build
29
30 %define PREFIX "%{_libdir}/wrt-plugins"
31
32 export LDFLAGS+="-Wl,--rpath=%{PREFIX} -Wl,--as-needed"
33
34 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DDPL_LOG="ON" -DENABLE_TIME_TRACER="OFF"
35
36 make %{?jobs:-j%jobs} VERBOSE=1
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %post
43
44 %postun
45
46 %files
47 %{_libdir}/pkgconfig/phoned.pc
48 %{_prefix}/sbin/phoned
49 %{_prefix}/share/dbus-1/services/org.tizen.phone.service
50 %{_prefix}/lib/systemd/user/phoned.service
51