9653c225757e0887f3b303988b2d0794ed1be8a1
[platform/upstream/perl-XML-Parser.git] / packaging / perl-XML-Parser.spec
1 Name:           perl-XML-Parser
2 %define cpan_name XML-Parser
3 Summary:        A perl module for parsing XML documents
4 Version:        2.41
5 Release:        9
6 License:        GPL-1.0+ or Artistic-1.0
7 Group:          Development/Libraries/Perl
8 AutoReqProv:    on
9 Url:            http://www.cpan.org/modules/by-module/XML/ 
10 Source:         %{cpan_name}-%{version}.tar.gz
11 BuildRequires:  perl
12 BuildRequires:  libexpat-devel
13
14 %description
15 This module provides ways to parse XML documents. It is built on top of
16  XML::Parser::Expat, which is a lower level interface to James Clark's expat
17  library. Each call to one of the parsing methods creates a new instance of
18  XML::Parser::Expat which is then used to parse the document. Expat options may
19  be provided when the XML::Parser object is created. These options are then
20  passed on to the Expat object on each parse call. They can also be given as
21  extra arguments to the parse methods, in which case they override options
22  given at XML::Parser creation time.
23
24 The behavior of the parser is controlled either by "Style" and/or "Handlers"
25  options, or by "setHandlers" method. These all provide mechanisms for
26  XML::Parser to set the handlers needed by XML::Parser::Expat. If neither
27  Style nor Handlers are specified, then parsing just checks the document
28  for being well-formed.
29
30 When underlying handlers get called, they receive as their first parameter
31  the Expat object, not the Parser object.
32
33 You will find examples in
34 /usr/share/doc/packages/perl-XML-Parser/samples.  For documentation
35 read the XML::Parser and XML::Parser::Expat man pages.
36
37
38 %prep
39 %setup -n XML-Parser-%{version} -q
40
41 %build
42 CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL
43 %{__make}
44
45 %check
46 %{__make} test
47
48 %install
49 %perl_make_install
50 %perl_process_packlist
51 %perl_gen_filelist
52
53 %clean
54 %{__rm} -rf $RPM_BUILD_ROOT
55
56 %files -f %{name}.files
57 %defattr(0644,root,root,0755)
58
59 %changelog