Imported vendor release 0.28.0-2.1
[services/perl-BSSolv-obs-2.7.git] / packaging / perl-BSSolv.spec
1 #
2 # spec file for package perl-BSSolv
3 #
4 # Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18
19 Name:           perl-BSSolv
20 Version:        0.28.0
21 Release:        2.1
22 Url:            https://github.com/openSUSE/perl-BSSolv
23 Source:         libsolv-0.6.15.tar.gz
24 Source1:        Makefile.PL
25 Source2:        BSSolv.pm
26 Source3:        BSSolv.xs
27 Source4:        typemap
28 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
29
30 %if 0%{?mandriva_version}
31 # force this version on mandriva
32 BuildRequires:  libneon0.26-devel
33 %endif
34 %if 0%{?fedora_version}
35 BuildRequires:  db4-devel
36 BuildRequires:  perl-devel
37 %endif
38 %if 0%{?suse_version}
39 Requires:       perl = %perl_version
40 %if 0%{?suse_version} < 1030
41 BuildRequires:  expat
42 %else
43 BuildRequires:  libexpat-devel
44 %endif
45 %else
46 BuildRequires:  expat-devel
47 %endif
48 %if 0%{?rhel_version} || 0%{?centos_version}
49 BuildRequires:  db4-devel
50 %endif
51 BuildRequires:  cmake
52 BuildRequires:  gcc-c++
53 BuildRequires:  perl
54 BuildRequires:  rpm-devel
55 BuildRequires:  xz-devel
56 BuildRequires:  zlib-devel
57 #RHEL6 moved ExtUtils::MakeMaker outside the main perl package
58 BuildRequires:  perl(ExtUtils::MakeMaker)
59 # the testsuite uses the check framework
60 BuildRequires:  check-devel
61 Summary:        A new approach to package dependency solving
62 License:        BSD-3-Clause
63 Group:          Development/Libraries/C and C++
64 # probably needed for rhel/centos on x86_64
65 %if 0%{!?perl_vendorarch}
66 %define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
67 %endif
68
69 %description
70 Using a Satisfyability Solver to compute package dependencies.
71
72 %prep
73 %setup -c
74 ln -s libsolv-* libsolv
75 cp %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} .
76 pushd libsolv
77 popd
78
79 %build
80 export CFLAGS="$RPM_OPT_FLAGS"
81 export CXXFLAGS="$CFLAGS"
82
83 CMAKE_FLAGS=
84 %if 0%{?fedora_version} || 0%{?rhel_version} || 0%{?centos_version}
85 CMAKE_FLAGS="-DFEDORA=1"
86 %endif
87
88 %if 0%{?rhel_version} || 0%{?centos_version}
89 CFLAGS="$CFLAGS -DUSE_OWN_QSORT"
90 %endif
91
92 pushd libsolv
93 cmake   $CMAKE_FLAGS \
94         -DDISABLE_SHARED=1 \
95         -DCMAKE_BUILD_TYPE=Release \
96         -DCMAKE_SKIP_RPATH=1 \
97         -DENABLE_RPMDB=1 \
98         -DENABLE_DEBIAN=1 \
99         -DENABLE_ARCHREPO=1 \
100         -DENABLE_LZMA_COMPRESSION=1 \
101         -DMULTI_SEMANTICS=1
102 pushd src ; make ; popd
103 pushd ext ; make ; popd
104 popd
105 perl Makefile.PL --bundled-libsolv
106 make
107
108 %install
109 make DESTDIR=$RPM_BUILD_ROOT install_vendor
110 %if 0%{?suse_version}  
111 %perl_process_packlist  
112 %else  
113 find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} \;  
114 find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;  
115 find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'  
116 find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;  
117 %{_fixperms} $RPM_BUILD_ROOT/*  
118 %endif  
119
120 %files
121 %defattr(-,root,root)
122 %{perl_vendorarch}/BSSolv.pm
123 %{perl_vendorarch}/auto/BSSolv
124 %if 0%{?suse_version}
125 %if 0%{?suse_version} < 1140
126 /var/adm/perl-modules/*
127 %endif
128 %endif
129
130 %changelog
131 * Fri Apr  1 2016 mls@suse.de
132 - update to version 0.28.0 (perl module 0.08 version)
133   * fix typo, rename obscpiostats to obscpiostorestats
134 * Fri Apr  1 2016 mls@suse.de
135 - update to version 0.27.0 (perl module 0.07 version)
136   * add delta storage support
137 * Tue Mar 15 2016 mls@suse.de
138 - update to version 0.26.0 (perl module 0.06 version)
139   * add preparehashes pool method to speed up the scheduler
140 * Tue Aug 18 2015 mls@suse.de
141 - update to version 0.25.0 (perl module 0.05 version)
142   * make checksums pass our writefilter
143 * Tue Aug 18 2015 mls@suse.de
144 - update to version 0.24.0 (perl module 0.04 version)
145   * allow setting of the dodcookie without a dodurl
146 * Thu Jul 30 2015 mls@suse.de
147 - update to version 0.23.0 (perl module 0.03 version)
148   * implement download on demand data updating
149 * Thu Jun 11 2015 adrian@suse.de
150 - update to version 0.22.0 (perl module 0.02 version)
151   * implement handling of conflicts (aka '!') deps in expander
152   * treat ARCH_ANY like ARCH_ALL
153   * improve conflictsinfo handling
154   * support --ignoreignore-- flag
155   * improved debug output
156 * Thu Sep 18 2014 ro@suse.de
157 - update to BSSolv.xs from GIT
158 * Fri Oct 18 2013 mls@suse.de
159 - update to libsolv-0.4.0 to get REL_MULTIARCH support
160 * Wed Feb  6 2013 mls@suse.de
161 - update to libsolv-0.2.4
162 * Wed Nov 14 2012 mls@suse.de
163 - update BSSolv.xs to get debugstr support
164 * Tue Nov 13 2012 mls@suse.de
165 - support 'ignoreconflicts' expandflag
166 * Tue Nov 13 2012 mls@suse.de
167 - use REPO_NO_LOCATION
168 * Mon Nov 12 2012 mls@suse.de
169 - update libsolv to current version to fix deb parsing
170 - bump repocookie
171 * Mon Oct 15 2012 mls@suse.de
172 - update libsolv and BSSolv.xs to current version
173   * export all dependencies
174   * obey package conflicts when expanding
175 * Fri Apr 27 2012 mls@suse.de
176 - update BSSolv.xs so that the worker caches binaries again
177 * Wed Apr 25 2012 mls@suse.de
178 - bump version to 0.18.2
179 - update to libsolv-0.1.0 to fix opensuse 11.4 builds
180 * Wed Apr  4 2012 mls@suse.de
181 - bump version to 0.18.1
182 - update to current libsolv
183 - enable arch linux support
184 * Wed Nov 30 2011 adrian@suse.de
185 - bump version to 0.18.0
186 - base package on libsolv tar ball
187 * Wed Nov 30 2011 mls@suse.de
188 - update BSSolv.xs:
189   * fix prefer order handling bug
190   * add repo->tofile_fd
191 * Wed Nov 16 2011 mls@suse.de
192 - fix debian control file extraction, thanks djszapi!
193 * Thu Aug 25 2011 mls@suse.de
194 - fix debian dependency compare function
195 * Tue Jun 28 2011 coolo@novell.com
196 - add requires to correct perl version
197 * Tue Feb 15 2011 mls@suse.de
198 - define USE_OWN_QSORT instead of using glib
199 * Mon Feb 14 2011 adrian@suse.de
200 - update to 0.16.4
201 * Thu Dec  9 2010 adrian@suse.de
202 - update to 0.16.2
203 - fix build for Factory
204 * Fri Oct 29 2010 adrian@suse.de
205 - follow the version of satsolver for this package
206 * Sat Oct 23 2010 mrdocs@opensuse.org
207 - fix the build with the correct source version
208 * Tue Oct 19 2010 adrian@suse.de
209 - adapt spec to version 0.16.0
210 * Fri Jul 23 2010 adrian@suse.de
211 - update BSSolv.xs from current build-service git repo
212 * Fri May 14 2010 adrian@suse.de
213 - adapt spec to version 0.15.0
214 * Wed Apr  7 2010 mls@suse.de
215 - adapt spec to version 0.14.17
216 * Mon Mar 15 2010 chris@computersalat.de
217 - fix spec
218   o new version 0.14.16 (zypp:Head)
219 * Tue Mar  2 2010 chris@computersalat.de
220 - hmm, cause of undocumented SOURCE changes
221   (satsolver-0.14.15 from zypp:Head),
222   util patch (SLES 10 fix) now obsolete
223   o hence removed
224 * Sun Feb 28 2010 adrian@suse.de
225 - fixed SLES 10 fix
226 * Tue Feb 23 2010 chris@computersalat.de
227 - fix spec
228   o new version 0.14.15 (zypp:Head)
229 - reworked patch for SLE_10
230 * Fri Feb 12 2010 chris@computersalat.de
231 - spec mods
232   o added header
233   o fixed source version
234 - fix build for SLE_10
235   o added satsolver-0.14.14-util.patch
236 - BuildReq ruby-devel > 1.8.4
237   o /usr/bin/ruby: no such file to
238     load -- vendor-specific (LoadError)
239 * Mon Dec 21 2009 mls@suse.de
240 - add dod changes
241 - fix bug in debian dep parsing
242 - add support for whatprovides/whatrequires
243 * Fri Oct 23 2009 mls@suse.de
244 - strip trailing spaces in dep2id
245 * Wed Oct 21 2009 mls@suse.de
246 - add pkg2sizek
247 * Wed Oct  7 2009 mls@suse.de
248 - update BSSolv.xs
249 * Tue Oct  6 2009 mls@suse.de
250 - initial version