tizen 2.3.1 release
[framework/web/pcre.git] / packaging / pcre.spec
1 %define keepstatic 1
2
3 Name: pcre
4 Version: 7.7
5 Release: 4
6 Summary: Perl-compatible regular expression library - Tools
7 URL: http://www.pcre.org/
8 Source: http://downloads.sourceforge.net/project/pcre/pcre/%{version}/%{name}-%{version}.tar.bz2
9 License: BSD-2.0
10 Group: System/Libraries
11 BuildRequires: autoconf, automake, libtool
12
13 %description
14 Tools and Utilities coming with %{name}
15
16
17 %package -n lib%{name}
18 Summary: Perl-compatible regular expression library
19 Group: System/Libraries
20
21 %description -n lib%{name}
22 Perl-compatible regular expression library.
23 PCRE has its own native API, but a set of "wrapper" functions that are based on
24 the POSIX API are also supplied in the library libpcreposix. Note that this
25 just provides a POSIX calling interface to PCRE: the regular expressions
26 themselves still follow Perl syntax and semantics. The header file
27 for the POSIX-style functions is called pcreposix.h.
28
29
30 %package -n lib%{name}-devel
31 Summary: Development files for %{name}
32 Group: Development/Libraries
33 Requires: lib%{name} = %{version}-%{release}
34
35 %description -n lib%{name}-devel
36 Development files (Headers, libraries for dynamic linking, etc) for %{name}.
37
38 %package -n lib%{name}-static
39 Summary: Static library for %{name}
40 Group: Development/Libraries
41 Requires: lib%{name} = %{version}-%{release}
42
43 %description -n lib%{name}-static
44 Static library for %{name}.
45
46 %prep
47 %setup -q
48
49 %build
50
51 %autogen.sh --enable-utf8 --enable-unicode-properties --enable-newline-is-any --disable-stack-for-recursion
52
53
54 make %{?_smp_mflags}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 mkdir -p %{buildroot}/usr/share/license
59 cp LICENCE %{buildroot}/usr/share/license/%{name}
60 cp LICENCE %{buildroot}/usr/share/license/lib%{name}
61 %make_install
62
63 rm -rf $RPM_BUILD_ROOT/usr/share/man
64 rm -rf $RPM_BUILD_ROOT/usr/share/doc
65
66 %post -n lib%{name} -p /sbin/ldconfig
67
68 %postun -n lib%{name} -p /sbin/ldconfig
69
70
71 %files
72 %manifest pcre.manifest
73 %{_bindir}/pcregrep
74 %{_bindir}/pcretest
75 %{_datadir}/license/%{name}
76
77 %files -n lib%{name}
78 %{_libdir}/*.so.*
79 %{_datadir}/license/lib%{name}
80
81 %files -n lib%{name}-devel
82 %{_libdir}/*.so
83 %{_libdir}/pkgconfig/*
84 %{_includedir}/*.h
85 %{_bindir}/pcre-config
86
87 %files -n lib%{name}-static
88 %{_libdir}/*.a