pass-hal: tm2: Add implementation of HAL for CPU
[platform/adaptation/tm2/pass-hal-tm2.git] / packaging / pass-hal-tm2.spec
1 %define version 0.0.1
2 %define release 1
3
4 Name:       pass-hal-tm2
5 Summary:    PASS hal for TM2
6 Version:    %{version}
7 Release:    %{release}
8 Group:      System/Hardware Adaptation
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 Source1:    %{name}.manifest
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 BuildRequires:  cmake
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(pass-hal-devel)
18
19 %description
20 PASS hal for TM2
21
22 %prep
23 %setup -q
24 cp %{SOURCE1} .
25
26 %build
27 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DHAL_VERSION=%{version}.%{release}
28
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33
34 %make_install
35
36 %post -p /sbin/ldconfig
37
38 %postun -p /sbin/ldconfig
39
40 %files
41 %manifest %{name}.manifest
42 %{_libdir}/pass/*.so