Clean up spec file for packaging
[profile/ivi/pango.git] / packaging / pango.spec
1 %define freetype_version 2.1.3-3
2 %define fontconfig_version 2.6
3 %define cairo_version 1.7.6
4
5 Name:       pango
6 Summary:    System for layout and rendering of internationalized text
7 Version:    1.30.0
8 Release:    3.2
9 Group:      System/GUI/GNOME
10 License:    LGPL-2.0 or GPL or FreeType
11 URL:        http://www.pango.org
12 Source0:    %{name}-%{version}.tar.bz2
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(freetype2) >= %{freetype_version}
15 BuildRequires:  pkgconfig(fontconfig) >= %{fontconfig_version}
16 BuildRequires:  pkgconfig(xt)
17 BuildRequires:  pkgconfig(xrender)
18 BuildRequires:  pkgconfig(x11)
19 BuildRequires:  pkgconfig(xext)
20 BuildRequires:  pkgconfig(xft)
21 BuildRequires:  pkgconfig(cairo) >= %{cairo_version}
22
23 %description
24 Pango is a library for laying out and rendering of text, with an emphasis
25 on internationalization. Pango can be used anywhere that text layout is needed,
26 though most of the work on Pango so far has been done in the context of the
27 GTK+ widget toolkit. Pango forms the core of text and font handling for GTK+.
28
29 Pango is designed to be modular; the core Pango layout engine can be used
30 with different font backends.
31
32 The integration of Pango with Cairo provides a complete solution with high
33 quality text handling and graphics rendering.
34
35
36 %package -n libpango
37 Summary:    Pango Library
38 Group:      System/Libraries
39 Requires(post): /sbin/ldconfig
40 Requires(postun): /sbin/ldconfig
41
42 %description -n libpango
43 Pango is a library for laying out and rendering of text, with an emphasis
44 on internationalization. Pango can be used anywhere that text layout is needed,
45 though most of the work on Pango so far has been done in the context of the
46 GTK+ widget toolkit. Pango forms the core of text and font handling for GTK+.
47
48 Pango is designed to be modular; the core Pango layout engine can be used
49 with different font backends.
50
51 The integration of Pango with Cairo provides a complete solution with high
52 quality text handling and graphics rendering.
53
54
55 %package -n libpango-devel
56 Summary:    Development files for pango
57 Group:      Development/Libraries
58 Requires:   lib%{name} = %{version}-%{release}
59
60 %description -n libpango-devel
61 The pango-devel package includes the header files and developer documentation
62 for the pango package.
63
64 %prep
65 %setup -q -n %{name}-%{version}
66
67 %build
68
69 %configure --disable-static \
70         --sysconfdir=/etc \
71         --with-x \
72         --enable-freetype \
73         --disable-glibtest \
74         --enable-explicit-deps=yes \
75         --enable-gtk-doc=no \
76         ac_cv_lib_cairo_cairo_xlib_surface_create=yes \
77         ac_cv_lib_cairo_cairo_ft_scaled_font_lock_face=yes
78
79 make %{?jobs:-j%jobs}
80
81 %install
82 rm -rf %{buildroot}
83 %make_install
84 rm -rf $RPM_BUILD_ROOT/usr/share/gtk-doc
85 rm -rf $RPM_BUILD_ROOT/usr/share/man
86
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
88 mkdir -p %{buildroot}/etc/pango
89
90
91
92 %post -n libpango 
93 /sbin/ldconfig
94 %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/pango.modules
95
96 %postun -n libpango -p /sbin/ldconfig
97
98 %files
99 %{_bindir}/pango-view
100 %dir %{_sysconfdir}/pango
101 %config %{_sysconfdir}/pango/pangox.aliases
102
103
104 %files -n libpango
105 %{_bindir}/pango-querymodules
106 %ghost %{_sysconfdir}/pango/pango.modules
107 %{_libdir}/libpango*-*.so.*
108 %{_libdir}/pango
109 %dir /etc/pango
110
111
112 %files -n libpango-devel
113 %{_libdir}/libpango*.so
114 %{_includedir}/*
115 %{_libdir}/pkgconfig/*.pc
116