resetting manifest requested domain to floor
[platform/upstream/p11-kit.git] / packaging / p11-kit.spec
1 Name:           p11-kit
2 Version:        0.18.4
3 Release:        0
4 License:        BSD-3-Clause
5 Summary:        Library to work with PKCS#11 modules
6 Url:            http://p11-glue.freedesktop.org/p11-kit.html
7 Group:          Security/Crypto Libraries
8 Source0:        http://p11-glue.freedesktop.org/releases/%{name}-%{version}.tar.gz
9 Source99:       baselibs.conf
10 Source1001:     p11-kit.manifest
11 BuildRequires:  pkg-config
12 BuildRequires:  pkgconfig(libtasn1)
13
14 %description
15 p11-kit provides a way to load and enumerate PKCS#11 modules, as well
16 as a standard configuration setup for installing PKCS#11 modules in
17 such a way that they're discoverable.
18
19 %package -n libp11-kit
20 Summary:        Library to work with PKCS#11 modules
21
22 %description -n libp11-kit
23 p11-kit provides a way to load and enumerate PKCS#11 modules, as well
24 as a standard configuration setup for installing PKCS#11 modules in
25 such a way that they're discoverable.
26
27 %package tools
28 Summary:        Library to work with PKCS#11 modules -- Tools
29
30 %description tools
31 p11-kit provides a way to load and enumerate PKCS#11 modules, as well
32 as a standard configuration setup for installing PKCS#11 modules in
33 such a way that they're discoverable.
34
35 %package devel
36 Summary:        Library to work with PKCS#11 modules -- Development Files
37 Requires:       libp11-kit = %{version}
38
39 %description devel
40 p11-kit provides a way to load and enumerate PKCS#11 modules, as well
41 as a standard configuration setup for installing PKCS#11 modules in
42 such a way that they're discoverable.
43
44 %prep
45 %setup -q
46 cp %{SOURCE1001} .
47
48 %build
49 %configure --without-trust-paths
50 make %{?_smp_mflags}
51
52 %install
53 %make_install
54 # Create pkcs11 config directory
55 test ! -e %{buildroot}%{_sysconfdir}/pkcs11/modules
56 install -d %{buildroot}%{_sysconfdir}/pkcs11/modules
57 # Remove sample config away to doc folder. Having the sample there would conflict
58 # with future versions of the library on file level. As replacement, we package
59 # the file as documentation file.
60 rm %{buildroot}%{_sysconfdir}/pkcs11/pkcs11.conf.example
61
62 %post -n libp11-kit -p /sbin/ldconfig
63
64 %postun -n libp11-kit -p /sbin/ldconfig
65
66 %files -n libp11-kit
67 %manifest %{name}.manifest
68 %defattr(-,root,root)
69 # Package the example conf file as documentation. Like this we're sure that we will
70 # not introduce conflicts with this version of the library and future ones.
71 %doc p11-kit/pkcs11.conf.example
72 %license COPYING
73 %dir %{_sysconfdir}/pkcs11
74 %dir %{_sysconfdir}/pkcs11/modules/
75 %{_libdir}/libp11-kit.so.*
76 %{_libdir}/p11-kit-proxy.so
77 %dir %{_libdir}/pkcs11
78 %dir %{_libdir}/p11-kit
79 %{_libdir}/pkcs11/p11-kit-trust.so
80 %{_libdir}/p11-kit/p11-kit-extract-trust
81 %dir %_datadir/p11-kit
82 %dir %_datadir/p11-kit/modules
83 %_datadir/p11-kit/modules/p11-kit-trust.module
84
85 %files tools
86 %manifest %{name}.manifest
87 %defattr(-,root,root)
88 %{_bindir}/p11-kit
89
90 %files devel
91 %manifest %{name}.manifest
92 %defattr(-,root,root)
93 %{_includedir}/p11-kit-1/
94 %{_libdir}/libp11-kit.so
95 %{_libdir}/pkgconfig/p11-kit-1.pc
96 %doc %dir %{_datadir}/gtk-doc
97 %doc %dir %{_datadir}/gtk-doc/html
98 %doc %{_datadir}/gtk-doc/html/p11-kit/
99
100 %changelog