merge with master
[framework/osp/web.git] / packaging / osp-web.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:           osp-web
5 Summary:        osp web library
6 Version:        1.2.1.0
7 Release:        2
8 Group:          System/Libraries
9 License:        TO_BE/FILLED_IN
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(capi-appfw-application)
13 BuildRequires:  pkgconfig(capi-network-connection)
14 BuildRequires:  pkgconfig(capi-web-favorites)
15 BuildRequires:  pkgconfig(dbus-1)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(edbus)
18 BuildRequires:  pkgconfig(eina)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(ethumb)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(ewebkit2)
23 BuildRequires:  pkgconfig(bundle)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(osp-appfw)
26 BuildRequires:  pkgconfig(osp-content)
27 BuildRequires:  osp-appfw-internal-devel
28 BuildRequires:  osp-content-internal-devel
29 BuildRequires:  pkgconfig(osp-net)
30 BuildRequires:  osp-net-internal-devel
31 BuildRequires:  pkgconfig(osp-uifw)
32 BuildRequires:  pkgconfig(osp-content)
33 BuildRequires:  osp-uifw-internal-devel
34 BuildRequires:  pkgconfig(osp-image-core)
35 BuildRequires:  pkgconfig(osp-image)
36 BuildRequires:  pkgconfig(osp-media)
37 BuildRequires:  osp-media-internal-devel
38 BuildRequires:  pkgconfig(osp-json)
39 BuildRequires:  pkgconfig(libsoup-2.4)
40 BuildRequires:  pkgconfig(vconf)
41 BuildRequires:  pkgconfig(openssl)
42
43 # runtime requires
44 Requires: osp-appfw 
45 Requires: osp-media
46 Requires: osp-net
47 Requires: osp-json
48 Requires: osp-content
49
50 %description
51 osp web library
52
53 %package devel
54 Summary:    osp web library (Development)
55 Group:      TO_BE/FILLED_IN
56 Requires:   %{name} = %{version}-%{release}
57
58 %description devel
59 osp web library (DEV)
60
61 %package debug
62 Summary:    osp web library (Development)
63 Group:      TO_BE/FILLED_IN
64 Requires:   %{name} = %{version}-%{release}
65
66 %description debug
67 osp web library (DEV)
68
69 %prep
70 %setup -q
71
72 %build 
73 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
74 %ifarch %{ix86}
75 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
76 %else
77 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
78 %endif
79
80 # Call make instruction with smp support
81 make %{?jobs:-j%jobs}
82
83 %install
84 rm -rf %{buildroot}
85 mkdir -p %{buildroot}/usr/share/license
86 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2.0 >> %{buildroot}/usr/share/license/%{name}
87
88 %make_install
89
90 %post -p /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94 %files
95 %manifest osp-web.manifest
96 /usr/share/license/%{name}
97 %{_libdir}/osp/libosp-web.so*
98 %{_libdir}/osp/browser-plugin/*.so
99
100 %files devel
101 %{_includedir}/osp/*.h
102 %{_libdir}/pkgconfig/osp-web.pc
103
104 %files debug
105 %{_libdir}/osp/debug/*.so.*
106 %{_libdir}/osp/browser-plugin/debug/*.so