Initialize Tizen 2.3
[framework/osp/web.git] / packaging / osp-web.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:           osp-web
5 Summary:        osp web library
6 Version:        1.2.2.0
7 Release:        2
8 Group:          System/Libraries
9 License:        Apache-2.0
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(capi-appfw-application)
13 BuildRequires:  pkgconfig(capi-network-connection)
14 BuildRequires:  pkgconfig(capi-web-favorites)
15 BuildRequires:  pkgconfig(capi-content-media-content)
16 BuildRequires:  pkgconfig(dbus-1)
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(edbus)
19 BuildRequires:  pkgconfig(eina)
20 BuildRequires:  pkgconfig(elementary)
21 BuildRequires:  pkgconfig(ethumb)
22 BuildRequires:  pkgconfig(evas)
23 BuildRequires:  pkgconfig(ewebkit2)
24 BuildRequires:  pkgconfig(bundle)
25 BuildRequires:  pkgconfig(glib-2.0)
26 BuildRequires:  pkgconfig(osp-appfw)
27 BuildRequires:  pkgconfig(osp-content)
28 BuildRequires:  osp-appfw-internal-devel
29 BuildRequires:  osp-content-internal-devel
30 BuildRequires:  pkgconfig(osp-net)
31 BuildRequires:  osp-net-internal-devel
32 BuildRequires:  pkgconfig(osp-uifw)
33 BuildRequires:  pkgconfig(osp-content)
34 BuildRequires:  osp-uifw-internal-devel
35 BuildRequires:  pkgconfig(osp-image-core)
36 BuildRequires:  pkgconfig(osp-image)
37 BuildRequires:  pkgconfig(osp-media)
38 BuildRequires:  osp-media-internal-devel
39 BuildRequires:  pkgconfig(osp-json)
40 BuildRequires:  pkgconfig(libsoup-2.4)
41 BuildRequires:  pkgconfig(vconf)
42 BuildRequires:  pkgconfig(openssl)
43 BuildRequires:  pkgconfig(haptic)
44
45 # runtime requires
46 Requires: osp-appfw 
47 Requires: osp-media
48 Requires: osp-net
49 Requires: osp-json
50 Requires: osp-content
51
52 %description
53 osp web library
54
55 %package devel
56 Summary:    osp web library (Development)
57 Group:      TO_BE/FILLED_IN
58 Requires:   %{name} = %{version}-%{release}
59
60 %description devel
61 osp web library (DEV)
62
63 %package internal-devel
64 Summary:    osp web framework internel (Internal)
65 Group:      TO_BE/FILLED_IN
66 Requires:   %{name} = %{version}-%{release}
67
68 %description internal-devel
69 The Web Framework library of OSP (Internal-DEV)
70
71 %package debug
72 Summary:    osp web library (Development)
73 Group:      TO_BE/FILLED_IN
74 Requires:   %{name} = %{version}-%{release}
75
76 %description debug
77 osp web library (DEV)
78
79 %prep
80 %setup -q
81
82 %build 
83 %if 0%{?tizen_build_binary_release_type_eng}
84 CXXFLAGS="$CXXFLAGS -D_SECURE_LOG"
85 %endif
86 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
87 %ifarch %{ix86}
88 %if 0%{?simulator}
89 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
90 %else
91 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
92 %endif
93 %else
94
95 %if 0%{?tizen_build_binary_release_type_eng}
96 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
97 %else
98 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
99 %endif
100
101 %endif
102 # Call make instruction with smp support
103 make %{?jobs:-j%jobs}
104
105 %install
106 rm -rf %{buildroot}
107 mkdir -p %{buildroot}/usr/share/license
108 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2.0 >> %{buildroot}/usr/share/license/%{name}
109
110 %make_install
111
112 %post -p /sbin/ldconfig
113
114 %postun -p /sbin/ldconfig
115
116 %files
117 %manifest osp-web.manifest
118 /usr/share/license/%{name}
119 %{_libdir}/osp/libosp-web.so*
120 %{_libdir}/osp/browser-plugin/*.so
121
122 %files devel
123 %{_includedir}/osp/*.h
124 %{_libdir}/pkgconfig/osp-web.pc
125
126 %files internal-devel
127 %{_includedir}/osp/web/controls/*.h
128
129 %files debug
130 %{_libdir}/osp/debug/*.so.*
131 %{_libdir}/osp/browser-plugin/debug/*.so