fix gbs/obs build failure
[framework/osp/web.git] / packaging / osp-web.spec
1 %define __strip /bin/true
2
3 Name:           osp-web
4 Summary:        osp web library
5 Version:        1.2.2.0
6 Release:        2
7 Group:          System/Libraries
8 License:        TO_BE/FILLED_IN
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(capi-appfw-application)
12 BuildRequires:  pkgconfig(capi-network-connection)
13 BuildRequires:  pkgconfig(capi-web-favorites)
14 BuildRequires:  pkgconfig(capi-content-media-content)
15 BuildRequires:  pkgconfig(dbus-1)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(edbus)
18 BuildRequires:  pkgconfig(eina)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(ethumb)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(ewebkit2)
23 BuildRequires:  pkgconfig(bundle)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(osp-appfw)
26 BuildRequires:  pkgconfig(osp-content)
27 BuildRequires:  osp-appfw-internal-devel
28 BuildRequires:  osp-content-internal-devel
29 BuildRequires:  pkgconfig(osp-net)
30 BuildRequires:  osp-net-internal-devel
31 BuildRequires:  pkgconfig(osp-uifw)
32 BuildRequires:  pkgconfig(osp-content)
33 BuildRequires:  osp-uifw-internal-devel
34 BuildRequires:  pkgconfig(osp-image-core)
35 BuildRequires:  pkgconfig(osp-image)
36 BuildRequires:  pkgconfig(osp-media)
37 BuildRequires:  osp-media-internal-devel
38 BuildRequires:  pkgconfig(osp-json)
39 BuildRequires:  pkgconfig(libsoup-2.4)
40 BuildRequires:  pkgconfig(vconf)
41 BuildRequires:  pkgconfig(openssl)
42 BuildRequires:  pkgconfig(haptic)
43
44 # runtime requires
45 Requires: osp-appfw 
46 Requires: osp-media
47 Requires: osp-net
48 Requires: osp-json
49 Requires: osp-content
50
51 %description
52 osp web library
53
54 %package devel
55 Summary:    osp web library (Development)
56 Group:      TO_BE/FILLED_IN
57 Requires:   %{name} = %{version}-%{release}
58
59 %description devel
60 osp web library (DEV)
61
62 %package internal-devel
63 Summary:    osp web framework internel (Internal)
64 Group:      TO_BE/FILLED_IN
65 Requires:   %{name} = %{version}-%{release}
66
67 %description internal-devel
68 The Web Framework library of OSP (Internal-DEV)
69
70 %package debug
71 Summary:    osp web library (Development)
72 Group:      TO_BE/FILLED_IN
73 Requires:   %{name} = %{version}-%{release}
74
75 %description debug
76 osp web library (DEV)
77
78 %prep
79 %setup -q
80
81 %build 
82 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
83 %ifarch %{ix86}
84 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
85 %else
86 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
87 %endif
88
89 # Call make instruction with smp support
90 make %{?jobs:-j%jobs}
91
92 %install
93 rm -rf %{buildroot}
94 mkdir -p %{buildroot}/usr/share/license
95 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2.0 >> %{buildroot}/usr/share/license/%{name}
96
97 %make_install
98
99 %post -p /sbin/ldconfig
100
101 %postun -p /sbin/ldconfig
102
103 %files
104 %manifest osp-web.manifest
105 /usr/share/license/%{name}
106 %{_libdir}/osp/libosp-web.so*
107 %{_libdir}/osp/browser-plugin/*.so
108
109 %files devel
110 %{_includedir}/osp/*.h
111 %{_libdir}/pkgconfig/osp-web.pc
112
113 %files internal-devel
114 %{_includedir}/osp/web/controls/*.h
115
116 %files debug
117 %{_libdir}/osp/debug/*.so.*
118 %{_libdir}/osp/browser-plugin/debug/*.so