merge with master
[platform/framework/native/uix.git] / packaging / osp-uix.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:           osp-uix
5 Summary:        osp uix library
6 Version:        1.2.1.0
7 Release:        2
8 Group:          System/Libraries
9 License:        TO_BE/FILLED_IN
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(sensor)
13 BuildRequires:  pkgconfig(capi-system-sensor)
14 BuildRequires:  pkgconfig(osp-appfw)
15 BuildRequires:  osp-appfw-internal-devel
16
17 # runtime requires
18 Requires: osp-appfw 
19
20 %description
21 osp uix library
22
23 %package devel
24 Summary:    osp uix library (Development)
25 Group:      TO_BE/FILLED_IN
26 Requires:   %{name} = %{version}-%{release}
27
28 %description devel
29 osp uix library (DEV)
30
31 %package internal-devel
32 Summary:    osp uix library (Internal)
33 Group:      TO_BE/FILLED_IN
34 Requires:   %{name} = %{version}-%{release}
35
36 %description internal-devel
37 osp uix library (Internal-DEV)
38
39 %package debug
40 Summary:    osp uix library (Development)
41 Group:      TO_BE/FILLED_IN
42 Requires:   %{name} = %{version}-%{release}
43
44 %description debug
45 osp uix library (DEV)
46
47 %prep
48 %setup -q
49
50 %build 
51 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
52 %ifarch %{ix86}
53 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
54 %else
55 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
56 %endif
57
58 # Call make instruction with smp support
59 make %{?jobs:-j%jobs}
60
61 %install
62 rm -rf %{buildroot}
63 mkdir -p %{buildroot}/usr/share/license
64 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
65 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2 >> %{buildroot}/usr/share/license/%{name}
66 %make_install
67
68 %post -p /sbin/ldconfig
69
70 %postun -p /sbin/ldconfig
71
72 %files
73 %manifest osp-uix.manifest
74 /usr/share/license/%{name}
75 %{_libdir}/osp/*.so*
76
77 %files devel
78 %{_includedir}/osp/*.h
79 %{_libdir}/pkgconfig/osp-uix.pc
80
81 %files internal-devel
82 %{_includedir}/osp/uix/*.h
83
84 %files debug
85 %{_libdir}/osp/debug/*.so*