683c5bbc9d6e250f6d4d2a29c28b36e735ea992c
[platform/framework/native/uix.git] / packaging / osp-uix.spec
1 Name:           osp-uix
2 Version:        1.2.2.0
3 Release:        2
4 License:        Apache-2.0 or Flora
5 Summary:        OSP uix library
6 Group:          Graphics & UI Framework/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  osp-appfw-internal-devel
10 BuildRequires:  pkgconfig(capi-system-sensor)
11 BuildRequires:  pkgconfig(osp-appfw)
12 BuildRequires:  pkgconfig(sensor)
13
14 Requires:       osp-appfw
15
16 %description
17 osp uix library
18
19 %package devel
20 Summary:        OSP uix library (Development)
21 Requires:       %{name} = %{version}
22
23 %description devel
24 osp uix library (DEV)
25
26 %package internal-devel
27 Summary:        OSP uix library (Internal)
28 Requires:       %{name} = %{version}
29
30 %description internal-devel
31 osp uix library (Internal-DEV)
32
33 %prep
34 %setup -q
35
36 %build
37 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
38 %ifarch %{ix86}
39 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
40 %else
41 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
42 %endif
43 make %{?_smp_mflags}
44
45 %install
46 %make_install
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files
53 %manifest osp-uix.manifest
54 %license LICENSE.APLv2  LICENSE.Flora
55 %{_libdir}/osp/*.so*
56
57 %files devel
58 %{_includedir}/osp/*.h
59 %{_libdir}/pkgconfig/osp-uix.pc
60
61 %files internal-devel
62 %{_includedir}/osp/uix/*.h