443c9face15aed0cd74be173b5688de211f441cd
[platform/framework/native/uix.git] / packaging / osp-uix.spec
1 %define __strip /bin/true
2
3 Name:           osp-uix
4 Summary:        osp uix library
5 Version:        1.2.2.0
6 Release:        2
7 Group:          System/Libraries
8 License:        TO_BE/FILLED_IN
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(sensor)
12 BuildRequires:  pkgconfig(capi-system-sensor)
13 BuildRequires:  pkgconfig(osp-appfw)
14 BuildRequires:  osp-appfw-internal-devel
15
16 # runtime requires
17 Requires: osp-appfw 
18
19 %description
20 osp uix library
21
22 %package devel
23 Summary:    osp uix library (Development)
24 Group:      TO_BE/FILLED_IN
25 Requires:   %{name} = %{version}-%{release}
26
27 %description devel
28 osp uix library (DEV)
29
30 %package internal-devel
31 Summary:    osp uix library (Internal)
32 Group:      TO_BE/FILLED_IN
33 Requires:   %{name} = %{version}-%{release}
34
35 %description internal-devel
36 osp uix library (Internal-DEV)
37
38 %package debug
39 Summary:    osp uix library (Development)
40 Group:      TO_BE/FILLED_IN
41 Requires:   %{name} = %{version}-%{release}
42
43 %description debug
44 osp uix library (DEV)
45
46 %prep
47 %setup -q
48
49 %build 
50 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
51 %ifarch %{ix86}
52 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
53 %else
54 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
55 %endif
56
57 # Call make instruction with smp support
58 make %{?jobs:-j%jobs}
59
60 %install
61 rm -rf %{buildroot}
62 mkdir -p %{buildroot}/usr/share/license
63 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
64 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2 >> %{buildroot}/usr/share/license/%{name}
65 %make_install
66
67 %post -p /sbin/ldconfig
68
69 %postun -p /sbin/ldconfig
70
71 %files
72 %manifest osp-uix.manifest
73 /usr/share/license/%{name}
74 %{_libdir}/osp/*.so*
75
76 %files devel
77 %{_includedir}/osp/*.h
78 %{_libdir}/pkgconfig/osp-uix.pc
79
80 %files internal-devel
81 %{_includedir}/osp/uix/*.h
82
83 %files debug
84 %{_libdir}/osp/debug/*.so*