Remove the trust zone service
[framework/osp/security-service.git] / packaging / osp-security-service.spec
1 Name:           osp-security-service
2 Summary:        osp security service
3 Version:        1.2.2.0
4 Release:        1
5 Group:          TO_BE/FILLED_IN
6 License:        TO_BE/FILLED_IN
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(chromium)
10 BuildRequires:  pkgconfig(capi-system-media-key)
11 BuildRequires:  pkgconfig(capi-network-bluetooth)
12 BuildRequires:  pkgconfig(pkgmgr)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(osp-appfw)
15 BuildRequires:  osp-appfw-internal-devel
16 BuildRequires:  hash-signer
17
18 # smack domain requires
19 Requires(post): cert-svc
20
21 # runtime requires
22 Requires: osp-appfw 
23 Requires: osp-installer
24 Requires: osp-app-service
25 Requires: osp-channel-service
26 Requires: libcryptsvc
27
28 %description
29 osp security service
30
31 %prep
32 %setup -q
33
34 %build 
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %ifarch %{ix86}
37 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38 %else
39 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
40 %endif
41
42 # Call make instruction with smp support
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 mkdir -p %{buildroot}/usr/share/license
48 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
49
50 %make_install
51 ###### for package signing step ######
52 PKG_ID=q7097a278m
53 %define tizen_sign 1
54 %define tizen_sign_base /usr/apps/${PKG_ID}
55 %define tizen_sign_level public
56 %define tizen_author_sign 1
57 %define tizen_dist_sign 1
58
59 %post
60 /bin/rm -fr /opt/apps/q7097a278m
61 /usr/etc/package-manager/backend/tpk -i /usr/apps/q7097a278m
62
63 %files
64 %manifest osp-security-service.manifest
65 /usr/share/license/%{name}
66 /usr/apps/*
67 %dir %attr(0711, root, root) /opt/usr/share/certs
68 %dir %attr(0711, root, root) /opt/usr/share/certs/rootcert
69 %dir %attr(0755, root, root) /opt/usr/share/certs/usercert
70 %dir %attr(0755, root, root) /opt/usr/share/certs/usercert/key