merge with master
[framework/osp/ime.git] / packaging / osp-ime.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:       osp-ime
5 Summary:    The IME library of OSP 
6 Version:    1.2.1.0
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    TO BE FILLED IN
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(ecore)
14 BuildRequires:  pkgconfig(elementary)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(isf)
17 BuildRequires:  pkgconfig(libwbxml2)
18 BuildRequires:  pkgconfig(osp-appfw)
19 BuildRequires:  pkgconfig(pkgmgr)
20 BuildRequires:  osp-appfw-internal-devel
21 BuildRequires:  pkgconfig(osp-uifw)
22 BuildRequires:  osp-uifw-internal-devel
23 BuildRequires:  pkgconfig(libprivilege-control)
24 BuildRequires:  pkgconfig(xv)
25
26 # runtime requires
27 Requires: osp-appfw
28 Requires: osp-uifw
29
30 Provides:   libosp-ime.so.1 
31
32 Requires(post): /sbin/ldconfig  
33 Requires(postun): /sbin/ldconfig
34
35 %description
36 The IME library of OSP
37
38 %package devel
39 Summary:    The IME library of OSP (Development)
40 Group:      TO_BE/FILLED_IN
41 Requires:   %{name} = %{version}-%{release}
42
43 %description devel
44 The IME library of OSP (DEV)
45
46 %package debug
47 Summary:    The IME library of OSP (Development)
48 Group:      TO_BE/FILLED_IN
49 Requires:   %{name} = %{version}-%{release}
50
51 %description debug
52 The IME library of OSP (DEV)
53
54 %prep
55 %setup -q
56
57 %build
58 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
59 %ifarch %{ix86}
60 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=x86
61 %else
62 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=arm
63 %endif
64
65 # Call make instruction with smp support
66 make %{?jobs:-j%jobs}
67
68 %install
69 rm -rf %{buildroot}
70 mkdir -p %{buildroot}/usr/share/license
71 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2.0  %{buildroot}/usr/share/license/%{name}
72
73 %make_install
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %files
80 %manifest osp-ime.manifest
81 /usr/share/license/%{name}
82 %{_libdir}/osp/libosp-ime.so*
83
84 %files devel
85 %{_includedir}/osp/*.h
86 %{_libdir}/pkgconfig/osp-ime.pc
87
88 %files debug
89 %{_libdir}/osp/debug/*.so*
90