Merge commits Tizen 2.2 to Tizen 2.2.1
[platform/framework/native/face.git] / packaging / osp-face.spec
1 Name:           osp-face
2 Summary:        osp face library
3 Version:        1.2.1.0
4 Release:        2
5 Group:          System/Libraries
6 License:        TO_BE/FILLED_IN
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(face-engine)
10 BuildRequires:  pkgconfig(osp-appfw)
11 BuildRequires:  osp-appfw-internal-devel
12 BuildRequires:  pkgconfig(osp-uifw)
13 BuildRequires:  osp-uifw-internal-devel
14
15 Provides:       libface-engine-plugin.so
16
17 # runtime requires
18 Requires: face-engine
19 Requires: osp-appfw
20 Requires: osp-uifw
21
22 %description
23 osp face library
24
25 %package devel
26 Summary:    osp face library (Development)
27 Group:      TO_BE/FILLED_IN
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 osp face library (DEV)
32
33 %prep
34 %setup -q
35
36 %build
37 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
38
39 %ifarch %{ix86}
40 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
41 %else
42 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
43 %endif
44
45 # Call make instruction with smp support
46 make %{?jobs:-j%jobs}
47
48 %install
49 rm -rf %{buildroot}
50 mkdir -p %{buildroot}/usr/share/license
51 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
52 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2 >> %{buildroot}/usr/share/license/%{name}
53 %make_install
54
55 %post -p /sbin/ldconfig
56
57 %postun -p /sbin/ldconfig
58
59 %files
60 %manifest osp-face.manifest
61 /usr/share/license/%{name}
62 %{_libdir}/osp/*.so*
63
64 %files devel
65 %{_includedir}/osp/*.h
66 %{_libdir}/pkgconfig/osp-face.pc