Tizen 2.1 base
[platform/framework/native/content.git] / packaging / osp-content.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:           osp-content
5 Summary:        osp content library
6 Version:        1.2.0.0
7 Release:        2
8 Group:          System/Libraries
9 License:        Apache License, Version 2.0
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(alarm-service)
13 BuildRequires:  pkgconfig(chromium)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(capi-content-media-content)
16 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
17 BuildRequires:  pkgconfig(capi-content-mime-type)
18 BuildRequires:  pkgconfig(capi-web-url-download)
19 BuildRequires:  pkgconfig(osp-appfw)
20 BuildRequires:  osp-appfw-internal-devel
21 BuildRequires:  pkgconfig(osp-net)
22 BuildRequires:  osp-net-internal-devel
23 BuildRequires:  pkgconfig(osp-uifw)
24 BuildRequires:  osp-uifw-internal-devel
25 BuildRequires:  pkgconfig(osp-media)
26 BuildRequires:  osp-media-internal-devel
27 BuildRequires:  pkgconfig(osp-image-core)
28 BuildRequires:  osp-image-core-internal-devel
29 BuildRequires:  pkgconfig(osp-image)
30 BuildRequires:  osp-image-internal-devel
31 BuildRequires:  pkgconfig(osp-locations)
32 BuildRequires:  libexif-devel
33 BuildRequires:  libcurl-devel
34 BuildRequires:  openssl-devel
35
36 # runtime requires
37 Requires: osp-appfw 
38 Requires: osp-net
39 Requires: osp-image
40 Requires: osp-media
41 Requires: osp-uifw
42 Requires: osp-locations
43 Requires: capi-web-url-download
44
45 Requires(post): /sbin/ldconfig
46 Requires(post): coreutils
47 Requires(postun): /sbin/ldconfig
48
49 %description
50 osp content library
51
52 %package devel
53 Summary:    osp content library (Development)
54 Group:      TO_BE/FILLED_IN
55 Requires:   %{name} = %{version}-%{release}
56
57 %description devel
58 osp content library (DEV)
59
60 %package internal-devel
61 Summary:    osp content library (Internal)
62 Group:      TO_BE/FILLED_IN
63 Requires:   %{name} = %{version}-%{release}
64
65 %description internal-devel
66 osp content library (Internal-DEV)
67
68 %package debug
69 Summary:    osp content library (Development)
70 Group:      TO_BE/FILLED_IN
71 Requires:   %{name} = %{version}-%{release}
72
73 %description debug
74 osp content library (DEV)
75
76 %prep
77 %setup -q
78
79 %build 
80 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
81 %ifarch %{ix86}
82 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
83 %else
84 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
85 %endif
86
87 # Call make instruction with smp support
88 make %{?jobs:-j%jobs}
89
90 %install
91 rm -rf %{buildroot}
92 mkdir -p %{buildroot}/usr/share/license
93 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
94
95 %make_install
96
97 %post -p /sbin/ldconfig
98
99 %postun -p /sbin/ldconfig
100
101 %files
102 %manifest osp-content.manifest
103 /usr/share/license/%{name}
104 %{_libdir}/osp/*.so*
105
106 %files devel
107 %{_includedir}/osp/*.h
108 %{_libdir}/pkgconfig/osp-content.pc
109
110 %files internal-devel
111 %{_includedir}/osp/content/*.h
112
113 %files debug
114 %{_libdir}/osp/debug/*.so*