sync with master
[framework/osp/common-service.git] / packaging / osp-common-service.spec
1 Name: osp-common-service
2 Summary:        osp common service
3 Version:        1.2.1.0
4 Release:        1
5 Group:          System/Libraries
6 License:        Apache License, Version 2.0 or Flora
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(chromium)
11 BuildRequires:  pkgconfig(capi-appfw-package-manager)
12 BuildRequires:  pkgconfig(pkgmgr)
13 BuildRequires:  pkgconfig(osp-appfw)
14 BuildRequires:  pkgconfig(osp-uifw)
15 BuildRequires:  osp-appfw-internal-devel
16 BuildRequires:  osp-uifw-internal-devel
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(x11)
19 BuildRequires:  pkgconfig(utilX)
20
21 # runtime requires
22 Requires: chromium
23 Requires: osp-appfw
24
25 %description
26 osp common service
27
28 %prep
29 %setup -q
30
31 %build 
32 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
33 %ifarch %{ix86}
34 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
35 %else
36 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
37 %endif
38
39 # Call make instruction with smp support
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 mkdir -p %{buildroot}/usr/share/license
45 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
46
47 %make_install
48
49 %post
50 /usr/etc/package-manager/backend/tpk -i /opt/apps/sjjevolsjk
51
52 %files
53 /opt/apps/sjjevolsjk/*
54 %manifest osp-common-service.manifest
55 /usr/share/license/%{name}
56
57