Add to sign the package
[framework/osp/common-service.git] / packaging / osp-common-service.spec
1 Name: osp-common-service
2 Summary:        osp common service
3 Version:        1.2.2.0
4 Release:        1
5 Group:          System/Libraries
6 License:        Apache License, Version 2.0 or Flora
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(chromium)
11 BuildRequires:  pkgconfig(capi-appfw-package-manager)
12 BuildRequires:  pkgconfig(pkgmgr)
13 BuildRequires:  pkgconfig(osp-appfw)
14 BuildRequires:  pkgconfig(osp-uifw)
15 BuildRequires:  osp-appfw-internal-devel
16 BuildRequires:  osp-uifw-internal-devel
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(x11)
19 BuildRequires:  pkgconfig(utilX)
20 BuildRequires:  hash-signer
21
22 # runtime requires
23 Requires: chromium
24 Requires: osp-appfw
25
26 %description
27 osp common service
28
29 %prep
30 %setup -q
31
32 %build 
33 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
34 %ifarch %{ix86}
35 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
36 %else
37 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38 %endif
39
40 # Call make instruction with smp support
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 mkdir -p %{buildroot}/usr/share/license
46 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
47
48 %make_install
49 %define tizen_sign 1
50 %define tizen_sign_base /usr/apps/sjjevolsjk
51 %define tizen_sign_level public
52 %define tizen_author_sign 1
53 %define tizen_dist_sign 1
54
55 %post
56 /bin/rm -fr /opt/apps/sjjevolsjk
57 /usr/etc/package-manager/backend/tpk -i /usr/apps/sjjevolsjk
58
59 %files
60 /usr/apps/sjjevolsjk/*
61 %manifest osp-common-service.manifest
62 /usr/share/license/%{name}
63
64